]> git.pld-linux.org Git - packages/parallel.git/blob - parallel.spec
package env_parallel
[packages/parallel.git] / parallel.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Shell tool for executing jobs in parallel
3 Name:           parallel
4 Version:        20181122
5 Release:        1
6 License:        GPL v3+
7 Group:          Applications/System
8 Source0:        https://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
9 # Source0-md5:  2b0d799aef98e0684ac6dc4868d880fe
10 URL:            https://www.gnu.org/software/parallel/
11 BuildRequires:  perl-tools-pod
12 BuildRequires:  rpm-perlprov
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GNU Parallel is a shell tool for executing jobs in parallel using one
18 or more machines. A job is typically a single command or a small
19 script that has to be run for each of the lines in the input. The
20 typical input is a list of files, a list of hosts, a list of users, or
21 a list of tables.
22
23 If you use xargs today you will find GNU Parallel very easy to use. If
24 you write loops in shell, you will find GNU Parallel may be able to
25 replace most of the loops and make them run faster by running jobs in
26 parallel. If you use ppss or pexec you will find GNU Parallel will
27 often make the command easier to read.
28
29 GNU Parallel also makes sure output from the commands is the same
30 output as you would get had you run the commands sequentially. This
31 makes it possible to use output from GNU Parallel as input for other
32 programs.
33
34 GNU Parallel is command-line-compatible with moreutils' parallel, but
35 offers additional features.
36
37 %package -n env_parallel
38 Summary:        env_parallel
39 Group:          Applications/System
40 Requires:       %{name} = %{version}-%{release}
41
42 %description -n env_parallel
43 env_parallel is a shell function that exports the current environment
44 to GNU parallel.
45
46 %prep
47 %setup -q
48
49 %build
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 mv $RPM_BUILD_ROOT%{_mandir}/man1/{sql,parallel-sql}.1
60 touch $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
61 rm -rv $RPM_BUILD_ROOT%{_docdir}/parallel
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README NEWS
69 %doc src/parallel.html src/sem.html src/sql.html src/niceload.html
70 %doc src/*.texi
71 %dir %{_sysconfdir}/parallel
72 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
73 %attr(755,root,root) %{_bindir}/niceload
74 %attr(755,root,root) %{_bindir}/parallel
75 %attr(755,root,root) %{_bindir}/parcat
76 %attr(755,root,root) %{_bindir}/parset
77 %attr(755,root,root) %{_bindir}/sem
78 %attr(755,root,root) %{_bindir}/sql
79 %{_mandir}/man1/niceload.1*
80 %{_mandir}/man1/parallel.1*
81 %{_mandir}/man1/parallel-sql.1*
82 %{_mandir}/man1/parcat.1*
83 %{_mandir}/man1/parset.1*
84 %{_mandir}/man1/sem.1*
85 %{_mandir}/man7/parallel_alternatives.7*
86 %{_mandir}/man7/parallel_book.7*
87 %{_mandir}/man7/parallel_design.7*
88 %{_mandir}/man7/parallel_tutorial.7*
89
90 %files -n env_parallel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/env_parallel
93 %attr(755,root,root) %{_bindir}/env_parallel.ash
94 %attr(755,root,root) %{_bindir}/env_parallel.bash
95 %attr(755,root,root) %{_bindir}/env_parallel.csh
96 %attr(755,root,root) %{_bindir}/env_parallel.dash
97 %attr(755,root,root) %{_bindir}/env_parallel.fish
98 %attr(755,root,root) %{_bindir}/env_parallel.ksh
99 %attr(755,root,root) %{_bindir}/env_parallel.mksh
100 %attr(755,root,root) %{_bindir}/env_parallel.pdksh
101 %attr(755,root,root) %{_bindir}/env_parallel.sh
102 %attr(755,root,root) %{_bindir}/env_parallel.tcsh
103 %attr(755,root,root) %{_bindir}/env_parallel.zsh
104 %{_mandir}/man1/env_parallel.1*
This page took 0.075954 seconds and 4 git commands to generate.