]> git.pld-linux.org Git - SPECS.git/blob - parallel.spec
SPECS updated Thu 20 Jun 07:54:00 CEST 2024
[SPECS.git] / parallel.spec
1 Summary:        Shell tool for executing jobs in parallel
2 Summary(pl.UTF-8):      Narzędzie powłoki do równoległego uruchamiania zadań
3 Name:           parallel
4 Version:        20231222
5 Release:        1
6 License:        GPL v3+
7 Group:          Applications/System
8 Source0:        https://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
9 # Source0-md5:  c302f3c311497977b9f62603eeccfabb
10 URL:            https://www.gnu.org/software/parallel/
11 BuildRequires:  perl-tools-pod
12 BuildRequires:  rpm-perlprov
13 BuildRequires:  rpmbuild(macros) >= 1.745
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 GNU Parallel is a shell tool for executing jobs in parallel using one
19 or more machines. A job is typically a single command or a small
20 script that has to be run for each of the lines in the input. The
21 typical input is a list of files, a list of hosts, a list of users, or
22 a list of tables.
23
24 If you use xargs today you will find GNU Parallel very easy to use. If
25 you write loops in shell, you will find GNU Parallel may be able to
26 replace most of the loops and make them run faster by running jobs in
27 parallel. If you use ppss or pexec you will find GNU Parallel will
28 often make the command easier to read.
29
30 GNU Parallel also makes sure output from the commands is the same
31 output as you would get had you run the commands sequentially. This
32 makes it possible to use output from GNU Parallel as input for other
33 programs.
34
35 GNU Parallel is command-line-compatible with moreutils' parallel, but
36 offers additional features.
37
38 %description -l pl.UTF-8
39 GNU Parallel to narzędzie powłoki do równoległego uruchamiania zadań
40 przy użyciu jednej lub większej liczby maszyn. Zadanie to zwykle
41 pojedyncze polecenie lub mały skrypt, który ma być uruchomiony dla
42 każdego wiersza z wejścia. Zwykle wejściem jest lista plików, lista
43 hostów, lista użytkowników lub lista tabel.
44
45 Korzystający dotychczas z xargs uznają GNU Parallel za bardzo łatwe w
46 użyciu. Piszący pętle w języku powłoki zauważą, że GNU Parallel może
47 zastąpić większość pętli i przyspieszyć je poprzez uruchamianie zadań
48 równolegle. Użytkownicy programów ppss lub pexec zwykle uznają, że
49 GNU Parallel czyni polecenia bardziej czytelnymi.
50
51 GNU Parallel zapewnia dodatkowo, że wyjście poleceń jest takie samo,
52 jak przy sekwencyjnym uruchamianiu poleceń. Pozwala to wykorzystywać
53 wyjście z GNU Parallel jako wejście dla innych programów.
54
55 GNU Parallel jest zgodny co do wiersza poleceń z narzędziem parallel z
56 moreutils, ale oferuje dodatkowe możliwości.
57
58 %package -n env_parallel
59 Summary:        env_parallel shell function
60 Summary(pl.UTF-8):      Funkca powłoki env_parallel
61 Group:          Applications/System
62 Requires:       %{name} = %{version}-%{release}
63
64 %description -n env_parallel
65 env_parallel is a shell function that exports the current environment
66 to GNU Parallel.
67
68 %description -n env_parallel -l pl.UTF-8
69 env_parallel to funkcja powłoki eksportująca bieżące środowisko do
70 GNU Parallel.
71
72 %package -n bash-completion-parallel
73 Summary:        Bash completion for parallel commands
74 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń parallel
75 Group:          Applications/Shells
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       bash-completion >= 1:2.0
78
79 %description -n bash-completion-parallel
80 Bash completion for parallel commands.
81
82 %description -n bash-completion-parallel -l pl.UTF-8
83 Bashowe uzupełnianie poleceń parallel.
84
85 %package -n zsh-completion-parallel
86 Summary:        Zsh completion for parallel commands
87 Summary(pl.UTF-8):      Uzupełnianie poleceń parallel w Zsh
88 Group:          Applications/Shells
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       zsh
91
92 %description -n zsh-completion-parallel
93 Zsh completion for parallel commands.
94
95 %description -n zsh-completion-parallel -l pl.UTF-8
96 Uzupełnianie poleceń parallel w Zsh.
97
98 %prep
99 %setup -q
100
101 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' src/{parallel,sem}
102 %{__sed} -i -e '1{\@^#!@d}' src/env_parallel.*
103 %{__sed} -i -e '1s,^#!/usr/bin/env ,#!/bin/,' src/env_* src/parset
104
105 %build
106 %configure
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{sql,parallel-sql}.1
117 touch $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
118 %{__rm} -rv $RPM_BUILD_ROOT%{_docdir}/parallel
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc CITATION CREDITS NEWS README
126 %dir %{_sysconfdir}/parallel
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
128 %attr(755,root,root) %{_bindir}/niceload
129 %attr(755,root,root) %{_bindir}/parallel
130 %attr(755,root,root) %{_bindir}/parcat
131 %attr(755,root,root) %{_bindir}/parset
132 %attr(755,root,root) %{_bindir}/parsort
133 %attr(755,root,root) %{_bindir}/sem
134 %attr(755,root,root) %{_bindir}/sql
135 %{_mandir}/man1/niceload.1*
136 %{_mandir}/man1/parallel.1*
137 %{_mandir}/man1/parallel-sql.1*
138 %{_mandir}/man1/parcat.1*
139 %{_mandir}/man1/parset.1*
140 %{_mandir}/man1/parsort.1*
141 %{_mandir}/man1/sem.1*
142 %{_mandir}/man7/parallel_alternatives.7*
143 %{_mandir}/man7/parallel_book.7*
144 %{_mandir}/man7/parallel_design.7*
145 %{_mandir}/man7/parallel_examples.7*
146 %{_mandir}/man7/parallel_tutorial.7*
147
148 %files -n env_parallel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/env_parallel
151 %attr(755,root,root) %{_bindir}/env_parallel.ash
152 %attr(755,root,root) %{_bindir}/env_parallel.bash
153 %attr(755,root,root) %{_bindir}/env_parallel.csh
154 %attr(755,root,root) %{_bindir}/env_parallel.dash
155 %attr(755,root,root) %{_bindir}/env_parallel.fish
156 %attr(755,root,root) %{_bindir}/env_parallel.ksh
157 %attr(755,root,root) %{_bindir}/env_parallel.mksh
158 %attr(755,root,root) %{_bindir}/env_parallel.pdksh
159 %attr(755,root,root) %{_bindir}/env_parallel.sh
160 %attr(755,root,root) %{_bindir}/env_parallel.tcsh
161 %attr(755,root,root) %{_bindir}/env_parallel.zsh
162 %{_mandir}/man1/env_parallel.1*
163
164 %files -n bash-completion-parallel
165 %defattr(644,root,root,755)
166 %{bash_compdir}/parallel
167
168 %files -n zsh-completion-parallel
169 %defattr(644,root,root,755)
170 %{zsh_compdir}/_parallel
This page took 0.151847 seconds and 4 git commands to generate.