]> git.pld-linux.org Git - packages/parallel.git/blob - parallel.spec
pld fixes
[packages/parallel.git] / parallel.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Shell tool for executing jobs in parallel
3 Name:           parallel
4 Version:        20131222
5 Release:        1
6 License:        GPL v3+
7 Group:          Applications/System
8 Source0:        http://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
9 # Source0-md5:  782e594b226454ef58ac4e3d4addaba4
10 URL:            http://www.gnu.org/software/parallel/
11 BuildRequires:  perl-tools-pod
12 BuildRequires:  rpm-perlprov
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GNU Parallel is a shell tool for executing jobs in parallel using one
18 or more machines. A job is typically a single command or a small
19 script that has to be run for each of the lines in the input. The
20 typical input is a list of files, a list of hosts, a list of users, or
21 a list of tables.
22
23 If you use xargs today you will find GNU Parallel very easy to use. If
24 you write loops in shell, you will find GNU Parallel may be able to
25 replace most of the loops and make them run faster by running jobs in
26 parallel. If you use ppss or pexec you will find GNU Parallel will
27 often make the command easier to read.
28
29 GNU Parallel also makes sure output from the commands is the same
30 output as you would get had you run the commands sequentially. This
31 makes it possible to use output from GNU Parallel as input for other
32 programs.
33
34 GNU Parallel is command-line-compatible with moreutils' parallel, but
35 offers additional features.
36
37 %prep
38 %setup -q
39
40 %build
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 mv $RPM_BUILD_ROOT%{_mandir}/man1/{sql,parallel-sql}.1
51 :> $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
52 rm -rv $RPM_BUILD_ROOT%{_docdir}/parallel
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README NEWS
60 %doc src/parallel.html src/sem.html src/sql.html src/niceload.html
61 %doc src/*.texi
62 %dir %{_sysconfdir}/parallel
63 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
64 %attr(755,root,root) %{_bindir}/parallel
65 %attr(755,root,root) %{_bindir}/sem
66 %attr(755,root,root) %{_bindir}/sql
67 %attr(755,root,root) %{_bindir}/niceload
68 %{_mandir}/man1/niceload.1*
69 %{_mandir}/man1/parallel.1*
70 %{_mandir}/man1/sem.1*
71 %{_mandir}/man1/parallel-sql.1*
72 %{_mandir}/man1/parallel_tutorial.1*
This page took 0.052893 seconds and 4 git commands to generate.