]> git.pld-linux.org Git - packages/parallel.git/blob - parallel.spec
- initial
[packages/parallel.git] / parallel.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Shell tool for executing jobs in parallel
3 Name:           parallel
4 Version:        20131222
5 Release:        1
6 License:        GPL v3+
7 Group:          X11/Applications
8 URL:            http://www.gnu.org/software/parallel/
9 Source0:        http://ftp.gnu.org/gnu/parallel/%{name}-%{version}.tar.bz2
10 # Source0-md5:  782e594b226454ef58ac4e3d4addaba4
11 BuildRequires:  perl-tools-pod
12 BuildRequires:  rpm-perlprov
13 BuildArch:      noarch
14
15 %description
16 GNU Parallel is a shell tool for executing jobs in parallel using one
17 or more machines. A job is typically a single command or a small
18 script that has to be run for each of the lines in the input. The
19 typical input is a list of files, a list of hosts, a list of users, or
20 a list of tables.
21
22 If you use xargs today you will find GNU Parallel very easy to use. If
23 you write loops in shell, you will find GNU Parallel may be able to
24 replace most of the loops and make them run faster by running jobs in
25 parallel. If you use ppss or pexec you will find GNU Parallel will
26 often make the command easier to read.
27
28 GNU Parallel also makes sure output from the commands is the same
29 output as you would get had you run the commands sequentially. This
30 makes it possible to use output from GNU Parallel as input for other
31 programs.
32
33 GNU Parallel is command-line-compatible with moreutils' parallel, but
34 offers additional features.
35
36 %prep
37
38 %setup -q
39
40 %build
41 %configure
42 %{__make}
43
44 %install
45
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 find $RPM_BUILD_ROOT -iname "*.html" -delete
51 find $RPM_BUILD_ROOT -iname "*.texi" -delete
52 find $RPM_BUILD_ROOT -iname "*.pod" -delete
53
54 mv $RPM_BUILD_ROOT%{_mandir}/man1/sql.1 $RPM_BUILD_ROOT%{_mandir}/man1/parallel-sql.1
55
56 install -d $RPM_BUILD_ROOT%{_sysconfdir}/parallel
57 :> $RPM_BUILD_ROOT%{_sysconfdir}/parallel/config
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README NEWS COPYING src/parallel.html src/sem.html src/sql.html
65 %doc src/niceload.html src/*.texi
66 %attr(755,root,root) %{_bindir}/parallel
67 %attr(755,root,root) %{_bindir}/sem
68 %attr(755,root,root) %{_bindir}/sql
69 %attr(755,root,root) %{_bindir}/niceload
70 %dir %{_sysconfdir}/parallel/
71 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/parallel/config
72 %{_mandir}/man1/niceload.1.*
73 %{_mandir}/man1/parallel.1.*
74 %{_mandir}/man1/sem.1.*
75 %{_mandir}/man1/parallel-sql.1.*
This page took 0.106603 seconds and 4 git commands to generate.