]> git.pld-linux.org Git - SPECS.git/blob - pangopdf.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / pangopdf.spec
1 #
2 # Conditional build:
3 %bcond_with     gnomeprint      # build GNOME Print (pangogp) backend
4                                 # (broken: libgnomeprint is linked with newer pango)
5 %bcond_without  qt              # don't build Qt-based viewer
6 #
7 Summary:        Pango PDF backend
8 Summary(pl.UTF-8):      Backend PDF dla Pango
9 Name:           pangopdf
10 Version:        1.2.3.7
11 Release:        2
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/pangopdf/%{name}-%{version}.tar.gz
15 # Source0-md5:  e0671aeaba45e0aa5a2c1aba8cebba41
16 URL:            http://pangopdf.sourceforge.net/
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  freetype-devel >= 2.0.9
21 BuildRequires:  fontconfig-devel >= 1:1.0.1
22 BuildRequires:  glib2-devel >= 2.1.3
23 BuildRequires:  gtk-doc >= 0.10
24 %{?with_gnomeprint:BuildRequires:       libgnomeprint-devel >= 2.2}
25 %{?with_qt:BuildRequires:       libstdc++-devel}
26 BuildRequires:  libtool >= 2:1.5
27 BuildRequires:  pdflib-devel >= 4.0.0
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig
30 %{?with_qt:BuildRequires:       qt-devel}
31 BuildRequires:  xft-devel >= 2.0.0
32 Requires:       glib2-devel >= 2.1.3
33 Requires:       fontconfig >= 1:1.0.1
34 Requires:       freetype >= 2.0.9
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoprov     libpango-1.0.so.0 libpangoft2-1.0.so.0 libpangox-1.0.so.0 libpangoxft-1.0.so.0
38
39 %description
40 PangoPDF implements a version of the Pango (http://www.pango.org/)
41 library with a PDF backend for creating PDF output. This library also
42 implements several of the inline properties defined by XSL
43 (http://www.w3.org/TR/xsl/) that are not currently implemented by
44 Pango.
45
46 %description -l pl.UTF-8
47 PangoPDF to implementacja wersji biblioteki Pango
48 (http://www.pango.org/) z backendem PDF do tworzenia wyjścia w PDF. Ta
49 biblioteka ma zaimplementowanych także trochę własności inline
50 zdefiniowanych przez XSL (http://www.w3.org/TR/xsl/), które aktualnie
51 nie są zaimplementowane w Pango.
52
53 %package devel
54 Summary:        Header files for Pango PDF backend
55 Summary(pl.UTF-8):      Pliki nagłówkowe dla backendu PDF dla Pango
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 PangoPDF implements a version of the Pango (http://www.pango.org/)
61 library with a PDF backend for creating PDF output. This library also
62 implements several of the inline properties defined by XSL
63 (http://www.w3.org/TR/xsl/) that are not currently implemented by
64 Pango.
65
66 This package contains the header files needed to develop programs that
67 use these pangopdf.
68
69 %description devel -l pl.UTF-8
70 PangoPDF to implementacja wersji biblioteki Pango
71 (http://www.pango.org/) z backendem PDF do tworzenia wyjścia w PDF. Ta
72 biblioteka ma zaimplementowanych także trochę własności inline
73 zdefiniowanych przez XSL (http://www.w3.org/TR/xsl/), które aktualnie
74 nie są zaimplementowane w Pango.
75
76 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
77 używających bibliotek pangopdf.
78
79 %package viewer
80 Summary:        pangopdf and Qt based UTF-8 file viewer
81 Summary(pl.UTF-8):      Przeglądarka plików UTF-8 oparta na pangopdf i Qt
82 Group:          X11/Applications
83 Requires:       %{name} = %{version}-%{release}
84
85 %description viewer
86 Example program to view a UTF-8 encoding file using Pango to render
87 result.
88
89 %description viewer -l pl.UTF-8
90 Przykładowy program do oglądania plików w kodowaniu UTF-8 przy użyciu
91 Pango do wyświetlania wyników.
92
93 %prep
94 %setup -q
95
96 sed -i -e 's,QTDIR/lib ,QTDIR/%{_lib} ,;s,QTDIR/include,QTDIR/include/qt,;s/-lqt/-lqt-mt/' \
97         configure.in
98 sed -i -e 's,QTDIR)/lib ,QTDIR)/%{_lib} ,;s,QTDIR)/include,QTDIR)/include/qt,;s/-lqt/-lqt-mt/' \
99         examples/Makefile.am
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__automake}
106 %configure \
107         %{!?with_gnomeprint:--disable-gp} \
108         --enable-pdflib \
109         --with-html-dir=%{_gtkdocdir} \
110         --with-x \
111         --with%{!?with_qt:out}-qt%{?with_qt:=/usr}
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         pkgconfigdir=%{_pkgconfigdir}
121
122 rm -f $RPM_BUILD_ROOT%{_libdir}/pangopdf/pango/1.2.0/modules/*.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS* ChangeLog* NEWS* README* TODO
130 %attr(755,root,root) %{_bindir}/pangopdf-querymodules
131 %dir %{_sysconfdir}/pangopdf
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pangopdf/pangox.aliases
133 %dir %{_libdir}/pangopdf
134 %attr(755,root,root) %{_libdir}/pangopdf/lib*.so.*
135 %dir %{_libdir}/pangopdf/pango
136 %dir %{_libdir}/pangopdf/pango/1.2.0
137 %dir %{_libdir}/pangopdf/pango/1.2.0/modules
138 %attr(755,root,root) %{_libdir}/pangopdf/pango/1.2.0/modules/*.so
139 %{_datadir}/pangopdf
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/pangopdf/*.so
144 %{_libdir}/pangopdf/*.la
145 %{_pkgconfigdir}/*.pc
146 %{_includedir}/pangopdf
147 %{_gtkdocdir}/pangopdf
148
149 %if %{with qt}
150 %files viewer
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/pango-viewer
153 %endif
This page took 0.251228 seconds and 3 git commands to generate.