]> git.pld-linux.org Git - SPECS.git/blob - pam-pam_bioapi.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / pam-pam_bioapi.spec
1 # TODO:
2 # - wrong (and unnecessary) pam modules paths in pam.d files
3 # - wrong (not lib64-aware) libbirdb_sqlite3 path in birdb.conf
4 #   (maybe this module should be moved to /usr/%{_lib} as it uses libsqlite3 from /usr?)
5 %define         modulename pam_bioapi
6 Summary:        PAM BioAPI module
7 Summary(pl.UTF-8):      Moduł PAM BioAPI
8 Name:           pam-%{modulename}
9 Version:        0.4.0
10 Release:        0.2
11 Epoch:          0
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        http://pam-bioapi.googlecode.com/files/%{modulename}-%{version}.tar.gz
15 # Source0-md5:  0896c6549be3720d358b1e8507c36a4d
16 URL:            http://www.qrivy.net/~michael/blua/
17 BuildRequires:  bioapi-devel
18 BuildRequires:  pam-devel
19 BuildRequires:  sqlite3-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Provides a PAM-compliant interface to use in biometrically
24 authenticating local users.
25
26 %description -l pl.UTF-8
27 Ten pakiet udostępnia zgody z PAM-em interfejs do biometrycznego
28 uwierzytelniania użytkowników lokalnych.
29
30 %prep
31 %setup -q -n %{modulename}-%{version}
32
33 %build
34 CPPFLAGS="-I%{_includedir}/bioapi"
35 # 1. We need to set prefix to empty string to have proper config files generated.
36 # 2. libdir is set to /lib to allow pam to find modules in /lib/security.
37 #    However, this package requires sqlite3, which is located under /usr.
38 %configure \
39         --prefix='' \
40         --libdir=/%{_lib}
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bioapi/pam
50
51 rm $RPM_BUILD_ROOT/%{_lib}/*.la $RPM_BUILD_ROOT/%{_lib}/security/*.la
52
53 %find_lang tfmessbsp
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files -f tfmessbsp.lang
62 %defattr(644,root,root,755)
63 %doc AUTHORS ChangeLog NEWS README
64 %attr(755,root,root) %{_bindir}/birdbtest
65 %attr(755,root,root) %{_bindir}/test_enroll-pam_bioapi
66 %attr(755,root,root) %{_bindir}/test_verify-pam_bioapi
67 # suid?
68 %attr(755,root,root) %{_sbindir}/bioapi_chbird
69 # -avoid-version is missing for this module
70 %attr(755,root,root) /%{_lib}/security/pam_bioapi.so*
71 %attr(755,root,root) /%{_lib}/libbirdb.so.*.*.*
72 %attr(755,root,root) %ghost /%{_lib}/libbirdb.so.0
73 # -avoid-version is missing for this module
74 %attr(755,root,root) /%{_lib}/libbirdb_sqlite3.so.*.*.*
75 %attr(755,root,root) %ghost /%{_lib}/libbirdb_sqlite3.so.0
76 %attr(755,root,root) /%{_lib}/libbirdb_sqlite3.so
77 %dir %{_sysconfdir}/bioapi
78 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bioapi/birdb.conf
79 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/bioapi_chbird
80 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/test-pam_bioapi
81 %{_mandir}/man8/pam_bioapi.8*
This page took 2.468153 seconds and 3 git commands to generate.