]> git.pld-linux.org Git - SPECS.git/blob - otcl.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / otcl.spec
1 Summary:        Extension to Tcl/Tk for object-oriented programming
2 Summary(pl.UTF-8):      Rozszerzenie Tcl/Tk do programowania zorientowanego obiektowo
3 Name:           otcl
4 Version:        1.11
5 Release:        1
6 License:        MIT
7 Group:          Development/Languages/Tcl
8 Source0:        http://dl.sourceforge.net/otcl-tclcl/%{name}-%{version}.tar.gz
9 # Source0-md5:  2aec90ffa9370596dc02048ba1e8b468
10 Patch0:         tcl-lib.patch
11 URL:            http://otcl-tclcl.sourceforge.net/otcl/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  tcl-devel >= 8.4
15 BuildRequires:  tk-devel >= 8.4
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 OTcl, short for MIT Object Tcl, is an extension to Tcl/Tk for
20 object-oriented programming.
21
22 Some of OTcl's features as compared to alternatives are:
23
24  * designed to be dynamically extensible, like Tcl, from the ground up
25  * builds on Tcl syntax and concepts rather than importing another
26    language
27  * compact yet powerful object programming system (draws on CLOS,
28    Smalltalk, and Self)
29  * fairly portable implementation (2000 lines of C, without core
30    hacks)
31
32 %description -l pl.UTF-8
33 OTcl, skrót od Obiektowego Tcl MIT, jest rozszerzeniem Tcl/Tk do
34 programowania zorientowanego obiektowo.
35
36 Pewne z cech OTcl-a w porównaniu do alternatywnych:
37
38  * zaprojektowany by być dynamicznie rozszerzalnym, jak Tcl, od zera
39  * oparty na składni i koncepcie Tcl zamiast importowania innego
40    języka
41  * kompaktowy acz potężny system programowania obiektowego (CLOS,
42    Smalltalk oraz Self)
43  * raczej przenośna implementacja (2000 linii C bez niskopoziomowych
44    wstawek)
45
46 %package devel
47 Summary:        OTcl header file
48 Summary(pl.UTF-8):      Plik nagłówkowy OTcl
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Obsoletes:      otcl-static
52
53 %description devel
54 OTcl header file.
55
56 %description devel -l pl.UTF-8
57 Plik nagłówkowy OTcl.
58
59 %package static
60 Summary:        OTcl static library
61 Summary(pl.UTF-8):      Biblioteka statyczna OTcl
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 OTcl static library.
67
68 %description static -l pl.UTF-8
69 Biblioteka statyczna OTcl.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 cp -f /usr/share/automake/config.sub .
77 %{__autoconf}
78 %configure \
79         --with-tcl-ver=8.4 \
80         --with-tk-ver=8.4
81 %{__make} 
82 # and make again for shared library
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
88
89 install o*sh $RPM_BUILD_ROOT%{_bindir}
90 install *.h $RPM_BUILD_ROOT%{_includedir}
91 install libotcl.* $RPM_BUILD_ROOT%{_libdir}
92
93 rm -f doc/CHANGES.html
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc {CHANGES,README}.html doc/*
104 %attr(755,root,root) %{_bindir}/*
105 %attr(755,root,root) %{_libdir}/*.so
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_includedir}/*
110 %{_libdir}/*.a
111
112 #%files static
113 #%defattr(644,root,root,755)
This page took 1.355077 seconds and 3 git commands to generate.