]> git.pld-linux.org Git - SPECS.git/blob - oslec.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / oslec.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel             # allow non-distribution kernel
4 #
5 %define         rel     1
6 Summary:        Open Source Line Echo Canceller (OSLEC)
7 Summary(pl.UTF-8):      Open Source Line Echo Canceller (OSLEC) - usuwanie echa
8 Name:           oslec
9 Version:        0.2
10 Release:        %{rel}
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:         http://www.rowetel.com/ucasterisk/downloads/%{name}-%{version}.tar.gz
14 # Source0-md5:  554a0d44d2b4bac27ca1cc29fc55f69b
15 Patch0:         %{name}-build.patch
16 URL:            http://www.rowetel.com/ucasterisk/oslec.html
17 %if %{with dist_kernel}
18 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.20.2
19 %endif
20 BuildRequires:  rpmbuild(macros) >= 1.379
21 Requires:       dialog
22 # build broken (ppc, sparc) or nothing built (alpha)
23 ExcludeArch:    ppc sparc alpha
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Oslec is an open source high performance line echo canceller. It works
28 well on lines where the built-in Zaptel echo canceller fails. No
29 tweaks like rxgain/txgain or fxotrain are required. Oslec is supplied
30 as GPL licensed C source code and is free as in speech.
31
32 %description -l pl.UTF-8
33 Oslec to mający otwarte źródła i wysoką wydajność moduł do usuwania
34 echa z linii. Działa dobrze na liniach, na których zawodzi wbudowane
35 narzędzie Zaptela do usuwania echa. Nie są wymagane sztuczki typu
36 rxgain/txgain czy fxotrain. Oslec jest wolnodostępny, rozpowszechniany
37 na licencji GPL z kodem źródłowym w C.
38
39 %package -n kernel%{_alt_kernel}-misc-oslec
40 Summary:        oslec - Linux kernel module
41 Summary(pl.UTF-8):      oslec - moduł jądra Linuksa
42 Release:        %{rel}@%{_kernel_ver_str}
43 Group:          Base/Kernel
44 %{?with_dist_kernel:%requires_releq_kernel}
45 License:        GPL v2
46 Requires(post,postun):  /sbin/depmod
47 Requires:       module-init-tools >= 3.2.2-2
48
49 %description -n kernel%{_alt_kernel}-misc-oslec
50 oslec - Linux kernel module.
51
52 %description -n kernel%{_alt_kernel}-misc-oslec -l pl.UTF-8
53 oslec - moduł jądra Linuksa.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 sed -i "s|#include <echo.h>|#include <$PWD/spandsp-0.0.3/src/spandsp/echo.h>|" kernel/oslec_wrap.c
60
61 %build
62 %build_kernel_modules -C kernel -m oslec
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 install -D kernel/oslec-ctrl-panel.sh $RPM_BUILD_ROOT%{_sbindir}/oslec-ctrl-panel.sh
68
69 %install_kernel_modules -m kernel/oslec -d misc
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -n kernel%{_alt_kernel}-misc-oslec
75 %depmod %{_kernel_ver}
76
77 %postun -n kernel%{_alt_kernel}-misc-oslec
78 %depmod %{_kernel_ver}
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README.txt
83 %attr(755,root,root) %{_sbindir}/oslec-ctrl-panel.sh
84
85 %files -n kernel%{_alt_kernel}-misc-oslec
86 %defattr(644,root,root,755)
87 /lib/modules/%{_kernel_ver}/misc/oslec*
This page took 0.776881 seconds and 3 git commands to generate.