]> git.pld-linux.org Git - SPECS.git/blob - orbitcpp.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / orbitcpp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        C++ bindings for the ORBit Corba ORB
6 Summary(pl.UTF-8):      Powiązania C++ dla ORBit Corba ORB
7 Name:           orbitcpp
8 Version:        1.3.9
9 Release:        2
10 License:        LGPL v2+
11 Group:          Applications/Engineering
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/orbitcpp/1.3/%{name}-%{version}.tar.bz2
13 # Source0-md5:  ef1594819cf62fc2dad6e0a1cc4cb578
14 URL:            http://orbitcpp.sourceforge.net/
15 BuildRequires:  ORBit2-devel >= 1:2.8.2
16 BuildRequires:  autoconf >= 2.12
17 BuildRequires:  automake
18 BuildRequires:  libIDL-devel >= 0.8.2
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.4d
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Orbitcpp is a project to develop C++ bindings for the ORBit Corba ORB.
26
27 %description -l pl.UTF-8
28 Orbitcpp to projekt umożliwiający tworzenie powiązań C++ dla ORBit
29 Corba ORB.
30
31 %package devel
32 Summary:        Header files and utilities for orbitcpp
33 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla orbitcpp
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       ORBit2-devel >= 1:2.8.2
37 Requires:       libIDL-devel >= 0.8.2
38 Requires:       libstdc++-devel
39
40 %description devel
41 Orbitcpp is a project to develop C++ bindings for the ORBit Corba ORB.
42
43 This package includes the header files and utilities neecessary to
44 write programs that use orbitcpp.
45
46 %description devel -l pl.UTF-8
47 Orbitcpp to projekt umożliwiający tworzenie powiązań C++ dla ORBit
48 Corba ORB.
49
50 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
51 programów używających orbitcpp.
52
53 %package static
54 Summary:        Static orbitcpp library
55 Summary(pl.UTF-8):      Statyczna biblioteka orbitcpp
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Orbitcpp is a project to develop C++ bindings for the ORBit Corba ORB.
61
62 This package includes static library neecessary to write programs
63 statically linked that use CORBA technology.
64
65 %description static -l pl.UTF-8
66 Orbitcpp to projekt umożliwiający tworzenie powiązań C++ dla ORBit
67 Corba ORB.
68
69 Ten pakiet zawiera bibliotekę statyczną potrzebną do pisania
70 konsolidowanych statycznie programów używających technologii CORBA.
71
72 %prep
73 %setup -q
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__autoheader}
80 # -i is workaround for am problems in tests
81 %{__automake} -i
82 %configure \
83         %{!?with_static_libs:--disable-static}
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # not needed for ORBit2 backends
93 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/idl-backends/*.{a,la}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS NEWS README
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
102 %dir %{_libdir}/orbit-2.0/idl-backends
103 %attr(755,root,root) %{_libdir}/orbit-2.0/idl-backends/*.so*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %doc ChangeLog
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %{_libdir}/lib*.la
110 %{_includedir}/orbitcpp-*
111 %{_pkgconfigdir}/*.pc
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
117 %endif
This page took 0.059753 seconds and 3 git commands to generate.