]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- pl for -server-ldap
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        6
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch8:         ldap.conf.patch
56 Patch6:         %{name}-config.patch
57 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
58 Patch7:         authorized-keys-command.patch
59 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
61 Patch9:         %{name}-5.2p1-hpn13v6.diff
62 Patch10:        %{name}-include.patch
63 Patch11:        %{name}-chroot.patch
64 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
65 Patch12:        %{name}-blacklist.diff
66 Patch13:        %{name}-kuserok.patch
67 URL:            http://www.openssh.com/portable.html
68 BuildRequires:  %{__perl}
69 %{?with_audit:BuildRequires:    audit-libs-devel}
70 BuildRequires:  autoconf >= 2.50
71 BuildRequires:  automake
72 %{?with_gnome:BuildRequires:    gnome-libs-devel}
73 %{?with_gtk:BuildRequires:      gtk+2-devel}
74 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
75 %{?with_libedit:BuildRequires:  libedit-devel}
76 %{?with_selinux:BuildRequires:  libselinux-devel}
77 BuildRequires:  libwrap-devel
78 %{?with_ldap:BuildRequires:     openldap-devel}
79 BuildRequires:  openssl-devel >= 0.9.7d
80 BuildRequires:  pam-devel
81 %{?with_gtk:BuildRequires:      pkgconfig}
82 BuildRequires:  rpm >= 4.4.9-56
83 BuildRequires:  rpmbuild(macros) >= 1.318
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  zlib-devel
86 %if "%{pld_release}" == "ac"
87 Requires:       filesystem >= 2.0-1
88 Requires:       pam >= 0.79.0
89 %else
90 Requires:       filesystem >= 3.0-11
91 Requires:       pam >= %{pam_ver}
92 Suggests:       openssh-blacklist
93 Suggests:       xorg-app-xauth
94 %endif
95 Obsoletes:      ssh
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/ssh
99 %define         _libexecdir     %{_libdir}/%{name}
100 %define         _privsepdir     /usr/share/empty
101 %define         schemadir       /usr/share/openldap/schema
102
103 %description
104 Ssh (Secure Shell) a program for logging into a remote machine and for
105 executing commands in a remote machine. It is intended to replace
106 rlogin and rsh, and provide secure encrypted communications between
107 two untrusted hosts over an insecure network. X11 connections and
108 arbitrary TCP/IP ports can also be forwarded over the secure channel.
109
110 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
111 it up to date in terms of security and features, as well as removing
112 all patented algorithms to seperate libraries (OpenSSL).
113
114 This package includes the core files necessary for both the OpenSSH
115 client and server. To make this package useful, you should also
116 install openssh-clients, openssh-server, or both.
117
118 %if %{with hpn}
119 This release includes High Performance SSH/SCP patches from
120 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
121 increase throughput on fast connections with high RTT (20-150 msec).
122 See the website for '-w' values for your connection and /proc/sys TCP
123 values. BTW. in a LAN you have got generally RTT < 1 msec.
124 %endif
125
126 %description -l de.UTF-8
127 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
128 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
129 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
130 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
131 andere TCP/IP Ports können ebenso über den sicheren Channel
132 weitergeleitet werden.
133
134 %description -l es.UTF-8
135 SSH es un programa para accesar y ejecutar órdenes en computadores
136 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
137 seguro entre dos servidores en una red insegura. Conexiones X11 y
138 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
139 seguro.
140
141 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
142 continuar la última versión gratuita de SSH, actualizándolo en
143 términos de seguridad y recursos,así también eliminando todos los
144 algoritmos patentados y colocándolos en bibliotecas separadas
145 (OpenSSL).
146
147 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
148 también el paquete openssh-clients u openssh-server o ambos.
149
150 %description -l fr.UTF-8
151 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
152 remplace telnet, rlogin, rexec et rsh, tout en assurant des
153 communications cryptées securisées entre deux hôtes non fiabilisés sur
154 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
155 arbitraires peuvent également être transmis sur le canal sécurisé.
156
157 %description -l it.UTF-8
158 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
159 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
160 sicure e crittate tra due host non fidati su una rete non sicura. Le
161 connessioni X11 ad una porta TCP/IP arbitraria possono essere
162 inoltrate attraverso un canale sicuro.
163
164 %description -l pl.UTF-8
165 Ssh (Secure Shell) to program służący do logowania się na zdalną
166 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
167 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
168 pomiędzy dwoma hostami.
169
170 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
171 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
172 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
173
174 %if %{with hpn}
175 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
176 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
177 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
178 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
179 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
180 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
181 %endif
182
183 %description -l pt.UTF-8
184 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
185 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
186 cifradas entre duas máquinas sem confiança mútua sobre uma rede
187 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
188 reenviados pelo canal seguro.
189
190 %description -l pt_BR.UTF-8
191 SSH é um programa para acessar e executar comandos em máquinas
192 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
193 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
194 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
195
196 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
197 última versão gratuita do SSH, atualizando-o em termos de segurança e
198 recursos, assim como removendo todos os algoritmos patenteados e
199 colocando-os em bibliotecas separadas (OpenSSL).
200
201 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
202 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
203
204 %description -l ru.UTF-8
205 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
206 машину и для выполнения команд на удаленной машине. Она предназначена
207 для замены rlogin и rsh и обеспечивает безопасную шифрованную
208 коммуникацию между двумя хостами в сети, являющейся небезопасной.
209 Соединения X11 и любые порты TCP/IP могут также быть проведены через
210 безопасный канал.
211
212 OpenSSH - это переделка командой разработчиков OpenBSD последней
213 свободной версии SSH, доведенная до современного состояния в терминах
214 уровня безопасности и поддерживаемых возможностей. Все патентованные
215 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
216
217 Этот пакет содержит файлы, необходимые как для клиента, так и для
218 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
219 openssh-server, или оба пакета.
220
221 %description -l uk.UTF-8
222 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
223 машини та для виконання команд на віддаленій машині. Вона призначена
224 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
225 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
226 довільні порти TCP/IP можуть також бути проведені через безпечний
227 канал.
228
229 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
230 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
231 підтримуваних можливостей. Всі патентовані алгоритми винесені до
232 окремих бібліотек (OpenSSL).
233
234 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
235 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
236 openssh-server, чи обидва пакети.
237
238 %package clients
239 Summary:        OpenSSH Secure Shell protocol clients
240 Summary(es.UTF-8):      Clientes de OpenSSH
241 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
242 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
243 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
244 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
245 Group:          Applications/Networking
246 Requires:       %{name}
247 Provides:       ssh-clients
248 Obsoletes:      ssh-clients
249
250 %description clients
251 Ssh (Secure Shell) a program for logging into a remote machine and for
252 executing commands in a remote machine. It is intended to replace
253 rlogin and rsh, and provide secure encrypted communications between
254 two untrusted hosts over an insecure network. X11 connections and
255 arbitrary TCP/IP ports can also be forwarded over the secure channel.
256
257 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
258 it up to date in terms of security and features, as well as removing
259 all patented algorithms to seperate libraries (OpenSSL).
260
261 This package includes the clients necessary to make encrypted
262 connections to SSH servers.
263
264 %description clients -l es.UTF-8
265 Este paquete incluye los clientes que se necesitan para hacer
266 conexiones codificadas con servidores SSH.
267
268 %description clients -l pl.UTF-8
269 Ssh (Secure Shell) to program służący do logowania się na zdalną
270 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
271 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
272 pomiędzy dwoma hostami.
273
274 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
275
276 %description clients -l pt_BR.UTF-8
277 Esse pacote inclui os clientes necessários para fazer conexões
278 encriptadas com servidores SSH.
279
280 %description clients -l ru.UTF-8
281 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
282 машину и для выполнения команд на удаленной машине.
283
284 Этот пакет содержит программы-клиенты, необходимые для установления
285 зашифрованных соединений с серверами SSH.
286
287 %description clients -l uk.UTF-8
288 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
289 машини та для виконання команд на віддаленій машині.
290
291 Цей пакет містить програми-клієнти, необхідні для встановлення
292 зашифрованих з'єднань з серверами SSH.
293
294 %package clients-agent-profile_d
295 Summary:        OpenSSH Secure Shell agent init script
296 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
297 Group:          Applications/Networking
298 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
299
300 %description clients-agent-profile_d
301 profile.d scripts for starting SSH agent.
302
303 %description clients-agent-profile_d -l pl.UTF-8
304 Skrypty profile.d do uruchamiania agenta SSH.
305
306 %package clients-agent-xinitrc
307 Summary:        OpenSSH Secure Shell agent init script
308 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
309 Group:          Applications/Networking
310 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
311 Requires:       xinitrc
312
313 %description clients-agent-xinitrc
314 xinitrc scripts for starting SSH agent.
315
316 %description clients-agent-xinitrc -l pl.UTF-8
317 Skrypty xinitrc do uruchamiania agenta SSH.
318
319 %package server
320 Summary:        OpenSSH Secure Shell protocol server (sshd)
321 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
322 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
323 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
324 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
325 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
326 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
327 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
328 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
329 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
330 Group:          Networking/Daemons
331 Requires(post): /sbin/chkconfig
332 Requires(post): grep
333 Requires(post,preun):   /sbin/chkconfig
334 Requires(postun):       /usr/sbin/userdel
335 Requires(pre):  /bin/id
336 Requires(pre):  /usr/sbin/useradd
337 Requires:       %{name} = %{epoch}:%{version}-%{release}
338 # remove in 6.0, kept for flawless upgrade
339 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
340 Requires:       pam >= %{pam_ver}
341 Requires:       rc-scripts >= 0.4.3.0
342 Requires:       util-linux
343 Suggests:       /bin/login
344 Provides:       ssh-server
345 Provides:       user(sshd)
346
347 %description server
348 Ssh (Secure Shell) a program for logging into a remote machine and for
349 executing commands in a remote machine. It is intended to replace
350 rlogin and rsh, and provide secure encrypted communications between
351 two untrusted hosts over an insecure network. X11 connections and
352 arbitrary TCP/IP ports can also be forwarded over the secure channel.
353
354 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
355 it up to date in terms of security and features, as well as removing
356 all patented algorithms to seperate libraries (OpenSSL).
357
358 This package contains the secure shell daemon. The sshd is the server
359 part of the secure shell protocol and allows ssh clients to connect to
360 your host.
361
362 %description server -l de.UTF-8
363 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
364
365 %description server -l es.UTF-8
366 Este paquete contiene el servidor SSH. sshd es la parte servidor del
367 protocolo secure shell y permite que clientes ssh se conecten a su
368 servidor.
369
370 %description server -l fr.UTF-8
371 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
372
373 %description server -l it.UTF-8
374 Questo pacchetto installa sshd, il server di OpenSSH.
375
376 %description server -l pl.UTF-8
377 Ssh (Secure Shell) to program służący do logowania się na zdalną
378 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
379 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
380 pomiędzy dwoma hostami.
381
382 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
383 ssh).
384
385 %description server -l pt.UTF-8
386 Este pacote intala o sshd, o servidor do OpenSSH.
387
388 %description server -l pt_BR.UTF-8
389 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
390 protocolo secure shell e permite que clientes ssh se conectem ao seu
391 host.
392
393 %description server -l ru.UTF-8
394 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
395 машину и для выполнения команд на удаленной машине.
396
397 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
398 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
399 вашим хостом.
400
401 %description server -l uk.UTF-8
402 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
403 машини та для виконання команд на віддаленій машині.
404
405 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
406 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
407 з вашим хостом.
408
409 %package server-ldap
410 Summary:        A LDAP support for open source SSH server daemon
411 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
412 Group:          Daemons
413 Requires:       %{name} = %{epoch}:%{version}-%{release}
414
415 %description server-ldap
416 OpenSSH LDAP backend is a way how to distribute the authorized tokens
417 among the servers in the network.
418
419 %description server-ldap -l pl.UTF-8
420 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
421 tokenów między serwerami w sieci.
422
423 %package server-upstart
424 Summary:        Upstart job description for OpenSSH server
425 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
426 Group:          Daemons
427 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
428 Requires:       upstart >= 0.6
429 Conflicts:      syslog-ng < 3.2.4-1
430
431 %description server-upstart
432 Upstart job description for OpenSSH.
433
434 %description server-upstart -l pl.UTF-8
435 Opis zadania Upstart dla OpenSSH.
436
437 %package gnome-askpass
438 Summary:        OpenSSH GNOME passphrase dialog
439 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
440 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
441 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
442 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
443 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
444 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
445 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
446 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
447 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
448 Group:          Applications/Networking
449 Requires:       %{name} = %{epoch}:%{version}-%{release}
450 Obsoletes:      openssh-askpass
451 Obsoletes:      ssh-askpass
452 Obsoletes:      ssh-extras
453
454 %description gnome-askpass
455 Ssh (Secure Shell) a program for logging into a remote machine and for
456 executing commands in a remote machine. It is intended to replace
457 rlogin and rsh, and provide secure encrypted communications between
458 two untrusted hosts over an insecure network. X11 connections and
459 arbitrary TCP/IP ports can also be forwarded over the secure channel.
460
461 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
462 it up to date in terms of security and features, as well as removing
463 all patented algorithms to seperate libraries (OpenSSL).
464
465 This package contains the GNOME passphrase dialog.
466
467 %description gnome-askpass -l es.UTF-8
468 Este paquete contiene un programa que abre una caja de diálogo para
469 entrada de passphrase en GNOME.
470
471 %description gnome-askpass -l pl.UTF-8
472 Ssh (Secure Shell) to program służący do logowania się na zdalną
473 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
474 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
475 pomiędzy dwoma hostami.
476
477 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
478
479 %description gnome-askpass -l pt_BR.UTF-8
480 Esse pacote contém um programa que abre uma caixa de diálogo para
481 entrada de passphrase no GNOME.
482
483 %description gnome-askpass -l ru.UTF-8
484 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
485 машину и для выполнения команд на удаленной машине.
486
487 Этот пакет содержит диалог ввода ключевой фразы для использования под
488 GNOME.
489
490 %description gnome-askpass -l uk.UTF-8
491 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
492 машини та для виконання команд на віддаленій машині.
493
494 Цей пакет містить діалог вводу ключової фрази для використання під
495 GNOME.
496
497 %package -n openldap-schema-openssh-lpk
498 Summary:        OpenSSH LDAP Public Key schema
499 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
500 Group:          Networking/Daemons
501 Requires(post,postun):  sed >= 4.0
502 Requires:       openldap-servers
503
504 %description -n openldap-schema-openssh-lpk
505 This package contains OpenSSH LDAP Public Key schema for openldap.
506
507 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
508 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
509 openldap-a.
510
511 %prep
512 %setup -q
513 %{?with_kerberos5:%patch100 -p1}
514 %patch0 -p1
515 %patch2 -p1
516 %patch3 -p1
517 %patch4 -p1
518 %patch5 -p1
519 %patch8 -p1
520 %patch6 -p1
521 %patch7 -p1
522 %{?with_hpn:%patch9 -p1}
523 %patch10 -p1
524 %patch11 -p1
525 %patch12 -p1
526 %patch13 -p1
527
528 cp -p %{SOURCE3} sshd.pam
529 install -p %{SOURCE2} sshd.init
530
531 %if "%{pld_release}" == "ac"
532 # fix for missing x11.pc
533 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
534 # not present in ac, no point searching it
535 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
536
537 # openssl on ac does not have OPENSSL_HAS_ECC
538 %{__sed} -i -e '/ecdsa/d' sshd.init
539 %endif
540
541 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
542 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
543
544 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
545 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
546
547 %build
548 cp /usr/share/automake/config.sub .
549 %{__aclocal}
550 %{__autoconf}
551 %{__autoheader}
552 CPPFLAGS="-DCHROOT"
553 %configure \
554         PERL=%{__perl} \
555         --disable-strip \
556         --enable-utmpx \
557         --enable-wtmpx \
558         --with-4in6 \
559         %{?with_audit:--with-audit=linux} \
560         --with-ipaddr-display \
561         %{?with_kerberos5:--with-kerberos5=/usr} \
562         --with-ldap%{!?with_ldap:=no} \
563         %{?with_libedit:--with-libedit} \
564         --with-mantype=man \
565         --with-md5-passwords \
566         --with-pam \
567         --with-authorized-keys-command \
568         --with-pid-dir=%{_localstatedir}/run \
569         --with-privsep-path=%{_privsepdir} \
570         %{?with_selinux:--with-selinux} \
571         --with-tcp-wrappers \
572 %if "%{pld_release}" == "ac"
573         --with-xauth=/usr/X11R6/bin/xauth
574 %else
575         --with-xauth=%{_bindir}/xauth
576 %endif
577
578 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
579
580 %{__make}
581
582 cd contrib
583 %if %{with gnome}
584 %{__make} gnome-ssh-askpass1 \
585         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
586 %endif
587 %if %{with gtk}
588 %{__make} gnome-ssh-askpass2 \
589         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
590 %endif
591
592 %install
593 rm -rf $RPM_BUILD_ROOT
594 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
595         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
596 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
597
598 %{__make} install \
599         DESTDIR=$RPM_BUILD_ROOT
600
601 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
602
603 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
604 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
605 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
606 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
607 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
608 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
609 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
610 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
611
612 %if %{with gnome}
613 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
614 %endif
615 %if %{with gtk}
616 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
617 %endif
618 %if %{with gnome} || %{with gtk}
619 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
620 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
621 EOF
622 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
623 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
624 EOF
625 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
626 %endif
627
628 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
629 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
630
631 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
632 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
633
634 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
635
636 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
637 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
638 EOF
639
640 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
641 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
642
643 %clean
644 rm -rf $RPM_BUILD_ROOT
645
646 %post clients
647 %env_update
648
649 %postun clients
650 %env_update
651
652 %post gnome-askpass
653 %env_update
654
655 %postun gnome-askpass
656 %env_update
657
658 %pre server
659 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
660
661 %post server
662 /sbin/chkconfig --add sshd
663 %service sshd reload "OpenSSH Daemon"
664 if ! grep -qs ssh /etc/security/passwd.conf ; then
665         umask 022
666         echo "ssh" >> /etc/security/passwd.conf
667 fi
668
669 %preun server
670 if [ "$1" = "0" ]; then
671         %service sshd stop
672         /sbin/chkconfig --del sshd
673 fi
674
675 %postun server
676 if [ "$1" = "0" ]; then
677         %userremove sshd
678 fi
679
680 %triggerpostun server -- %{name}-server < 2:5.9p1-1
681 # lpk.patch to ldap.patch
682 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
683         echo >&2 "Migrating LPK patch to LDAP patch"
684         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
685         %{__sed} -i -e '
686                 # disable old configs
687                 # just UseLPK/LkpLdapConf supported for now
688                 s/^UseLPK/## Obsolete &/
689                 s/^Lpk/## Obsolete &/
690                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
691                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
692         ' %{_sysconfdir}/sshd_config
693         %service -q sshd reload
694 fi
695
696 %post server-upstart
697 %upstart_post sshd
698
699 %postun server-upstart
700 %upstart_postun sshd
701
702 %post -n openldap-schema-openssh-lpk
703 %openldap_schema_register %{schemadir}/openssh-lpk.schema
704 %service -q ldap restart
705
706 %postun -n openldap-schema-openssh-lpk
707 if [ "$1" = "0" ]; then
708         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
709         %service -q ldap restart
710 fi
711
712 %files
713 %defattr(644,root,root,755)
714 %doc TODO README OVERVIEW CREDITS Change*
715 %attr(755,root,root) %{_bindir}/ssh-key*
716 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
717 %{_mandir}/man1/ssh-key*.1*
718 %{_mandir}/man1/ssh-vulnkey*.1*
719 %dir %{_sysconfdir}
720 %dir %{_libexecdir}
721
722 %files clients
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_bindir}/ssh
725 %attr(755,root,root) %{_bindir}/slogin
726 %attr(755,root,root) %{_bindir}/sftp
727 %attr(755,root,root) %{_bindir}/ssh-agent
728 %attr(755,root,root) %{_bindir}/ssh-add
729 %attr(755,root,root) %{_bindir}/ssh-copy-id
730 %attr(755,root,root) %{_bindir}/scp
731 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
732 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
733 %{_mandir}/man1/scp.1*
734 %{_mandir}/man1/ssh.1*
735 %{_mandir}/man1/slogin.1*
736 %{_mandir}/man1/sftp.1*
737 %{_mandir}/man1/ssh-agent.1*
738 %{_mandir}/man1/ssh-add.1*
739 %{_mandir}/man1/ssh-copy-id.1*
740 %{_mandir}/man5/ssh_config.5*
741 %lang(it) %{_mandir}/it/man1/ssh.1*
742 %lang(it) %{_mandir}/it/man5/ssh_config.5*
743 %lang(pl) %{_mandir}/pl/man1/scp.1*
744 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
745
746 # for host-based auth (suid required for accessing private host key)
747 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
748 #%{_mandir}/man8/ssh-keysign.8*
749
750 %files clients-agent-profile_d
751 %defattr(644,root,root,755)
752 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
753 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
754
755 %files clients-agent-xinitrc
756 %defattr(644,root,root,755)
757 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
758
759 %files server
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_sbindir}/sshd
762 %attr(755,root,root) %{_libexecdir}/sftp-server
763 %attr(755,root,root) %{_libexecdir}/ssh-keysign
764 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
765 %{_mandir}/man8/sshd.8*
766 %{_mandir}/man8/sftp-server.8*
767 %{_mandir}/man8/ssh-keysign.8*
768 %{_mandir}/man8/ssh-pkcs11-helper.8*
769 %{_mandir}/man5/sshd_config.5*
770 %{_mandir}/man5/moduli.5*
771 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
772 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
773 %attr(640,root,root) %{_sysconfdir}/moduli
774 %attr(754,root,root) /etc/rc.d/init.d/sshd
775 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
776 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
777
778 %if %{with ldap}
779 %files server-ldap
780 %defattr(644,root,root,755)
781 %doc HOWTO.ldap-keys ldap.conf
782 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
783 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
784 %{_mandir}/man5/ssh-ldap.conf.5*
785 %{_mandir}/man8/ssh-ldap-helper.8*
786 %endif
787
788 %if %{with gnome} || %{with gtk}
789 %files gnome-askpass
790 %defattr(644,root,root,755)
791 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
792 %dir %{_libexecdir}/ssh
793 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
794 %attr(755,root,root) %{_libexecdir}/ssh-askpass
795 %endif
796
797 %if %{with ldap}
798 %files -n openldap-schema-openssh-lpk
799 %defattr(644,root,root,755)
800 %{schemadir}/openssh-lpk.schema
801 %endif
802
803 %if "%{pld_release}" != "ti"
804 %files server-upstart
805 %defattr(644,root,root,755)
806 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
807 %endif
This page took 0.086835 seconds and 4 git commands to generate.