]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- openssh-linux.patch obsoleted in 1.2.3
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.3
4 Release:        1
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        ftp://ftp.franken.de/pub/Linux/openssh/files/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch0:         openssh-PAM_NEW_AUTHTOK.patch
16 Patch1:         openssh-libwrap.patch
17 BuildRequires:  openssl-devel >= 0.9.4-2
18 BuildRequires:  zlib-devel
19 BuildRequires:  pam-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  gnome-libs-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      ssh < %{version}, ssh > %{version}
24
25 %define         _sysconfdir     /etc/ssh
26
27 %description
28 Ssh (Secure Shell) a program for logging into a remote machine and for
29 executing commands in a remote machine. It is intended to replace rlogin and
30 rsh, and provide secure encrypted communications between two untrusted hosts
31 over an insecure network. X11 connections and arbitrary TCP/IP ports can
32 also be forwarded over the secure channel.
33
34 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
35 to date in terms of security and features, as well as removing all patented
36 algorithms to seperate libraries (OpenSSL).
37
38 This package includes the core files necessary for both the OpenSSH
39 client and server. To make this package useful, you should also
40 install openssh-clients, openssh-server, or both.
41
42 %package clients
43 Summary:        OpenSSH Secure Shell protocol clients
44 Requires:       openssh
45 Group:          Applications/Networking
46 Group(pl):      Aplikacje/Sieciowe
47 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
48 Requires:       %{name} = %{version}
49
50 %description clients
51 Ssh (Secure Shell) a program for logging into a remote machine and for
52 executing commands in a remote machine. It is intended to replace rlogin and
53 rsh, and provide secure encrypted communications between two untrusted hosts
54 over an insecure network. X11 connections and arbitrary TCP/IP ports can
55 also be forwarded over the secure channel.
56
57 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
58 to date in terms of security and features, as well as removing all patented
59 algorithms to seperate libraries (OpenSSL).
60
61 This package includes the clients necessary to make encrypted connections to
62 SSH servers.
63
64 %package server
65 Summary:        OpenSSH Secure Shell protocol server (sshd)
66 Requires:       openssh chkconfig >= 0.9
67 Group:          Networking/Daemons
68 Group(pl):      Sieciowe/Serwery
69 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
70 Requires:       rc-scripts
71 Requires:       /bin/login
72 Requires:       util-linux
73 Prereq:         %{name} = %{version}
74
75 %description server
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine. It is intended to replace rlogin and
78 rsh, and provide secure encrypted communications between two untrusted hosts
79 over an insecure network. X11 connections and arbitrary TCP/IP ports can
80 also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
83 to date in terms of security and features, as well as removing all patented
84 algorithms to seperate libraries (OpenSSL).
85
86 This package contains the secure shell daemon. The sshd is the server part
87 of the secure shell protocol and allows ssh clients to connect to your host.
88
89 %package gnome-askpass
90 Summary:        OpenSSH GNOME passphrase dialog
91 Group:          Applications/Networking
92 Group(pl):      Aplikacje/Sieciowe
93 Requires:       %{name} = %{version}
94 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
95 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
96 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
97
98 %description gnome-askpass
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine. It is intended to replace rlogin
101 and rsh, and provide secure encrypted communications between two untrusted
102 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
103 can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
106 to date in terms of security and features, as well as removing all patented
107 algorithms to seperate libraries (OpenSSL).
108
109 This package contains the GNOME passphrase dialog.
110
111 %prep
112 %setup  -q
113 %patch0 -p1
114 %patch1 -p1
115
116 %build
117 autoconf
118 %configure \
119         --with-gnome-askpass \
120         --with-tcp-wrappers \
121         --with-md5-passwords \
122         --with-ipaddr-display \
123         --enable-ipv6 \
124         --enable-log-auth 
125
126 # with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
127 #       --with-ipv4-default \
128 # broken options
129 #       --without-kerberos4 \
130 #       --without-afs \
131 #       --without-skey 
132
133 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
134
135 make
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
141
142 make install DESTDIR="$RPM_BUILD_ROOT"
143
144 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
145 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
146 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
147 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
148 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
149 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
150
151 mv -f   $RPM_BUILD_ROOT%{_libexecdir}/ssh/gnome-ssh-askpass \
152         $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
153
154 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
155         $RPM_BUILD_ROOT/%{_mandir}/man*/*
156
157 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
158         
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post server
163 /sbin/chkconfig --add sshd
164 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
165         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
166 fi
167 if [ -f /var/lock/subsys/sshd ]; then
168         /etc/rc.d/init.d/sshd restart 1>&2
169 fi
170 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
171         echo "ssh" >> /etc/security/passwd.conf
172 fi
173
174 %preun server
175 if [ "$1" = 0 ]; then
176         if [ -f /var/lock/subsys/sshd ]; then
177                 /etc/rc.d/init.d/sshd stop 1>&2
178         fi
179         /sbin/chkconfig --del sshd
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
185 %attr(755,root,root) %{_bindir}/ssh-keygen
186 %{_mandir}/man1/ssh-keygen.1*
187 %dir %{_sysconfdir}
188
189 %files clients
190 %defattr(644,root,root,755)
191 # suid root ?
192 #%attr(4755,root,root) %{_bindir}/ssh
193 %attr(0755,root,root) %{_bindir}/ssh
194 %attr(0755,root,root) %{_bindir}/ssh-agent
195 %attr(0755,root,root) %{_bindir}/ssh-add
196 #%attr(0755,root,root) %{_bindir}/slogin
197 %attr(755,root,root) %{_bindir}/scp
198 %{_mandir}/man1/scp.1*
199 %{_mandir}/man1/ssh.1*
200 %{_mandir}/man1/ssh-agent.1*
201 %{_mandir}/man1/ssh-add.1*
202 #%{_mandir}/man1/slogin.1
203 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
204
205 %files server
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_sbindir}/sshd
208 %{_mandir}/man8/sshd.8*
209 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
210 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
211 %attr(754,root,root) /etc/rc.d/init.d/sshd
212 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
213 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
214
215 %files gnome-askpass
216 %defattr(644,root,root,755)
217 %dir %{_libexecdir}/ssh
218 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.049207 seconds and 4 git commands to generate.