]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- upgrade to 4.0p1,
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # without gnome-askpass utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  chroot          # without chrooted user environment support
8 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
9 %bcond_without  selinux         # build without SELinux support
10 #
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13 Summary:        OpenSSH free Secure Shell (SSH) implementation
14 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
15 Summary(es):    Implementación libre de SSH
16 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
17 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
18 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
19 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20 Summary(pt_BR): Implementação livre do SSH
21 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
22 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
23 Name:           openssh
24 Version:        4.0p1
25 Release:        0.1
26 Epoch:          2
27 License:        BSD
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30 # Source0-md5:  7b36f28fc16e1b7f4ba3c1dca191ac92
31 Source1:        %{name}d.conf
32 Source2:        %{name}.conf
33 Source3:        %{name}d.init
34 Source4:        %{name}d.pamd
35 Source5:        %{name}.sysconfig
36 Source6:        passwd.pamd
37 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
38 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
39 Source9:        http://www.imasy.or.jp/~gotoh/ssh/connect.c
40 # NoSource9-md5:        c78de727e1208799072be78c05d64398
41 Source10:       http://www.imasy.or.jp/~gotoh/ssh/connect.html
42 # NoSource10-md5:       f14cb61fafd067a3f5ce4eaa9643bf05
43 Source11:       ssh-agent.sh
44 Source12:       ssh-agent.conf
45 Patch0:         %{name}-no_libnsl.patch
46 Patch2:         %{name}-linux-ipv6.patch
47 Patch3:         %{name}-pam_misc.patch
48 Patch4:         %{name}-sigpipe.patch
49 # http://ldappubkey.gcu-squad.org/
50 Patch5:         ldappubkey-ossh3.6-v2.patch
51 Patch6:         %{name}-heimdal.patch
52 Patch7:         %{name}-pam-conv.patch
53 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
54 Patch8:         %{name}-chroot.patch
55 Patch9:         %{name}-selinux.patch
56 Patch10:        %{name}-selinux-pld.patch
57 URL:            http://www.openssh.com/
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 %{?with_gnome:BuildRequires:    gnome-libs-devel}
61 %{?with_gtk:BuildRequires:      gtk+2-devel}
62 %{?with_kerberos5:BuildRequires:        heimdal-devel}
63 %{?with_selinux:BuildRequires:  libselinux-devel}
64 BuildRequires:  libwrap-devel
65 %{?with_ldap:BuildRequires:     openldap-devel}
66 BuildRequires:  openssl-devel >= 0.9.7d
67 BuildRequires:  pam-devel
68 BuildRequires:  %{__perl}
69 %{?with_gtk:BuildRequires:      pkgconfig}
70 BuildRequires:  rpmbuild(macros) >= 1.159
71 BuildRequires:  zlib-devel
72 PreReq:         FHS >= 2.1-24
73 PreReq:         openssl >= 0.9.7d
74 Obsoletes:      ssh
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _sysconfdir     /etc/ssh
78 %define         _libexecdir     %{_libdir}/%{name}
79 %define         _privsepdir     /usr/share/empty
80
81 %description
82 Ssh (Secure Shell) a program for logging into a remote machine and for
83 executing commands in a remote machine. It is intended to replace
84 rlogin and rsh, and provide secure encrypted communications between
85 two untrusted hosts over an insecure network. X11 connections and
86 arbitrary TCP/IP ports can also be forwarded over the secure channel.
87
88 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
89 it up to date in terms of security and features, as well as removing
90 all patented algorithms to seperate libraries (OpenSSL).
91
92 This package includes the core files necessary for both the OpenSSH
93 client and server. To make this package useful, you should also
94 install openssh-clients, openssh-server, or both.
95
96 %description -l de
97 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
98 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
99 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
100 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
101 andere TCP/IP Ports können ebenso über den sicheren Channel
102 weitergeleitet werden.
103
104 %description -l es
105 SSH es un programa para accesar y ejecutar órdenes en computadores
106 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
107 seguro entre dos servidores en una red insegura. Conexiones X11 y
108 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
109 seguro.
110
111 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
112 continuar la última versión gratuita de SSH, actualizándolo en
113 términos de seguridad y recursos,así también eliminando todos los
114 algoritmos patentados y colocándolos en bibliotecas separadas
115 (OpenSSL).
116
117 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
118 también el paquete openssh-clients u openssh-server o ambos.
119
120 %description -l fr
121 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
122 remplace telnet, rlogin, rexec et rsh, tout en assurant des
123 communications cryptées securisées entre deux hôtes non fiabilisés sur
124 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
125 arbitraires peuvent également être transmis sur le canal sécurisé.
126
127 %description -l it
128 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
129 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
130 sicure e crittate tra due host non fidati su una rete non sicura. Le
131 connessioni X11 ad una porta TCP/IP arbitraria possono essere
132 inoltrate attraverso un canale sicuro.
133
134 %description -l pl
135 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
136 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
137 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
138 pomiêdzy dwoma hostami.
139
140 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
141 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
142 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
143
144 %description -l pt
145 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
146 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
147 cifradas entre duas máquinas sem confiança mútua sobre uma rede
148 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
149 reenviados pelo canal seguro.
150
151 %description -l pt_BR
152 SSH é um programa para acessar e executar comandos em máquinas
153 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
154 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
155 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
156
157 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
158 última versão gratuita do SSH, atualizando-o em termos de segurança e
159 recursos, assim como removendo todos os algoritmos patenteados e
160 colocando-os em bibliotecas separadas (OpenSSL).
161
162 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
163 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
164
165 %description -l ru
166 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
167 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
168 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
169 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
170 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
171 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
172
173 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
174 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
175 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
176 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
177
178 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
179 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
180 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
181
182 %description -l uk
183 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
184 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
185 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
186 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
187 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
188 ËÁÎÁÌ.
189
190 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
191 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
192 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
193 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
194
195 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
196 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
197 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
198
199 %package clients
200 Summary:        OpenSSH Secure Shell protocol clients
201 Summary(es):    Clientes de OpenSSH
202 Summary(pl):    Klienci protoko³u Secure Shell
203 Summary(pt_BR): Clientes do OpenSSH
204 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
205 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
206 Group:          Applications/Networking
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 %{?with_sshagentsh:Requires:    xinitrc}
209 Provides:       ssh-clients
210 Obsoletes:      ssh-clients
211
212 %description clients
213 Ssh (Secure Shell) a program for logging into a remote machine and for
214 executing commands in a remote machine. It is intended to replace
215 rlogin and rsh, and provide secure encrypted communications between
216 two untrusted hosts over an insecure network. X11 connections and
217 arbitrary TCP/IP ports can also be forwarded over the secure channel.
218
219 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
220 it up to date in terms of security and features, as well as removing
221 all patented algorithms to seperate libraries (OpenSSL).
222
223 This package includes the clients necessary to make encrypted
224 connections to SSH servers.
225
226 %description clients -l es
227 Este paquete incluye los clientes que se necesitan para hacer
228 conexiones codificadas con servidores SSH.
229
230 %description clients -l pl
231 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
232 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
233 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
234 pomiêdzy dwoma hostami.
235
236 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
237
238 %description clients -l pt_BR
239 Esse pacote inclui os clientes necessários para fazer conexões
240 encriptadas com servidores SSH.
241
242 %description clients -l ru
243 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
244 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
245
246 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
247 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
248
249 %description clients -l uk
250 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
251 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
252
253 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
254 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
255
256 %package server
257 Summary:        OpenSSH Secure Shell protocol server (sshd)
258 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
259 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
260 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
261 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
262 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
263 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
264 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
265 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
266 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
267 Group:          Networking/Daemons
268 PreReq:         %{name} = %{epoch}:%{version}-%{release}
269 PreReq:         rc-scripts >= 0.3.1-15
270 Requires(pre):  /bin/id
271 Requires(pre):  /usr/sbin/useradd
272 Requires(post,preun):   /sbin/chkconfig
273 Requires(post): chkconfig >= 0.9
274 Requires(post): grep
275 Requires(postun):       /usr/sbin/userdel
276 Requires:       /bin/login
277 Requires:       util-linux
278 Requires:       pam >= 0.77.3
279 Provides:       user(sshd)
280 Provides:       ssh-server
281
282 %description server
283 Ssh (Secure Shell) a program for logging into a remote machine and for
284 executing commands in a remote machine. It is intended to replace
285 rlogin and rsh, and provide secure encrypted communications between
286 two untrusted hosts over an insecure network. X11 connections and
287 arbitrary TCP/IP ports can also be forwarded over the secure channel.
288
289 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
290 it up to date in terms of security and features, as well as removing
291 all patented algorithms to seperate libraries (OpenSSL).
292
293 This package contains the secure shell daemon. The sshd is the server
294 part of the secure shell protocol and allows ssh clients to connect to
295 your host.
296
297 %description server -l de
298 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
299
300 %description server -l es
301 Este paquete contiene el servidor SSH. sshd es la parte servidor del
302 protocolo secure shell y permite que clientes ssh se conecten a su
303 servidor.
304
305 %description server -l fr
306 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
307
308 %description server -l it
309 Questo pacchetto installa sshd, il server di OpenSSH.
310
311 %description server -l pl
312 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
313 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
314 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
315 pomiêdzy dwoma hostami.
316
317 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
318 ssh).
319
320 %description server -l pt
321 Este pacote intala o sshd, o servidor do OpenSSH.
322
323 %description server -l pt_BR
324 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
325 protocolo secure shell e permite que clientes ssh se conectem ao seu
326 host.
327
328 %description server -l ru
329 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
330 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
331
332 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
333 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
334 ×ÁÛÉÍ ÈÏÓÔÏÍ.
335
336 %description server -l uk
337 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
338 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
339
340 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
341 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
342 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
343
344 %package gnome-askpass
345 Summary:        OpenSSH GNOME passphrase dialog
346 Summary(de):    OpenSSH GNOME Passwort-Dialog
347 Summary(es):    Diálogo para introducción de passphrase para GNOME
348 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
349 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
350 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
351 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
352 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
353 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
354 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
355 Group:          Applications/Networking
356 Requires:       %{name} = %{epoch}:%{version}-%{release}
357 Obsoletes:      ssh-extras
358 Obsoletes:      ssh-askpass
359 Obsoletes:      openssh-askpass
360
361 %description gnome-askpass
362 Ssh (Secure Shell) a program for logging into a remote machine and for
363 executing commands in a remote machine. It is intended to replace
364 rlogin and rsh, and provide secure encrypted communications between
365 two untrusted hosts over an insecure network. X11 connections and
366 arbitrary TCP/IP ports can also be forwarded over the secure channel.
367
368 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
369 it up to date in terms of security and features, as well as removing
370 all patented algorithms to seperate libraries (OpenSSL).
371
372 This package contains the GNOME passphrase dialog.
373
374 %description gnome-askpass -l es
375 Este paquete contiene un programa que abre una caja de diálogo para
376 entrada de passphrase en GNOME.
377
378 %description gnome-askpass -l pl
379 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
380 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
381 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
382 pomiêdzy dwoma hostami.
383
384 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
385
386 %description gnome-askpass -l pt_BR
387 Esse pacote contém um programa que abre uma caixa de diálogo para
388 entrada de passphrase no GNOME.
389
390 %description gnome-askpass -l ru
391 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
392 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
393
394 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
395 GNOME.
396
397 %description gnome-askpass -l uk
398 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
399 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
400
401 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
402 GNOME.
403
404 %prep
405 %setup -q
406
407 echo "Please, look and fix patches !!"
408 exit 1
409 %patch0 -p1
410 %patch2 -p1
411 %patch3 -p1
412 ## %patch4 -p1
413 %{?with_ldap:%patch5 -p1}
414 %{?with_kerberos5:%patch6 -p1}
415 #%patch7 -p1
416 ## %patch8 -p1
417 %{?with_selinux:%patch9 -p1}
418 %{?with_selinux:%patch10 -p1}
419
420 %build
421 cp %{_datadir}/automake/config.sub .
422 %{__aclocal}
423 %{__autoconf}
424 %{?with_chroot:CPPFLAGS="-DCHROOT"}
425 %configure \
426         PERL=%{__perl} \
427         --with-dns \
428         --with-pam \
429         --with-mantype=man \
430         --with-md5-passwords \
431         --with-ipaddr-display \
432         --with-4in6 \
433         --disable-suid-ssh \
434         --with-tcp-wrappers \
435         %{?with_ldap:--with-libs="-lldap -llber"} \
436         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
437         %{?with_kerberos5:--with-kerberos5} \
438         --with-privsep-path=%{_privsepdir} \
439         --with-pid-dir=%{_localstatedir}/run \
440         --with-xauth=/usr/X11R6/bin/xauth
441
442 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
443
444 %{__make}
445
446 cp -f %{SOURCE9} .
447 cp -f %{SOURCE10} .
448 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
449
450 cd contrib
451 %if %{with gnome}
452 %{__make} gnome-ssh-askpass1 \
453         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
454 %endif
455 %if %{with gtk}
456 %{__make} gnome-ssh-askpass2 \
457         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
458 %endif
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
463         $RPM_BUILD_ROOT%{_libexecdir}/ssh
464 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
465
466 %{__make} install \
467         DESTDIR=$RPM_BUILD_ROOT
468
469 install connect    $RPM_BUILD_ROOT%{_bindir}
470 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
471 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
472 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
473 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
474 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
475 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
476 %if %{with sshagentsh}
477 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
478 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
479 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
480 %endif
481
482 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
483
484 %if %{with gnome}
485 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
486 %endif
487 %if %{with gtk}
488 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
489 %endif
490 %if %{with gnome} || %{with gtk}
491 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
492 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
493 EOF
494 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
495 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
496 EOF
497 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
498 %endif
499
500 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
501 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
502
503 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
504
505 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
506 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
507 EOF
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512 %pre server
513 if [ -n "`/bin/id -u sshd 2>/dev/null`" ]; then
514         if [ "`/bin/id -u sshd`" != "40" ]; then
515                 echo "Error: user sshd doesn't have uid=40. Correct this before installing ssh server." 1>&2
516                 exit 1
517         fi
518 else
519         /usr/sbin/useradd -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd 1>&2
520 fi
521
522 %post server
523 /sbin/chkconfig --add sshd
524 if [ -f /var/lock/subsys/sshd ]; then
525         /etc/rc.d/init.d/sshd restart 1>&2
526 else
527         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
528 fi
529 if ! grep -qs ssh /etc/security/passwd.conf ; then
530         umask 022
531         echo "ssh" >> /etc/security/passwd.conf
532 fi
533
534 %preun server
535 if [ "$1" = "0" ]; then
536         if [ -f /var/lock/subsys/sshd ]; then
537                 /etc/rc.d/init.d/sshd stop 1>&2
538         fi
539         /sbin/chkconfig --del sshd
540 fi
541
542 %postun server
543 if [ "$1" = "0" ]; then
544         %userremove sshd
545 fi
546
547 %files
548 %defattr(644,root,root,755)
549 %doc *.RNG TODO README OVERVIEW CREDITS Change*
550 %attr(755,root,root) %{_bindir}/ssh-key*
551 %{_mandir}/man1/ssh-key*.1*
552 %dir %{_sysconfdir}
553 %dir %{_libexecdir}
554
555 %files clients
556 %defattr(644,root,root,755)
557 %doc connect.html
558 %attr(755,root,root) %{_bindir}/connect
559 %attr(755,root,root) %{_bindir}/ssh
560 %attr(755,root,root) %{_bindir}/slogin
561 %attr(755,root,root) %{_bindir}/sftp
562 %attr(755,root,root) %{_bindir}/ssh-agent
563 %attr(755,root,root) %{_bindir}/ssh-add
564 %attr(755,root,root) %{_bindir}/scp
565 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
566 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/SSH_ASKPASS
567 %if %{with sshagentsh}
568 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh-agent.conf
569 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
570 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
571 %endif
572 %{_mandir}/man1/scp.1*
573 %{_mandir}/man1/ssh.1*
574 %{_mandir}/man1/slogin.1*
575 %{_mandir}/man1/sftp.1*
576 %{_mandir}/man1/ssh-agent.1*
577 %{_mandir}/man1/ssh-add.1*
578 %{_mandir}/man5/ssh_config.5*
579 %lang(it) %{_mandir}/it/man1/ssh.1*
580 %lang(it) %{_mandir}/it/man5/ssh_config.5*
581 %lang(pl) %{_mandir}/pl/man1/scp.1*
582 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
583
584 # for host-based auth (suid required for accessing private host key)
585 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
586 #%{_mandir}/man8/ssh-keysign.8*
587
588 %files server
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_sbindir}/sshd
591 %attr(755,root,root) %{_libexecdir}/sftp-server
592 %attr(755,root,root) %{_libexecdir}/ssh-keysign
593 %{_mandir}/man8/sshd.8*
594 %{_mandir}/man8/sftp-server.8*
595 %{_mandir}/man8/ssh-keysign.8*
596 %{_mandir}/man5/sshd_config.5*
597 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
598 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
599 %attr(640,root,root) %{_sysconfdir}/moduli
600 %attr(754,root,root) /etc/rc.d/init.d/sshd
601 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
602 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
603
604 %if %{with gnome} || %{with gtk}
605 %files gnome-askpass
606 %defattr(644,root,root,755)
607 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/GNOME_SSH_ASKPASS*
608 %dir %{_libexecdir}/ssh
609 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
610 %attr(755,root,root) %{_libexecdir}/ssh-askpass
611 %endif
This page took 0.10443 seconds and 4 git commands to generate.