]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- AC-branch merge: paths are already substituted by Makefile; rel 3
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
12 #
13 %if %{with hpn_none}
14 %undefine       with_hpn
15 %endif
16 # gtk2-based gnome-askpass means no gnome1-based
17 %{?with_gtk:%undefine with_gnome}
18 #
19 %define         _rel    3
20 #
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        4.7p1
33 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  50a800fd2c6def9e9a53068837e87b91
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Patch0:         %{name}-no_libnsl.patch
47 Patch1:         %{name}-linux-ipv6.patch
48 Patch2:         %{name}-pam_misc.patch
49 Patch3:         %{name}-sigpipe.patch
50 # http://www.opendarwin.org/projects/openssh-lpk/
51 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
52 Patch5:         %{name}-config.patch
53 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
54 Patch6:         %{name}-chroot.patch
55 Patch7:         %{name}-selinux.patch
56 # HPN patches rediffed due sigpipe patch.
57 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
58 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
59 Patch8:         %{name}-4.3p1-hpn11.patch
60 # Adds HPN (see p11) and an undocumented -z none cipher flag
61 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
62 Patch9:         %{name}-4.3p1-hpn11-none.patch
63 Patch10:        %{name}-include.patch
64 URL:            http://www.openssh.com/
65 BuildRequires:  %{__perl}
66 BuildRequires:  autoconf
67 BuildRequires:  automake
68 %{?with_gnome:BuildRequires:    gnome-libs-devel}
69 %{?with_gtk:BuildRequires:      gtk+2-devel}
70 %{?with_kerberos5:BuildRequires:        krb5-devel}
71 %{?with_libedit:BuildRequires:  libedit-devel}
72 %{?with_selinux:BuildRequires:  libselinux-devel}
73 BuildRequires:  libwrap-devel
74 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
75 BuildRequires:  openssl-devel >= 0.9.7d
76 BuildRequires:  pam-devel
77 %{?with_gtk:BuildRequires:      pkgconfig}
78 BuildRequires:  rpmbuild(macros) >= 1.318
79 BuildRequires:  zlib-devel
80 Requires:       filesystem >= 3.0-11
81 Requires:       pam >= 0.99.7.1
82 Obsoletes:      ssh
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     /etc/ssh
86 %define         _libexecdir     %{_libdir}/%{name}
87 %define         _privsepdir     /usr/share/empty
88
89 %description
90 Ssh (Secure Shell) a program for logging into a remote machine and for
91 executing commands in a remote machine. It is intended to replace
92 rlogin and rsh, and provide secure encrypted communications between
93 two untrusted hosts over an insecure network. X11 connections and
94 arbitrary TCP/IP ports can also be forwarded over the secure channel.
95
96 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
97 it up to date in terms of security and features, as well as removing
98 all patented algorithms to seperate libraries (OpenSSL).
99
100 This package includes the core files necessary for both the OpenSSH
101 client and server. To make this package useful, you should also
102 install openssh-clients, openssh-server, or both.
103 %if %{with hpn} || %{with hpn_none}
104 This release includes High Performance SSH/SCP patches from
105 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
106 to increase throughput on fast connections with high RTT (20-150 msec).
107 See the website for '-w' values for your connection and /proc/sys TCP
108 values. BTW. in a LAN you have got generally RTT < 1 msec.
109 %endif
110 %if %{with hpn_none}
111 It also includes an undocumented '-z' option which switches
112 the cipher to none after authentication is completed. Data is
113 still secured from tampering and corruption in transit through
114 the use of the Message Authentication Code (MAC).
115 This option will significantly reduce the number of cpu cycles used
116 by the SSH/SCP process. This may allow some users to see significant
117 improvement in (sniffable) data tranfer rates.
118 %endif
119
120 %description -l de.UTF-8
121 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
122 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
123 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
124 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
125 andere TCP/IP Ports können ebenso über den sicheren Channel
126 weitergeleitet werden.
127
128 %description -l es.UTF-8
129 SSH es un programa para accesar y ejecutar órdenes en computadores
130 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
131 seguro entre dos servidores en una red insegura. Conexiones X11 y
132 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
133 seguro.
134
135 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
136 continuar la última versión gratuita de SSH, actualizándolo en
137 términos de seguridad y recursos,así también eliminando todos los
138 algoritmos patentados y colocándolos en bibliotecas separadas
139 (OpenSSL).
140
141 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
142 también el paquete openssh-clients u openssh-server o ambos.
143
144 %description -l fr.UTF-8
145 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
146 remplace telnet, rlogin, rexec et rsh, tout en assurant des
147 communications cryptées securisées entre deux hôtes non fiabilisés sur
148 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
149 arbitraires peuvent également être transmis sur le canal sécurisé.
150
151 %description -l it.UTF-8
152 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
153 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
154 sicure e crittate tra due host non fidati su una rete non sicura. Le
155 connessioni X11 ad una porta TCP/IP arbitraria possono essere
156 inoltrate attraverso un canale sicuro.
157
158 %description -l pl.UTF-8
159 Ssh (Secure Shell) to program służący do logowania się na zdalną
160 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
161 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
162 pomiędzy dwoma hostami.
163
164 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
165 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
166 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
167 %if %{with hpn} || %{with hpn_none}
168 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
169 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
170 zwiększenie przepustowości transmisji dla szybkich połączeń
171 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
172 odpowednie dla danego połączenia wartości parametru '-w' oraz
173 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
174 %endif
175 %if %{with hpn_none}
176 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
177 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
178 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
179 stosowanie Message Authentication Code (MAC).
180 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
181 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
182 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
183 %endif
184
185 %description -l pt.UTF-8
186 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
187 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
188 cifradas entre duas máquinas sem confiança mútua sobre uma rede
189 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
190 reenviados pelo canal seguro.
191
192 %description -l pt_BR.UTF-8
193 SSH é um programa para acessar e executar comandos em máquinas
194 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
195 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
196 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
197
198 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
199 última versão gratuita do SSH, atualizando-o em termos de segurança e
200 recursos, assim como removendo todos os algoritmos patenteados e
201 colocando-os em bibliotecas separadas (OpenSSL).
202
203 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
204 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
205
206 %description -l ru.UTF-8
207 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
208 машину и для выполнения команд на удаленной машине. Она предназначена
209 для замены rlogin и rsh и обеспечивает безопасную шифрованную
210 коммуникацию между двумя хостами в сети, являющейся небезопасной.
211 Соединения X11 и любые порты TCP/IP могут также быть проведены через
212 безопасный канал.
213
214 OpenSSH - это переделка командой разработчиков OpenBSD последней
215 свободной версии SSH, доведенная до современного состояния в терминах
216 уровня безопасности и поддерживаемых возможностей. Все патентованные
217 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
218
219 Этот пакет содержит файлы, необходимые как для клиента, так и для
220 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
221 openssh-server, или оба пакета.
222
223 %description -l uk.UTF-8
224 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
225 машини та для виконання команд на віддаленій машині. Вона призначена
226 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
227 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
228 довільні порти TCP/IP можуть також бути проведені через безпечний
229 канал.
230
231 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
232 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
233 підтримуваних можливостей. Всі патентовані алгоритми винесені до
234 окремих бібліотек (OpenSSL).
235
236 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
237 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
238 openssh-server, чи обидва пакети.
239
240 %package clients
241 Summary:        OpenSSH Secure Shell protocol clients
242 Summary(es.UTF-8):      Clientes de OpenSSH
243 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
244 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
245 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
246 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
247 Group:          Applications/Networking
248 Provides:       ssh-clients
249 Requires:       %{name} = %{epoch}:%{version}-%{release}
250 Obsoletes:      ssh-clients
251
252 %description clients
253 Ssh (Secure Shell) a program for logging into a remote machine and for
254 executing commands in a remote machine. It is intended to replace
255 rlogin and rsh, and provide secure encrypted communications between
256 two untrusted hosts over an insecure network. X11 connections and
257 arbitrary TCP/IP ports can also be forwarded over the secure channel.
258
259 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
260 it up to date in terms of security and features, as well as removing
261 all patented algorithms to seperate libraries (OpenSSL).
262
263 This package includes the clients necessary to make encrypted
264 connections to SSH servers.
265
266 %description clients -l es.UTF-8
267 Este paquete incluye los clientes que se necesitan para hacer
268 conexiones codificadas con servidores SSH.
269
270 %description clients -l pl.UTF-8
271 Ssh (Secure Shell) to program służący do logowania się na zdalną
272 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
273 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
274 pomiędzy dwoma hostami.
275
276 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
277
278 %description clients -l pt_BR.UTF-8
279 Esse pacote inclui os clientes necessários para fazer conexões
280 encriptadas com servidores SSH.
281
282 %description clients -l ru.UTF-8
283 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
284 машину и для выполнения команд на удаленной машине.
285
286 Этот пакет содержит программы-клиенты, необходимые для установления
287 зашифрованных соединений с серверами SSH.
288
289 %description clients -l uk.UTF-8
290 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
291 машини та для виконання команд на віддаленій машині.
292
293 Цей пакет містить програми-клієнти, необхідні для встановлення
294 зашифрованих з'єднань з серверами SSH.
295
296 %package clients-agent-profile_d
297 Summary:        OpenSSH Secure Shell agent init script
298 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
299 Group:          Applications/Networking
300 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
301
302 %description clients-agent-profile_d
303 profile.d scripts for starting SSH agent.
304
305 %description clients-agent-profile_d -l pl.UTF-8
306 Skrypty profile.d do uruchamiania agenta SSH.
307
308 %package clients-agent-xinitrc
309 Summary:        OpenSSH Secure Shell agent init script
310 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
311 Group:          Applications/Networking
312 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
313 Requires:       xinitrc
314
315 %description clients-agent-xinitrc
316 xinitrc scripts for starting SSH agent.
317
318 %description clients-agent-xinitrc -l pl.UTF-8
319 Skrypty xinitrc do uruchamiania agenta SSH.
320
321 %package server
322 Summary:        OpenSSH Secure Shell protocol server (sshd)
323 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
324 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
325 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
326 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
327 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
328 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
329 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
330 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
331 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
332 Group:          Networking/Daemons
333 Provides:       ssh-server
334 Provides:       user(sshd)
335 Requires(post): chkconfig >= 0.9
336 Requires(post): grep
337 Requires(post,preun):   /sbin/chkconfig
338 Requires(postun):       /usr/sbin/userdel
339 Requires(pre):  /bin/id
340 Requires(pre):  /usr/sbin/useradd
341 Requires:       %{name} = %{epoch}:%{version}-%{release}
342 Requires:       /bin/login
343 Requires:       pam >= 0.99.7.1
344 Requires:       rc-scripts >= 0.4.0.18
345 Requires:       util-linux
346
347 %description server
348 Ssh (Secure Shell) a program for logging into a remote machine and for
349 executing commands in a remote machine. It is intended to replace
350 rlogin and rsh, and provide secure encrypted communications between
351 two untrusted hosts over an insecure network. X11 connections and
352 arbitrary TCP/IP ports can also be forwarded over the secure channel.
353
354 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
355 it up to date in terms of security and features, as well as removing
356 all patented algorithms to seperate libraries (OpenSSL).
357
358 This package contains the secure shell daemon. The sshd is the server
359 part of the secure shell protocol and allows ssh clients to connect to
360 your host.
361
362 %description server -l de.UTF-8
363 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
364
365 %description server -l es.UTF-8
366 Este paquete contiene el servidor SSH. sshd es la parte servidor del
367 protocolo secure shell y permite que clientes ssh se conecten a su
368 servidor.
369
370 %description server -l fr.UTF-8
371 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
372
373 %description server -l it.UTF-8
374 Questo pacchetto installa sshd, il server di OpenSSH.
375
376 %description server -l pl.UTF-8
377 Ssh (Secure Shell) to program służący do logowania się na zdalną
378 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
379 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
380 pomiędzy dwoma hostami.
381
382 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
383 ssh).
384
385 %description server -l pt.UTF-8
386 Este pacote intala o sshd, o servidor do OpenSSH.
387
388 %description server -l pt_BR.UTF-8
389 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
390 protocolo secure shell e permite que clientes ssh se conectem ao seu
391 host.
392
393 %description server -l ru.UTF-8
394 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
395 машину и для выполнения команд на удаленной машине.
396
397 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
398 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
399 вашим хостом.
400
401 %description server -l uk.UTF-8
402 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
403 машини та для виконання команд на віддаленій машині.
404
405 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
406 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
407 з вашим хостом.
408
409 %package gnome-askpass
410 Summary:        OpenSSH GNOME passphrase dialog
411 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
412 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
413 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
414 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
415 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
416 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
417 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
418 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
419 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
420 Group:          Applications/Networking
421 Requires:       %{name} = %{epoch}:%{version}-%{release}
422 Obsoletes:      openssh-askpass
423 Obsoletes:      ssh-askpass
424 Obsoletes:      ssh-extras
425
426 %description gnome-askpass
427 Ssh (Secure Shell) a program for logging into a remote machine and for
428 executing commands in a remote machine. It is intended to replace
429 rlogin and rsh, and provide secure encrypted communications between
430 two untrusted hosts over an insecure network. X11 connections and
431 arbitrary TCP/IP ports can also be forwarded over the secure channel.
432
433 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
434 it up to date in terms of security and features, as well as removing
435 all patented algorithms to seperate libraries (OpenSSL).
436
437 This package contains the GNOME passphrase dialog.
438
439 %description gnome-askpass -l es.UTF-8
440 Este paquete contiene un programa que abre una caja de diálogo para
441 entrada de passphrase en GNOME.
442
443 %description gnome-askpass -l pl.UTF-8
444 Ssh (Secure Shell) to program służący do logowania się na zdalną
445 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
446 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
447 pomiędzy dwoma hostami.
448
449 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
450
451 %description gnome-askpass -l pt_BR.UTF-8
452 Esse pacote contém um programa que abre uma caixa de diálogo para
453 entrada de passphrase no GNOME.
454
455 %description gnome-askpass -l ru.UTF-8
456 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
457 машину и для выполнения команд на удаленной машине.
458
459 Этот пакет содержит диалог ввода ключевой фразы для использования под
460 GNOME.
461
462 %description gnome-askpass -l uk.UTF-8
463 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
464 машини та для виконання команд на віддаленій машині.
465
466 Цей пакет містить діалог вводу ключової фрази для використання під
467 GNOME.
468
469 %prep
470 %setup -q
471 %patch0 -p1
472 %patch1 -p1
473 %patch2 -p1
474 %patch3 -p1
475 %{?with_ldap:%patch4 -p1}
476 %patch5 -p1
477 %patch6 -p1
478 %patch7 -p1
479 %{?with_hpn:%patch8 -p1}
480 %{?with_hpn_none:%patch9 -p1}
481 %patch10 -p1
482
483 %build
484 cp /usr/share/automake/config.sub .
485 %{__aclocal}
486 %{__autoconf}
487 %{?with_chroot:CPPFLAGS="-DCHROOT"}
488 %configure \
489         PERL=%{__perl} \
490         --with-dns \
491         --with-pam \
492         --with-mantype=man \
493         --with-md5-passwords \
494         --with-ipaddr-display \
495         %{?with_libedit:--with-libedit} \
496         --with-4in6 \
497         --disable-suid-ssh \
498         --with-tcp-wrappers \
499         %{?with_ldap:--with-libs="-lldap -llber"} \
500         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
501         %{?with_kerberos5:--with-kerberos5=/usr} \
502         --with-privsep-path=%{_privsepdir} \
503         --with-pid-dir=%{_localstatedir}/run \
504         --with-xauth=/usr/bin/xauth \
505         --enable-utmpx \
506         --enable-wtmpx
507
508 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
509
510 %{__make}
511
512 cd contrib
513 %if %{with gnome}
514 %{__make} gnome-ssh-askpass1 \
515         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
516 %endif
517 %if %{with gtk}
518 %{__make} gnome-ssh-askpass2 \
519         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520 %endif
521
522 %install
523 rm -rf $RPM_BUILD_ROOT
524 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
525         $RPM_BUILD_ROOT%{_libexecdir}/ssh
526 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
527
528 %{__make} install \
529         DESTDIR=$RPM_BUILD_ROOT
530
531 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
532
533 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
534 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
535 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
536 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
537 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
538 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
539
540 %if %{with gnome}
541 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
542 %endif
543 %if %{with gtk}
544 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
545 %endif
546 %if %{with gnome} || %{with gtk}
547 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
548 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
549 EOF
550 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
551 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
552 EOF
553 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
554 %endif
555
556 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
557 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
558
559 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
560
561 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
562 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
563 EOF
564
565 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
566 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %post clients
572 %env_update
573
574 %postun clients
575 %env_update
576
577 %post gnome-askpass
578 %env_update
579
580 %postun gnome-askpass
581 %env_update
582
583 %pre server
584 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
585
586 %post server
587 /sbin/chkconfig --add sshd
588 %service sshd reload "openssh daemon"
589 if ! grep -qs ssh /etc/security/passwd.conf ; then
590         umask 022
591         echo "ssh" >> /etc/security/passwd.conf
592 fi
593
594 %preun server
595 if [ "$1" = "0" ]; then
596         %service sshd stop
597         /sbin/chkconfig --del sshd
598 fi
599
600 %postun server
601 if [ "$1" = "0" ]; then
602         %userremove sshd
603 fi
604
605 %files
606 %defattr(644,root,root,755)
607 %doc *.RNG TODO README OVERVIEW CREDITS Change*
608 %attr(755,root,root) %{_bindir}/ssh-key*
609 %{_mandir}/man1/ssh-key*.1*
610 %dir %{_sysconfdir}
611 %dir %{_libexecdir}
612
613 %files clients
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_bindir}/ssh
616 %attr(755,root,root) %{_bindir}/slogin
617 %attr(755,root,root) %{_bindir}/sftp
618 %attr(755,root,root) %{_bindir}/ssh-agent
619 %attr(755,root,root) %{_bindir}/ssh-add
620 %attr(755,root,root) %{_bindir}/scp
621 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
622 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
623 %{_mandir}/man1/scp.1*
624 %{_mandir}/man1/ssh.1*
625 %{_mandir}/man1/slogin.1*
626 %{_mandir}/man1/sftp.1*
627 %{_mandir}/man1/ssh-agent.1*
628 %{_mandir}/man1/ssh-add.1*
629 %{_mandir}/man5/ssh_config.5*
630 %lang(it) %{_mandir}/it/man1/ssh.1*
631 %lang(it) %{_mandir}/it/man5/ssh_config.5*
632 %lang(pl) %{_mandir}/pl/man1/scp.1*
633 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
634
635 # for host-based auth (suid required for accessing private host key)
636 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
637 #%{_mandir}/man8/ssh-keysign.8*
638
639 %files clients-agent-profile_d
640 %defattr(644,root,root,755)
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
642 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
643
644 %files clients-agent-xinitrc
645 %defattr(644,root,root,755)
646 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
647
648 %files server
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_sbindir}/sshd
651 %attr(755,root,root) %{_libexecdir}/sftp-server
652 %attr(755,root,root) %{_libexecdir}/ssh-keysign
653 %{_mandir}/man8/sshd.8*
654 %{_mandir}/man8/sftp-server.8*
655 %{_mandir}/man8/ssh-keysign.8*
656 %{_mandir}/man5/sshd_config.5*
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
659 %attr(640,root,root) %{_sysconfdir}/moduli
660 %attr(754,root,root) /etc/rc.d/init.d/sshd
661 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
663
664 %if %{with gnome} || %{with gtk}
665 %files gnome-askpass
666 %defattr(644,root,root,755)
667 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
668 %dir %{_libexecdir}/ssh
669 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
670 %attr(755,root,root) %{_libexecdir}/ssh-askpass
671 %endif
This page took 0.153077 seconds and 4 git commands to generate.