]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- rel 1; replace lpk patch with maintained fedora ldap patch
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_without  ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13
14 %if "%{pld_release}" == "ac"
15 %define         pam_ver 0.79.0
16 %else
17 %define         pam_ver 0.99.7.1
18 %endif
19
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es.UTF-8):      Implementación libre de SSH
23 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
26 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR.UTF-8):   Implementação livre do SSH
28 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
29 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30 Name:           openssh
31 Version:        5.9p1
32 Release:        1
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  b50a499fa02616a47984b1920848b565
38 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
40 Source2:        %{name}d.init
41 Source3:        %{name}d.pamd
42 Source4:        %{name}.sysconfig
43 Source5:        ssh-agent.sh
44 Source6:        ssh-agent.conf
45 Source7:        %{name}-lpk.schema
46 Source8:        %{name}d.upstart
47 Patch100:       %{name}-heimdal.patch
48 Patch0:         %{name}-no_libnsl.patch
49 Patch2:         %{name}-pam_misc.patch
50 Patch3:         %{name}-sigpipe.patch
51 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
52 Patch4:         %{name}-5.9p1-ldap.patch
53 Patch5:         %{name}-5.9p1-ldap-fixes.patch
54 Patch6:         %{name}-config.patch
55 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
56 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
57 Patch9:         %{name}-5.2p1-hpn13v6.diff
58 Patch10:        %{name}-include.patch
59 Patch11:        %{name}-chroot.patch
60 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
61 Patch12:        %{name}-blacklist.diff
62 Patch13:        %{name}-kuserok.patch
63 URL:            http://www.openssh.com/portable.html
64 BuildRequires:  %{__perl}
65 BuildRequires:  autoconf
66 BuildRequires:  automake
67 %{?with_gnome:BuildRequires:    gnome-libs-devel}
68 %{?with_gtk:BuildRequires:      gtk+2-devel}
69 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
70 %{?with_libedit:BuildRequires:  libedit-devel}
71 %{?with_selinux:BuildRequires:  libselinux-devel}
72 BuildRequires:  libwrap-devel
73 %{?with_ldap:BuildRequires:     openldap-devel}
74 BuildRequires:  openssl-devel >= 0.9.7d
75 BuildRequires:  pam-devel
76 %{?with_gtk:BuildRequires:      pkgconfig}
77 BuildRequires:  rpm >= 4.4.9-56
78 BuildRequires:  rpmbuild(macros) >= 1.318
79 BuildRequires:  sed >= 4.0
80 BuildRequires:  zlib-devel
81 %if "%{pld_release}" == "ac"
82 Requires:       filesystem >= 2.0-1
83 Requires:       pam >= 0.79.0
84 %else
85 Requires:       filesystem >= 3.0-11
86 Requires:       pam >= %{pam_ver}
87 Suggests:       openssh-blacklist
88 Suggests:       xorg-app-xauth
89 %endif
90 Obsoletes:      ssh
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _sysconfdir     /etc/ssh
94 %define         _libexecdir     %{_libdir}/%{name}
95 %define         _privsepdir     /usr/share/empty
96 %define         schemadir       /usr/share/openldap/schema
97
98 %description
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine. It is intended to replace
101 rlogin and rsh, and provide secure encrypted communications between
102 two untrusted hosts over an insecure network. X11 connections and
103 arbitrary TCP/IP ports can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
106 it up to date in terms of security and features, as well as removing
107 all patented algorithms to seperate libraries (OpenSSL).
108
109 This package includes the core files necessary for both the OpenSSH
110 client and server. To make this package useful, you should also
111 install openssh-clients, openssh-server, or both.
112
113 %if %{with hpn}
114 This release includes High Performance SSH/SCP patches from
115 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
116 increase throughput on fast connections with high RTT (20-150 msec).
117 See the website for '-w' values for your connection and /proc/sys TCP
118 values. BTW. in a LAN you have got generally RTT < 1 msec.
119 %endif
120
121 %description -l de.UTF-8
122 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
124 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126 andere TCP/IP Ports können ebenso über den sicheren Channel
127 weitergeleitet werden.
128
129 %description -l es.UTF-8
130 SSH es un programa para accesar y ejecutar órdenes en computadores
131 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
132 seguro entre dos servidores en una red insegura. Conexiones X11 y
133 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
134 seguro.
135
136 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
137 continuar la última versión gratuita de SSH, actualizándolo en
138 términos de seguridad y recursos,así también eliminando todos los
139 algoritmos patentados y colocándolos en bibliotecas separadas
140 (OpenSSL).
141
142 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
143 también el paquete openssh-clients u openssh-server o ambos.
144
145 %description -l fr.UTF-8
146 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
147 remplace telnet, rlogin, rexec et rsh, tout en assurant des
148 communications cryptées securisées entre deux hôtes non fiabilisés sur
149 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150 arbitraires peuvent également être transmis sur le canal sécurisé.
151
152 %description -l it.UTF-8
153 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155 sicure e crittate tra due host non fidati su una rete non sicura. Le
156 connessioni X11 ad una porta TCP/IP arbitraria possono essere
157 inoltrate attraverso un canale sicuro.
158
159 %description -l pl.UTF-8
160 Ssh (Secure Shell) to program służący do logowania się na zdalną
161 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163 pomiędzy dwoma hostami.
164
165 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
168
169 %if %{with hpn}
170 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
171 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
172 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
173 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
174 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
175 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
176 %endif
177
178 %description -l pt.UTF-8
179 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
180 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
181 cifradas entre duas máquinas sem confiança mútua sobre uma rede
182 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
183 reenviados pelo canal seguro.
184
185 %description -l pt_BR.UTF-8
186 SSH é um programa para acessar e executar comandos em máquinas
187 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
188 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
189 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
190
191 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
192 última versão gratuita do SSH, atualizando-o em termos de segurança e
193 recursos, assim como removendo todos os algoritmos patenteados e
194 colocando-os em bibliotecas separadas (OpenSSL).
195
196 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
197 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
198
199 %description -l ru.UTF-8
200 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
201 машину и для выполнения команд на удаленной машине. Она предназначена
202 для замены rlogin и rsh и обеспечивает безопасную шифрованную
203 коммуникацию между двумя хостами в сети, являющейся небезопасной.
204 Соединения X11 и любые порты TCP/IP могут также быть проведены через
205 безопасный канал.
206
207 OpenSSH - это переделка командой разработчиков OpenBSD последней
208 свободной версии SSH, доведенная до современного состояния в терминах
209 уровня безопасности и поддерживаемых возможностей. Все патентованные
210 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
211
212 Этот пакет содержит файлы, необходимые как для клиента, так и для
213 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
214 openssh-server, или оба пакета.
215
216 %description -l uk.UTF-8
217 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
218 машини та для виконання команд на віддаленій машині. Вона призначена
219 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
220 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
221 довільні порти TCP/IP можуть також бути проведені через безпечний
222 канал.
223
224 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
225 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
226 підтримуваних можливостей. Всі патентовані алгоритми винесені до
227 окремих бібліотек (OpenSSL).
228
229 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
230 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
231 openssh-server, чи обидва пакети.
232
233 %package clients
234 Summary:        OpenSSH Secure Shell protocol clients
235 Summary(es.UTF-8):      Clientes de OpenSSH
236 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
237 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
238 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
239 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
240 Group:          Applications/Networking
241 Requires:       %{name}
242 Provides:       ssh-clients
243 Obsoletes:      ssh-clients
244
245 %description clients
246 Ssh (Secure Shell) a program for logging into a remote machine and for
247 executing commands in a remote machine. It is intended to replace
248 rlogin and rsh, and provide secure encrypted communications between
249 two untrusted hosts over an insecure network. X11 connections and
250 arbitrary TCP/IP ports can also be forwarded over the secure channel.
251
252 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
253 it up to date in terms of security and features, as well as removing
254 all patented algorithms to seperate libraries (OpenSSL).
255
256 This package includes the clients necessary to make encrypted
257 connections to SSH servers.
258
259 %description clients -l es.UTF-8
260 Este paquete incluye los clientes que se necesitan para hacer
261 conexiones codificadas con servidores SSH.
262
263 %description clients -l pl.UTF-8
264 Ssh (Secure Shell) to program służący do logowania się na zdalną
265 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
266 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
267 pomiędzy dwoma hostami.
268
269 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
270
271 %description clients -l pt_BR.UTF-8
272 Esse pacote inclui os clientes necessários para fazer conexões
273 encriptadas com servidores SSH.
274
275 %description clients -l ru.UTF-8
276 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
277 машину и для выполнения команд на удаленной машине.
278
279 Этот пакет содержит программы-клиенты, необходимые для установления
280 зашифрованных соединений с серверами SSH.
281
282 %description clients -l uk.UTF-8
283 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
284 машини та для виконання команд на віддаленій машині.
285
286 Цей пакет містить програми-клієнти, необхідні для встановлення
287 зашифрованих з'єднань з серверами SSH.
288
289 %package clients-agent-profile_d
290 Summary:        OpenSSH Secure Shell agent init script
291 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
292 Group:          Applications/Networking
293 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
294
295 %description clients-agent-profile_d
296 profile.d scripts for starting SSH agent.
297
298 %description clients-agent-profile_d -l pl.UTF-8
299 Skrypty profile.d do uruchamiania agenta SSH.
300
301 %package clients-agent-xinitrc
302 Summary:        OpenSSH Secure Shell agent init script
303 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
304 Group:          Applications/Networking
305 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
306 Requires:       xinitrc
307
308 %description clients-agent-xinitrc
309 xinitrc scripts for starting SSH agent.
310
311 %description clients-agent-xinitrc -l pl.UTF-8
312 Skrypty xinitrc do uruchamiania agenta SSH.
313
314 %package server
315 Summary:        OpenSSH Secure Shell protocol server (sshd)
316 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
317 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
318 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
319 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
320 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
321 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
322 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
323 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
324 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
325 Group:          Networking/Daemons
326 Requires(post): /sbin/chkconfig
327 Requires(post): grep
328 Requires(post,preun):   /sbin/chkconfig
329 Requires(postun):       /usr/sbin/userdel
330 Requires(pre):  /bin/id
331 Requires(pre):  /usr/sbin/useradd
332 Requires:       %{name} = %{epoch}:%{version}-%{release}
333 Requires:       pam >= %{pam_ver}
334 Requires:       rc-scripts >= 0.4.3.0
335 Requires:       util-linux
336 Suggests:       /bin/login
337 Provides:       ssh-server
338 Provides:       user(sshd)
339
340 %description server
341 Ssh (Secure Shell) a program for logging into a remote machine and for
342 executing commands in a remote machine. It is intended to replace
343 rlogin and rsh, and provide secure encrypted communications between
344 two untrusted hosts over an insecure network. X11 connections and
345 arbitrary TCP/IP ports can also be forwarded over the secure channel.
346
347 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
348 it up to date in terms of security and features, as well as removing
349 all patented algorithms to seperate libraries (OpenSSL).
350
351 This package contains the secure shell daemon. The sshd is the server
352 part of the secure shell protocol and allows ssh clients to connect to
353 your host.
354
355 %description server -l de.UTF-8
356 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
357
358 %description server -l es.UTF-8
359 Este paquete contiene el servidor SSH. sshd es la parte servidor del
360 protocolo secure shell y permite que clientes ssh se conecten a su
361 servidor.
362
363 %description server -l fr.UTF-8
364 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
365
366 %description server -l it.UTF-8
367 Questo pacchetto installa sshd, il server di OpenSSH.
368
369 %description server -l pl.UTF-8
370 Ssh (Secure Shell) to program służący do logowania się na zdalną
371 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
372 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
373 pomiędzy dwoma hostami.
374
375 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
376 ssh).
377
378 %description server -l pt.UTF-8
379 Este pacote intala o sshd, o servidor do OpenSSH.
380
381 %description server -l pt_BR.UTF-8
382 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
383 protocolo secure shell e permite que clientes ssh se conectem ao seu
384 host.
385
386 %description server -l ru.UTF-8
387 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
388 машину и для выполнения команд на удаленной машине.
389
390 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
391 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
392 вашим хостом.
393
394 %description server -l uk.UTF-8
395 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
396 машини та для виконання команд на віддаленій машині.
397
398 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
399 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
400 з вашим хостом.
401
402 %package server-upstart
403 Summary:        Upstart job description for OpenSSH server
404 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
405 Group:          Daemons
406 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
407 Requires:       upstart >= 0.6
408 Conflicts:      syslog-ng < 3.2.4-1
409
410 %description server-upstart
411 Upstart job description for OpenSSH.
412
413 %description server-upstart -l pl.UTF-8
414 Opis zadania Upstart dla OpenSSH.
415
416 %package gnome-askpass
417 Summary:        OpenSSH GNOME passphrase dialog
418 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
419 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
420 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
421 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
422 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
423 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
424 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
425 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
426 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
427 Group:          Applications/Networking
428 Requires:       %{name} = %{epoch}:%{version}-%{release}
429 Obsoletes:      openssh-askpass
430 Obsoletes:      ssh-askpass
431 Obsoletes:      ssh-extras
432
433 %description gnome-askpass
434 Ssh (Secure Shell) a program for logging into a remote machine and for
435 executing commands in a remote machine. It is intended to replace
436 rlogin and rsh, and provide secure encrypted communications between
437 two untrusted hosts over an insecure network. X11 connections and
438 arbitrary TCP/IP ports can also be forwarded over the secure channel.
439
440 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
441 it up to date in terms of security and features, as well as removing
442 all patented algorithms to seperate libraries (OpenSSL).
443
444 This package contains the GNOME passphrase dialog.
445
446 %description gnome-askpass -l es.UTF-8
447 Este paquete contiene un programa que abre una caja de diálogo para
448 entrada de passphrase en GNOME.
449
450 %description gnome-askpass -l pl.UTF-8
451 Ssh (Secure Shell) to program służący do logowania się na zdalną
452 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
453 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
454 pomiędzy dwoma hostami.
455
456 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
457
458 %description gnome-askpass -l pt_BR.UTF-8
459 Esse pacote contém um programa que abre uma caixa de diálogo para
460 entrada de passphrase no GNOME.
461
462 %description gnome-askpass -l ru.UTF-8
463 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
464 машину и для выполнения команд на удаленной машине.
465
466 Этот пакет содержит диалог ввода ключевой фразы для использования под
467 GNOME.
468
469 %description gnome-askpass -l uk.UTF-8
470 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
471 машини та для виконання команд на віддаленій машині.
472
473 Цей пакет містить діалог вводу ключової фрази для використання під
474 GNOME.
475
476 %package -n openldap-schema-openssh-lpk
477 Summary:        OpenSSH LDAP Public Key schema
478 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
479 Group:          Networking/Daemons
480 Requires(post,postun):  sed >= 4.0
481 Requires:       openldap-servers
482
483 %description -n openldap-schema-openssh-lpk
484 This package contains OpenSSH LDAP Public Key schema for openldap.
485
486 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
487 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
488 openldap-a.
489
490 %prep
491 %setup -q
492 %{?with_kerberos5:%patch100 -p1}
493 %patch0 -p1
494 %patch2 -p1
495 %patch3 -p1
496 %{?with_ldap:%patch4 -p1}
497 %patch5 -p1
498 %patch6 -p1
499 %{?with_hpn:%patch9 -p1}
500 %patch10 -p1
501 %patch11 -p1
502 %patch12 -p1
503 %patch13 -p1
504
505 cp -p %{SOURCE3} sshd.pam
506 install -p %{SOURCE2} sshd.init
507
508 %if "%{pld_release}" == "ac"
509 # fix for missing x11.pc
510 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
511 # not present in ac, no point searching it
512 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
513
514 # openssl on ac does not have OPENSSL_HAS_ECC
515 %{__sed} -i -e '/ecdsa/d' sshd.init
516 %endif
517
518 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
519 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
520
521 %build
522 cp /usr/share/automake/config.sub .
523 %{__aclocal}
524 %{__autoconf}
525 %{__autoheader}
526 CPPFLAGS="-DCHROOT"
527 %configure \
528         PERL=%{__perl} \
529         --with-pam \
530         --with-mantype=man \
531         --with-md5-passwords \
532         --with-ipaddr-display \
533         %{?with_libedit:--with-libedit} \
534         --with-4in6 \
535         --with-tcp-wrappers \
536         %{?with_ldap:--with-ldap} \
537         %{?with_kerberos5:--with-kerberos5=/usr} \
538         --with-privsep-path=%{_privsepdir} \
539         --with-pid-dir=%{_localstatedir}/run \
540 %if "%{pld_release}" == "ac"
541         --with-xauth=/usr/X11R6/bin/xauth \
542 %else
543         --with-xauth=%{_bindir}/xauth \
544 %endif
545         --enable-utmpx \
546         --enable-wtmpx
547
548 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
549
550 %{__make}
551
552 cd contrib
553 %if %{with gnome}
554 %{__make} gnome-ssh-askpass1 \
555         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
556 %endif
557 %if %{with gtk}
558 %{__make} gnome-ssh-askpass2 \
559         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
560 %endif
561
562 %install
563 rm -rf $RPM_BUILD_ROOT
564 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
565         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
566 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
567
568 %{__make} install \
569         DESTDIR=$RPM_BUILD_ROOT
570
571 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
572
573 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
574 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
575 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
576 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
577 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
578 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
579 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
580 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
581
582 %if %{with gnome}
583 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
584 %endif
585 %if %{with gtk}
586 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
587 %endif
588 %if %{with gnome} || %{with gtk}
589 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
590 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
591 EOF
592 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
593 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
594 EOF
595 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
596 %endif
597
598 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
599 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
600
601 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
602 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
603
604 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
605
606 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
607 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
608 EOF
609
610 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
611 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
612
613 %clean
614 rm -rf $RPM_BUILD_ROOT
615
616 %post clients
617 %env_update
618
619 %postun clients
620 %env_update
621
622 %post gnome-askpass
623 %env_update
624
625 %postun gnome-askpass
626 %env_update
627
628 %pre server
629 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
630
631 %post server
632 /sbin/chkconfig --add sshd
633 %service sshd reload "openssh daemon"
634 if ! grep -qs ssh /etc/security/passwd.conf ; then
635         umask 022
636         echo "ssh" >> /etc/security/passwd.conf
637 fi
638
639 %preun server
640 if [ "$1" = "0" ]; then
641         %service sshd stop
642         /sbin/chkconfig --del sshd
643 fi
644
645 %postun server
646 if [ "$1" = "0" ]; then
647         %userremove sshd
648 fi
649
650 %post server-upstart
651 %upstart_post sshd
652
653 %postun server-upstart
654 %upstart_postun sshd
655
656 %post -n openldap-schema-openssh-lpk
657 %openldap_schema_register %{schemadir}/openssh-lpk.schema
658 %service -q ldap restart
659
660 %postun -n openldap-schema-openssh-lpk
661 if [ "$1" = "0" ]; then
662         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
663         %service -q ldap restart
664 fi
665
666 %files
667 %defattr(644,root,root,755)
668 %doc TODO README OVERVIEW CREDITS Change*
669 %attr(755,root,root) %{_bindir}/ssh-key*
670 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
671 %{_mandir}/man1/ssh-key*.1*
672 %{_mandir}/man1/ssh-vulnkey*.1*
673 %dir %{_sysconfdir}
674 %dir %{_libexecdir}
675
676 %files clients
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_bindir}/ssh
679 %attr(755,root,root) %{_bindir}/slogin
680 %attr(755,root,root) %{_bindir}/sftp
681 %attr(755,root,root) %{_bindir}/ssh-agent
682 %attr(755,root,root) %{_bindir}/ssh-add
683 %attr(755,root,root) %{_bindir}/ssh-copy-id
684 %attr(755,root,root) %{_bindir}/scp
685 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
686 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
687 %{_mandir}/man1/scp.1*
688 %{_mandir}/man1/ssh.1*
689 %{_mandir}/man1/slogin.1*
690 %{_mandir}/man1/sftp.1*
691 %{_mandir}/man1/ssh-agent.1*
692 %{_mandir}/man1/ssh-add.1*
693 %{_mandir}/man1/ssh-copy-id.1*
694 %{_mandir}/man5/ssh_config.5*
695 %lang(it) %{_mandir}/it/man1/ssh.1*
696 %lang(it) %{_mandir}/it/man5/ssh_config.5*
697 %lang(pl) %{_mandir}/pl/man1/scp.1*
698 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
699
700 # for host-based auth (suid required for accessing private host key)
701 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
702 #%{_mandir}/man8/ssh-keysign.8*
703
704 %files clients-agent-profile_d
705 %defattr(644,root,root,755)
706 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
707 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
708
709 %files clients-agent-xinitrc
710 %defattr(644,root,root,755)
711 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
712
713 %files server
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_sbindir}/sshd
716 %attr(755,root,root) %{_libexecdir}/sftp-server
717 %attr(755,root,root) %{_libexecdir}/ssh-keysign
718 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
719 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
720 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
721 %{_mandir}/man8/sshd.8*
722 %{_mandir}/man8/sftp-server.8*
723 %{_mandir}/man8/ssh-keysign.8*
724 %{_mandir}/man8/ssh-ldap-helper.8*
725 %{_mandir}/man8/ssh-pkcs11-helper.8*
726 %{_mandir}/man5/sshd_config.5*
727 %{_mandir}/man5/ssh-ldap.conf.5*
728 %{_mandir}/man5/moduli.5*
729 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
730 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ldap.conf
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
732 %attr(640,root,root) %{_sysconfdir}/moduli
733 %attr(754,root,root) /etc/rc.d/init.d/sshd
734 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
736
737 %if %{with gnome} || %{with gtk}
738 %files gnome-askpass
739 %defattr(644,root,root,755)
740 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
741 %dir %{_libexecdir}/ssh
742 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
743 %attr(755,root,root) %{_libexecdir}/ssh-askpass
744 %endif
745
746 %if %{with ldap}
747 %files -n openldap-schema-openssh-lpk
748 %defattr(644,root,root,755)
749 %{schemadir}/openssh-lpk.schema
750 %endif
751
752 %if "%{pld_release}" != "ti"
753 %files server-upstart
754 %defattr(644,root,root,755)
755 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
756 %endif
This page took 1.50121 seconds and 4 git commands to generate.