]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- use hash known_hosts
[packages/openssh.git] / openssh.spec
1 # Conditional build:
2 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
3 %bcond_without  gtk             # without GTK+ (2.x)
4 %bcond_with     ldap            # with ldap support
5 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  selinux         # build without SELinux support
8 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12 #
13 Summary:        OpenSSH free Secure Shell (SSH) implementation
14 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
15 Summary(es.UTF-8):      Implementación libre de SSH
16 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
17 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
18 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
19 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20 Summary(pt_BR.UTF-8):   Implementação livre do SSH
21 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
22 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23 Name:           openssh
24 Version:        5.2p1
25 Release:        1
26 Epoch:          2
27 License:        BSD
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30 # Source0-md5:  ada79c7328a8551bdf55c95e631e7dad
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
33 Source2:        %{name}d.init
34 Source3:        %{name}d.pamd
35 Source4:        %{name}.sysconfig
36 Source5:        ssh-agent.sh
37 Source6:        ssh-agent.conf
38 Patch0:         %{name}-no_libnsl.patch
39 Patch2:         %{name}-pam_misc.patch
40 Patch3:         %{name}-sigpipe.patch
41 # http://www.opendarwin.org/projects/openssh-lpk/
42 Patch4:         %{name}-lpk-4.3p1-0.3.7.patch
43 Patch5:         %{name}-config.patch
44 Patch7:         %{name}-selinux.patch
45 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
46 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
47 Patch9:         %{name}-5.0p1-hpn13v4.diff
48 Patch10:        %{name}-include.patch
49 Patch11:        %{name}-chroot.patch
50 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
51 URL:            http://www.openssh.com/
52 BuildRequires:  %{__perl}
53 BuildRequires:  autoconf
54 BuildRequires:  automake
55 %{?with_gnome:BuildRequires:    gnome-libs-devel}
56 %{?with_gtk:BuildRequires:      gtk+2-devel}
57 %{?with_kerberos5:BuildRequires:        krb5-devel}
58 %{?with_libedit:BuildRequires:  libedit-devel}
59 %{?with_selinux:BuildRequires:  libselinux-devel}
60 BuildRequires:  libwrap-devel
61 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
62 BuildRequires:  openssl-devel >= 0.9.7d
63 BuildRequires:  pam-devel
64 %{?with_gtk:BuildRequires:      pkgconfig}
65 BuildRequires:  rpmbuild(macros) >= 1.318
66 BuildRequires:  zlib-devel
67 Requires:       filesystem >= 3.0-11
68 Requires:       pam >= 0.99.7.1
69 Suggests:       openssh-blacklist
70 Suggests:       xorg-app-xauth
71 Obsoletes:      ssh
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/ssh
75 %define         _libexecdir     %{_libdir}/%{name}
76 %define         _privsepdir     /usr/share/empty
77
78 %description
79 Ssh (Secure Shell) a program for logging into a remote machine and for
80 executing commands in a remote machine. It is intended to replace
81 rlogin and rsh, and provide secure encrypted communications between
82 two untrusted hosts over an insecure network. X11 connections and
83 arbitrary TCP/IP ports can also be forwarded over the secure channel.
84
85 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
86 it up to date in terms of security and features, as well as removing
87 all patented algorithms to seperate libraries (OpenSSL).
88
89 This package includes the core files necessary for both the OpenSSH
90 client and server. To make this package useful, you should also
91 install openssh-clients, openssh-server, or both.
92 %if %{with hpn} || %{with hpn_none}
93 This release includes High Performance SSH/SCP patches from
94 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
95 to increase throughput on fast connections with high RTT (20-150 msec).
96 See the website for '-w' values for your connection and /proc/sys TCP
97 values. BTW. in a LAN you have got generally RTT < 1 msec.
98 %endif
99 %if %{with hpn_none}
100 It also includes an undocumented '-z' option which switches
101 the cipher to none after authentication is completed. Data is
102 still secured from tampering and corruption in transit through
103 the use of the Message Authentication Code (MAC).
104 This option will significantly reduce the number of cpu cycles used
105 by the SSH/SCP process. This may allow some users to see significant
106 improvement in (sniffable) data tranfer rates.
107 %endif
108
109 %description -l de.UTF-8
110 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
111 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
112 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
113 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
114 andere TCP/IP Ports können ebenso über den sicheren Channel
115 weitergeleitet werden.
116
117 %description -l es.UTF-8
118 SSH es un programa para accesar y ejecutar órdenes en computadores
119 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
120 seguro entre dos servidores en una red insegura. Conexiones X11 y
121 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
122 seguro.
123
124 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
125 continuar la última versión gratuita de SSH, actualizándolo en
126 términos de seguridad y recursos,así también eliminando todos los
127 algoritmos patentados y colocándolos en bibliotecas separadas
128 (OpenSSL).
129
130 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
131 también el paquete openssh-clients u openssh-server o ambos.
132
133 %description -l fr.UTF-8
134 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
135 remplace telnet, rlogin, rexec et rsh, tout en assurant des
136 communications cryptées securisées entre deux hôtes non fiabilisés sur
137 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
138 arbitraires peuvent également être transmis sur le canal sécurisé.
139
140 %description -l it.UTF-8
141 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
142 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
143 sicure e crittate tra due host non fidati su una rete non sicura. Le
144 connessioni X11 ad una porta TCP/IP arbitraria possono essere
145 inoltrate attraverso un canale sicuro.
146
147 %description -l pl.UTF-8
148 Ssh (Secure Shell) to program służący do logowania się na zdalną
149 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
150 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
151 pomiędzy dwoma hostami.
152
153 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
154 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
155 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
156 %if %{with hpn} || %{with hpn_none}
157 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
158 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
159 zwiększenie przepustowości transmisji dla szybkich połączeń
160 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
161 odpowednie dla danego połączenia wartości parametru '-w' oraz
162 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
163 %endif
164 %if %{with hpn_none}
165 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
166 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
167 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
168 stosowanie Message Authentication Code (MAC).
169 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
170 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
171 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
172 %endif
173
174 %description -l pt.UTF-8
175 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
176 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
177 cifradas entre duas máquinas sem confiança mútua sobre uma rede
178 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
179 reenviados pelo canal seguro.
180
181 %description -l pt_BR.UTF-8
182 SSH é um programa para acessar e executar comandos em máquinas
183 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
184 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
185 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
186
187 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
188 última versão gratuita do SSH, atualizando-o em termos de segurança e
189 recursos, assim como removendo todos os algoritmos patenteados e
190 colocando-os em bibliotecas separadas (OpenSSL).
191
192 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
193 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
194
195 %description -l ru.UTF-8
196 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
197 машину и для выполнения команд на удаленной машине. Она предназначена
198 для замены rlogin и rsh и обеспечивает безопасную шифрованную
199 коммуникацию между двумя хостами в сети, являющейся небезопасной.
200 Соединения X11 и любые порты TCP/IP могут также быть проведены через
201 безопасный канал.
202
203 OpenSSH - это переделка командой разработчиков OpenBSD последней
204 свободной версии SSH, доведенная до современного состояния в терминах
205 уровня безопасности и поддерживаемых возможностей. Все патентованные
206 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
207
208 Этот пакет содержит файлы, необходимые как для клиента, так и для
209 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
210 openssh-server, или оба пакета.
211
212 %description -l uk.UTF-8
213 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
214 машини та для виконання команд на віддаленій машині. Вона призначена
215 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
216 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
217 довільні порти TCP/IP можуть також бути проведені через безпечний
218 канал.
219
220 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
221 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
222 підтримуваних можливостей. Всі патентовані алгоритми винесені до
223 окремих бібліотек (OpenSSL).
224
225 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
226 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
227 openssh-server, чи обидва пакети.
228
229 %package clients
230 Summary:        OpenSSH Secure Shell protocol clients
231 Summary(es.UTF-8):      Clientes de OpenSSH
232 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
233 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
234 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
235 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
236 Group:          Applications/Networking
237 Requires:       %{name} = %{epoch}:%{version}-%{release}
238 Provides:       ssh-clients
239 Obsoletes:      ssh-clients
240
241 %description clients
242 Ssh (Secure Shell) a program for logging into a remote machine and for
243 executing commands in a remote machine. It is intended to replace
244 rlogin and rsh, and provide secure encrypted communications between
245 two untrusted hosts over an insecure network. X11 connections and
246 arbitrary TCP/IP ports can also be forwarded over the secure channel.
247
248 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
249 it up to date in terms of security and features, as well as removing
250 all patented algorithms to seperate libraries (OpenSSL).
251
252 This package includes the clients necessary to make encrypted
253 connections to SSH servers.
254
255 %description clients -l es.UTF-8
256 Este paquete incluye los clientes que se necesitan para hacer
257 conexiones codificadas con servidores SSH.
258
259 %description clients -l pl.UTF-8
260 Ssh (Secure Shell) to program służący do logowania się na zdalną
261 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
262 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
263 pomiędzy dwoma hostami.
264
265 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
266
267 %description clients -l pt_BR.UTF-8
268 Esse pacote inclui os clientes necessários para fazer conexões
269 encriptadas com servidores SSH.
270
271 %description clients -l ru.UTF-8
272 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
273 машину и для выполнения команд на удаленной машине.
274
275 Этот пакет содержит программы-клиенты, необходимые для установления
276 зашифрованных соединений с серверами SSH.
277
278 %description clients -l uk.UTF-8
279 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
280 машини та для виконання команд на віддаленій машині.
281
282 Цей пакет містить програми-клієнти, необхідні для встановлення
283 зашифрованих з'єднань з серверами SSH.
284
285 %package clients-agent-profile_d
286 Summary:        OpenSSH Secure Shell agent init script
287 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
288 Group:          Applications/Networking
289 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
290
291 %description clients-agent-profile_d
292 profile.d scripts for starting SSH agent.
293
294 %description clients-agent-profile_d -l pl.UTF-8
295 Skrypty profile.d do uruchamiania agenta SSH.
296
297 %package clients-agent-xinitrc
298 Summary:        OpenSSH Secure Shell agent init script
299 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
300 Group:          Applications/Networking
301 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
302 Requires:       xinitrc
303
304 %description clients-agent-xinitrc
305 xinitrc scripts for starting SSH agent.
306
307 %description clients-agent-xinitrc -l pl.UTF-8
308 Skrypty xinitrc do uruchamiania agenta SSH.
309
310 %package server
311 Summary:        OpenSSH Secure Shell protocol server (sshd)
312 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
313 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
314 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
315 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
316 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
317 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
318 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
319 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
320 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
321 Group:          Networking/Daemons
322 Requires(post): chkconfig >= 0.9
323 Requires(post): grep
324 Requires(post,preun):   /sbin/chkconfig
325 Requires(postun):       /usr/sbin/userdel
326 Requires(pre):  /bin/id
327 Requires(pre):  /usr/sbin/useradd
328 Requires:       %{name} = %{epoch}:%{version}-%{release}
329 Requires:       /bin/login
330 Requires:       pam >= 0.99.7.1
331 Requires:       rc-scripts >= 0.4.1.23
332 Requires:       util-linux
333 Provides:       ssh-server
334 Provides:       user(sshd)
335
336 %description server
337 Ssh (Secure Shell) a program for logging into a remote machine and for
338 executing commands in a remote machine. It is intended to replace
339 rlogin and rsh, and provide secure encrypted communications between
340 two untrusted hosts over an insecure network. X11 connections and
341 arbitrary TCP/IP ports can also be forwarded over the secure channel.
342
343 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
344 it up to date in terms of security and features, as well as removing
345 all patented algorithms to seperate libraries (OpenSSL).
346
347 This package contains the secure shell daemon. The sshd is the server
348 part of the secure shell protocol and allows ssh clients to connect to
349 your host.
350
351 %description server -l de.UTF-8
352 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
353
354 %description server -l es.UTF-8
355 Este paquete contiene el servidor SSH. sshd es la parte servidor del
356 protocolo secure shell y permite que clientes ssh se conecten a su
357 servidor.
358
359 %description server -l fr.UTF-8
360 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
361
362 %description server -l it.UTF-8
363 Questo pacchetto installa sshd, il server di OpenSSH.
364
365 %description server -l pl.UTF-8
366 Ssh (Secure Shell) to program służący do logowania się na zdalną
367 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
368 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
369 pomiędzy dwoma hostami.
370
371 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
372 ssh).
373
374 %description server -l pt.UTF-8
375 Este pacote intala o sshd, o servidor do OpenSSH.
376
377 %description server -l pt_BR.UTF-8
378 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
379 protocolo secure shell e permite que clientes ssh se conectem ao seu
380 host.
381
382 %description server -l ru.UTF-8
383 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
384 машину и для выполнения команд на удаленной машине.
385
386 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
387 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
388 вашим хостом.
389
390 %description server -l uk.UTF-8
391 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
392 машини та для виконання команд на віддаленій машині.
393
394 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
395 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
396 з вашим хостом.
397
398 %package gnome-askpass
399 Summary:        OpenSSH GNOME passphrase dialog
400 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
401 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
402 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
403 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
404 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
405 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
406 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
407 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
408 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
409 Group:          Applications/Networking
410 Requires:       %{name} = %{epoch}:%{version}-%{release}
411 Obsoletes:      openssh-askpass
412 Obsoletes:      ssh-askpass
413 Obsoletes:      ssh-extras
414
415 %description gnome-askpass
416 Ssh (Secure Shell) a program for logging into a remote machine and for
417 executing commands in a remote machine. It is intended to replace
418 rlogin and rsh, and provide secure encrypted communications between
419 two untrusted hosts over an insecure network. X11 connections and
420 arbitrary TCP/IP ports can also be forwarded over the secure channel.
421
422 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
423 it up to date in terms of security and features, as well as removing
424 all patented algorithms to seperate libraries (OpenSSL).
425
426 This package contains the GNOME passphrase dialog.
427
428 %description gnome-askpass -l es.UTF-8
429 Este paquete contiene un programa que abre una caja de diálogo para
430 entrada de passphrase en GNOME.
431
432 %description gnome-askpass -l pl.UTF-8
433 Ssh (Secure Shell) to program służący do logowania się na zdalną
434 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
435 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
436 pomiędzy dwoma hostami.
437
438 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
439
440 %description gnome-askpass -l pt_BR.UTF-8
441 Esse pacote contém um programa que abre uma caixa de diálogo para
442 entrada de passphrase no GNOME.
443
444 %description gnome-askpass -l ru.UTF-8
445 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
446 машину и для выполнения команд на удаленной машине.
447
448 Этот пакет содержит диалог ввода ключевой фразы для использования под
449 GNOME.
450
451 %description gnome-askpass -l uk.UTF-8
452 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
453 машини та для виконання команд на віддаленій машині.
454
455 Цей пакет містить діалог вводу ключової фрази для використання під
456 GNOME.
457
458 %prep
459 %setup -q
460 %patch0 -p1
461 %patch2 -p1
462 %patch3 -p1
463 %{?with_ldap:%patch4 -p1}
464 %patch5 -p1
465 %patch7 -p1
466 %{?with_hpn:%patch9 -p1}
467 %patch10 -p1
468 %patch11 -p1
469 %patch12 -p1
470
471 %build
472 cp /usr/share/automake/config.sub .
473 %{__aclocal}
474 %{__autoconf}
475 CPPFLAGS="-DCHROOT"
476 %configure \
477         PERL=%{__perl} \
478         --with-dns \
479         --with-pam \
480         --with-mantype=man \
481         --with-md5-passwords \
482         --with-ipaddr-display \
483         %{?with_libedit:--with-libedit} \
484         --with-4in6 \
485         --disable-suid-ssh \
486         --with-tcp-wrappers \
487         %{?with_ldap:--with-libs="-lldap -llber"} \
488         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
489         %{?with_kerberos5:--with-kerberos5=/usr} \
490         --with-privsep-path=%{_privsepdir} \
491         --with-pid-dir=%{_localstatedir}/run \
492         --with-xauth=/usr/bin/xauth \
493         --enable-utmpx \
494         --enable-wtmpx
495
496 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
497
498 %{__make}
499
500 cd contrib
501 %if %{with gnome}
502 %{__make} gnome-ssh-askpass1 \
503         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
504 %endif
505 %if %{with gtk}
506 %{__make} gnome-ssh-askpass2 \
507         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
508 %endif
509
510 %install
511 rm -rf $RPM_BUILD_ROOT
512 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
513         $RPM_BUILD_ROOT%{_libexecdir}/ssh
514 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
515
516 %{__make} install \
517         DESTDIR=$RPM_BUILD_ROOT
518
519 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
520
521 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
522 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
523 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
524 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
525 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
526 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
527
528 %if %{with gnome}
529 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
530 %endif
531 %if %{with gtk}
532 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
533 %endif
534 %if %{with gnome} || %{with gtk}
535 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
536 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
537 EOF
538 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
539 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
540 EOF
541 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
542 %endif
543
544 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
545 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
546
547 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
548 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
549
550 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
551
552 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
553 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
554 EOF
555
556 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
557 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %post clients
563 %env_update
564
565 %postun clients
566 %env_update
567
568 %post gnome-askpass
569 %env_update
570
571 %postun gnome-askpass
572 %env_update
573
574 %pre server
575 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
576
577 %post server
578 /sbin/chkconfig --add sshd
579 %service sshd reload "openssh daemon"
580 if ! grep -qs ssh /etc/security/passwd.conf ; then
581         umask 022
582         echo "ssh" >> /etc/security/passwd.conf
583 fi
584
585 %preun server
586 if [ "$1" = "0" ]; then
587         %service sshd stop
588         /sbin/chkconfig --del sshd
589 fi
590
591 %postun server
592 if [ "$1" = "0" ]; then
593         %userremove sshd
594 fi
595
596 %files
597 %defattr(644,root,root,755)
598 %doc *.RNG TODO README OVERVIEW CREDITS Change*
599 %attr(755,root,root) %{_bindir}/ssh-key*
600 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
601 %{_mandir}/man1/ssh-key*.1*
602 %{_mandir}/man1/ssh-vulnkey*.1*
603 %dir %{_sysconfdir}
604 %dir %{_libexecdir}
605
606 %files clients
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/ssh
609 %attr(755,root,root) %{_bindir}/slogin
610 %attr(755,root,root) %{_bindir}/sftp
611 %attr(755,root,root) %{_bindir}/ssh-agent
612 %attr(755,root,root) %{_bindir}/ssh-add
613 %attr(755,root,root) %{_bindir}/ssh-copy-id
614 %attr(755,root,root) %{_bindir}/scp
615 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
616 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
617 %{_mandir}/man1/scp.1*
618 %{_mandir}/man1/ssh.1*
619 %{_mandir}/man1/slogin.1*
620 %{_mandir}/man1/sftp.1*
621 %{_mandir}/man1/ssh-agent.1*
622 %{_mandir}/man1/ssh-add.1*
623 %{_mandir}/man1/ssh-copy-id.1*
624 %{_mandir}/man5/ssh_config.5*
625 %lang(it) %{_mandir}/it/man1/ssh.1*
626 %lang(it) %{_mandir}/it/man5/ssh_config.5*
627 %lang(pl) %{_mandir}/pl/man1/scp.1*
628 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
629
630 # for host-based auth (suid required for accessing private host key)
631 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
632 #%{_mandir}/man8/ssh-keysign.8*
633
634 %files clients-agent-profile_d
635 %defattr(644,root,root,755)
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
637 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
638
639 %files clients-agent-xinitrc
640 %defattr(644,root,root,755)
641 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
642
643 %files server
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_sbindir}/sshd
646 %attr(755,root,root) %{_libexecdir}/sftp-server
647 %attr(755,root,root) %{_libexecdir}/ssh-keysign
648 %{_mandir}/man8/sshd.8*
649 %{_mandir}/man8/sftp-server.8*
650 %{_mandir}/man8/ssh-keysign.8*
651 %{_mandir}/man5/sshd_config.5*
652 %{_mandir}/man5/moduli.5*
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
655 %attr(640,root,root) %{_sysconfdir}/moduli
656 %attr(754,root,root) /etc/rc.d/init.d/sshd
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
659
660 %if %{with gnome} || %{with gtk}
661 %files gnome-askpass
662 %defattr(644,root,root,755)
663 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
664 %dir %{_libexecdir}/ssh
665 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
666 %attr(755,root,root) %{_libexecdir}/ssh-askpass
667 %endif
This page took 0.08231 seconds and 4 git commands to generate.