]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- added vars set with env.d
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # without gnome-askpass utility
4 %bcond_without  gtk             # without gtk (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  chroot          # without chrooted user environment support
8 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
9 #
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12 Summary:        OpenSSH free Secure Shell (SSH) implementation
13 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
14 Summary(es):    Implementación libre de SSH
15 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
16 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
17 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
18 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
19 Summary(pt_BR): Implementação livre do SSH
20 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
21 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
22 Name:           openssh
23 Version:        3.9p1
24 Release:        1
25 Epoch:          2
26 License:        BSD
27 Group:          Applications/Networking
28 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
29 # Source0-md5:  8e1774d0b52aff08f817f3987442a16e
30 Source1:        %{name}d.conf
31 Source2:        %{name}.conf
32 Source3:        %{name}d.init
33 Source4:        %{name}d.pamd
34 Source5:        %{name}.sysconfig
35 Source6:        passwd.pamd
36 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
37 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
38 Source9:        http://www.imasy.or.jp/~gotoh/ssh/connect.c
39 # NoSource9-md5:        c78de727e1208799072be78c05d64398
40 Source10:       http://www.imasy.or.jp/~gotoh/ssh/connect.html
41 # NoSource10-md5:       f14cb61fafd067a3f5ce4eaa9643bf05
42 Source11:       ssh-agent.sh
43 Source12:       ssh-agent.conf
44 Patch0:         %{name}-no_libnsl.patch
45 Patch2:         %{name}-linux-ipv6.patch
46 Patch3:         %{name}-pam_misc.patch
47 Patch4:         %{name}-sigpipe.patch
48 # http://ldappubkey.gcu-squad.org/
49 Patch5:         ldappubkey-ossh3.6-v2.patch
50 Patch6:         %{name}-heimdal.patch
51 Patch7:         %{name}-pam-conv.patch
52 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
53 Patch8:         %{name}-chroot.patch
54 Patch9:         %{name}-selinux.patch
55 Patch10:        %{name}-selinux-pld.patch
56 URL:            http://www.openssh.com/
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 %{?with_gnome:BuildRequires:    gnome-libs-devel}
60 %{?with_gtk:BuildRequires:      gtk+2-devel}
61 %{?with_kerberos5:BuildRequires:        heimdal-devel}
62 BuildRequires:  libselinux-devel
63 BuildRequires:  libwrap-devel
64 %{?with_ldap:BuildRequires:     openldap-devel}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 BuildRequires:  pam-devel
67 BuildRequires:  %{__perl}
68 %{?with_gtk:BuildRequires:      pkgconfig}
69 BuildRequires:  zlib-devel
70 PreReq:         FHS >= 2.1-24
71 PreReq:         openssl >= 0.9.7d
72 Obsoletes:      ssh
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/ssh
76 %define         _libexecdir     %{_libdir}/%{name}
77 %define         _privsepdir     /usr/share/empty
78
79 %description
80 Ssh (Secure Shell) a program for logging into a remote machine and for
81 executing commands in a remote machine. It is intended to replace
82 rlogin and rsh, and provide secure encrypted communications between
83 two untrusted hosts over an insecure network. X11 connections and
84 arbitrary TCP/IP ports can also be forwarded over the secure channel.
85
86 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
87 it up to date in terms of security and features, as well as removing
88 all patented algorithms to seperate libraries (OpenSSL).
89
90 This package includes the core files necessary for both the OpenSSH
91 client and server. To make this package useful, you should also
92 install openssh-clients, openssh-server, or both.
93
94 %description -l de
95 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
96 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
97 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
98 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
99 andere TCP/IP Ports können ebenso über den sicheren Channel
100 weitergeleitet werden.
101
102 %description -l es
103 SSH es un programa para accesar y ejecutar órdenes en computadores
104 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
105 seguro entre dos servidores en una red insegura. Conexiones X11 y
106 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
107 seguro.
108
109 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
110 continuar la última versión gratuita de SSH, actualizándolo en
111 términos de seguridad y recursos,así también eliminando todos los
112 algoritmos patentados y colocándolos en bibliotecas separadas
113 (OpenSSL).
114
115 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
116 también el paquete openssh-clients u openssh-server o ambos.
117
118 %description -l fr
119 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
120 remplace telnet, rlogin, rexec et rsh, tout en assurant des
121 communications cryptées securisées entre deux hôtes non fiabilisés sur
122 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
123 arbitraires peuvent également être transmis sur le canal sécurisé.
124
125 %description -l it
126 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
127 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
128 sicure e crittate tra due host non fidati su una rete non sicura. Le
129 connessioni X11 ad una porta TCP/IP arbitraria possono essere
130 inoltrate attraverso un canale sicuro.
131
132 %description -l pl
133 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
134 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
135 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
136 pomiedzy dwoma hostami.
137
138 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
139 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
140 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
141
142 %description -l pt
143 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
144 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
145 cifradas entre duas máquinas sem confiança mútua sobre uma rede
146 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
147 reenviados pelo canal seguro.
148
149 %description -l pt_BR
150 SSH é um programa para acessar e executar comandos em máquinas
151 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
152 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
153 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
154
155 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
156 última versão gratuita do SSH, atualizando-o em termos de segurança e
157 recursos, assim como removendo todos os algoritmos patenteados e
158 colocando-os em bibliotecas separadas (OpenSSL).
159
160 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
161 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
162
163 %description -l ru
164 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
165 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
166 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
167 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
168 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
169 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
170
171 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
172 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
173 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
174 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
175
176 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
177 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
178 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
179
180 %description -l uk
181 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
182 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
183 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
184 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
185 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
186 ËÁÎÁÌ.
187
188 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
189 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
190 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
191 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
192
193 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
194 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
195 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
196
197 %package clients
198 Summary:        OpenSSH Secure Shell protocol clients
199 Summary(es):    Clientes de OpenSSH
200 Summary(pl):    Klienci protoko³u Secure Shell
201 Summary(pt_BR): Clientes do OpenSSH
202 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
203 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
204 Group:          Applications/Networking
205 Requires:       %{name} = %{epoch}:%{version}-%{release}
206 %{?with_sshagentsh:Requires:    xinitrc}
207 Provides:       ssh-clients
208 Obsoletes:      ssh-clients
209
210 %description clients
211 Ssh (Secure Shell) a program for logging into a remote machine and for
212 executing commands in a remote machine. It is intended to replace
213 rlogin and rsh, and provide secure encrypted communications between
214 two untrusted hosts over an insecure network. X11 connections and
215 arbitrary TCP/IP ports can also be forwarded over the secure channel.
216
217 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
218 it up to date in terms of security and features, as well as removing
219 all patented algorithms to seperate libraries (OpenSSL).
220
221 This package includes the clients necessary to make encrypted
222 connections to SSH servers.
223
224 %description clients -l es
225 Este paquete incluye los clientes que se necesitan para hacer
226 conexiones codificadas con servidores SSH.
227
228 %description clients -l pl
229 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
230 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
231 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
232 pomiedzy dwoma hostami.
233
234 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
235
236 %description clients -l pt_BR
237 Esse pacote inclui os clientes necessários para fazer conexões
238 encriptadas com servidores SSH.
239
240 %description clients -l ru
241 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
242 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
243
244 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
245 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
246
247 %description clients -l uk
248 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
249 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
250
251 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
252 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
253
254 %package server
255 Summary:        OpenSSH Secure Shell protocol server (sshd)
256 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
257 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
258 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
259 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
260 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
261 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
262 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
263 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
264 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
265 Group:          Networking/Daemons
266 PreReq:         %{name} = %{epoch}:%{version}-%{release}
267 PreReq:         rc-scripts >= 0.3.1-15
268 Requires(pre):  /bin/id
269 Requires(pre):  /usr/sbin/useradd
270 Requires(post,preun):   /sbin/chkconfig
271 Requires(post): chkconfig >= 0.9
272 Requires(post): grep
273 Requires(postun):       /usr/sbin/userdel
274 Requires:       /bin/login
275 Requires:       util-linux
276 Requires:       pam >= 0.77.3
277 Provides:       ssh-server
278
279 %description server
280 Ssh (Secure Shell) a program for logging into a remote machine and for
281 executing commands in a remote machine. It is intended to replace
282 rlogin and rsh, and provide secure encrypted communications between
283 two untrusted hosts over an insecure network. X11 connections and
284 arbitrary TCP/IP ports can also be forwarded over the secure channel.
285
286 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
287 it up to date in terms of security and features, as well as removing
288 all patented algorithms to seperate libraries (OpenSSL).
289
290 This package contains the secure shell daemon. The sshd is the server
291 part of the secure shell protocol and allows ssh clients to connect to
292 your host.
293
294 %description server -l de
295 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
296
297 %description server -l es
298 Este paquete contiene el servidor SSH. sshd es la parte servidor del
299 protocolo secure shell y permite que clientes ssh se conecten a su
300 servidor.
301
302 %description server -l fr
303 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
304
305 %description server -l it
306 Questo pacchetto installa sshd, il server di OpenSSH.
307
308 %description server -l pl
309 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
310 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
311 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
312 pomiedzy dwoma hostami.
313
314 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
315 ssh).
316
317 %description server -l pt
318 Este pacote intala o sshd, o servidor do OpenSSH.
319
320 %description server -l pt_BR
321 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
322 protocolo secure shell e permite que clientes ssh se conectem ao seu
323 host.
324
325 %description server -l ru
326 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
327 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
328
329 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
330 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
331 ×ÁÛÉÍ ÈÏÓÔÏÍ.
332
333 %description server -l uk
334 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
335 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
336
337 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
338 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
339 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
340
341 %package gnome-askpass
342 Summary:        OpenSSH GNOME passphrase dialog
343 Summary(de):    OpenSSH GNOME Passwort-Dialog
344 Summary(es):    Diálogo para introducción de passphrase para GNOME
345 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
346 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
347 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
348 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
349 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
350 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
351 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
352 Group:          Applications/Networking
353 Requires:       %{name} = %{epoch}:%{version}-%{release}
354 Obsoletes:      ssh-extras
355 Obsoletes:      ssh-askpass
356 Obsoletes:      openssh-askpass
357
358 %description gnome-askpass
359 Ssh (Secure Shell) a program for logging into a remote machine and for
360 executing commands in a remote machine. It is intended to replace
361 rlogin and rsh, and provide secure encrypted communications between
362 two untrusted hosts over an insecure network. X11 connections and
363 arbitrary TCP/IP ports can also be forwarded over the secure channel.
364
365 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
366 it up to date in terms of security and features, as well as removing
367 all patented algorithms to seperate libraries (OpenSSL).
368
369 This package contains the GNOME passphrase dialog.
370
371 %description gnome-askpass -l es
372 Este paquete contiene un programa que abre una caja de diálogo para
373 entrada de passphrase en GNOME.
374
375 %description gnome-askpass -l pl
376 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
377 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
378 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
379 pomiedzy dwoma hostami.
380
381 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
382
383 %description gnome-askpass -l pt_BR
384 Esse pacote contém um programa que abre uma caixa de diálogo para
385 entrada de passphrase no GNOME.
386
387 %description gnome-askpass -l ru
388 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
389 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
390
391 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
392 GNOME.
393
394 %description gnome-askpass -l uk
395 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
396 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
397
398 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
399 GNOME.
400
401 %prep
402 %setup -q
403 %patch0 -p1
404 %patch2 -p1
405 %patch3 -p1
406 %patch4 -p1
407 %{?with_ldap:%patch5 -p1}
408 %{?with_kerberos5:%patch6 -p1}
409 #%patch7 -p1
410 %patch8 -p1
411 %patch9 -p1
412 %patch10 -p1
413
414 %build
415 cp %{_datadir}/automake/config.sub .
416 %{__aclocal}
417 %{__autoconf}
418 %{?with_chroot:CPPFLAGS="-DCHROOT"}
419 %configure \
420         PERL=%{__perl} \
421         --with-dns \
422         --with-pam \
423         --with-mantype=man \
424         --with-md5-passwords \
425         --with-ipaddr-display \
426         --with-4in6 \
427         --disable-suid-ssh \
428         --with-tcp-wrappers \
429         %{?with_ldap:--with-libs="-lldap -llber"} \
430         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
431         %{?with_kerberos5:--with-kerberos5} \
432         --with-privsep-path=%{_privsepdir} \
433         --with-pid-dir=%{_localstatedir}/run \
434         --with-xauth=/usr/X11R6/bin/xauth
435
436 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
437
438 %{__make}
439
440 cp -f %{SOURCE9} .
441 cp -f %{SOURCE10} .
442 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
443
444 cd contrib
445 %if %{with gnome}
446 %{__make} gnome-ssh-askpass1 \
447         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
448 %endif
449 %if %{with gtk}
450 %{__make} gnome-ssh-askpass2 \
451         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
452 %endif
453
454 %install
455 rm -rf $RPM_BUILD_ROOT
456 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
457         $RPM_BUILD_ROOT%{_libexecdir}/ssh
458 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
459
460 %{__make} install \
461         DESTDIR=$RPM_BUILD_ROOT
462
463 install connect    $RPM_BUILD_ROOT%{_bindir}
464 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
465 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
466 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
467 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
468 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
469 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
470 %if %{with sshagentsh}
471 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
472 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
473 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
474 %endif
475
476 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
477
478 %if %{with gnome}
479 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
480 %endif
481 %if %{with gtk}
482 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
483 %endif
484 %if %{with gnome} || %{with gtk}
485 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
486 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
487 EOF
488 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
489 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
490 EOF
491 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
492 %endif
493
494 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
495 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
496
497 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
498
499 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
500 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
501 EOF
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %pre server
507 if [ -n "`id -u sshd 2>/dev/null`" ]; then
508         if [ "`id -u sshd`" != "40" ]; then
509                 echo "Error: user sshd doesn't have uid=40. Correct this before installing ssh server." 1>&2
510                 exit 1
511         fi
512 else
513         /usr/sbin/useradd -u 40 -d %{_privsepdir} -s /bin/false -M -r -c "OpenSSH PrivSep User" -g nobody sshd 1>&2
514 fi
515
516 %post server
517 /sbin/chkconfig --add sshd
518 if [ -f /var/lock/subsys/sshd ]; then
519         /etc/rc.d/init.d/sshd restart 1>&2
520 else
521         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
522 fi
523 if ! grep -qs ssh /etc/security/passwd.conf ; then
524         umask 022
525         echo "ssh" >> /etc/security/passwd.conf
526 fi
527
528 %preun server
529 if [ "$1" = "0" ]; then
530         if [ -f /var/lock/subsys/sshd ]; then
531                 /etc/rc.d/init.d/sshd stop 1>&2
532         fi
533         /sbin/chkconfig --del sshd
534 fi
535
536 %postun server
537 if [ "$1" = "0" ]; then
538         /usr/sbin/userdel sshd
539 fi
540
541 %files
542 %defattr(644,root,root,755)
543 %doc *.RNG TODO README OVERVIEW CREDITS Change*
544 %attr(755,root,root) %{_bindir}/ssh-key*
545 %{_mandir}/man1/ssh-key*.1*
546 %dir %{_sysconfdir}
547
548 %files clients
549 %defattr(644,root,root,755)
550 %doc connect.html
551 %attr(755,root,root) %{_bindir}/connect
552 %attr(755,root,root) %{_bindir}/ssh
553 %attr(755,root,root) %{_bindir}/slogin
554 %attr(755,root,root) %{_bindir}/sftp
555 %attr(755,root,root) %{_bindir}/ssh-agent
556 %attr(755,root,root) %{_bindir}/ssh-add
557 %attr(755,root,root) %{_bindir}/scp
558 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
559 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/SSH_ASKPASS
560 %if %{with sshagentsh}
561 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh-agent.conf
562 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
563 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
564 %endif
565 %{_mandir}/man1/scp.1*
566 %{_mandir}/man1/ssh.1*
567 %{_mandir}/man1/slogin.1*
568 %{_mandir}/man1/sftp.1*
569 %{_mandir}/man1/ssh-agent.1*
570 %{_mandir}/man1/ssh-add.1*
571 %{_mandir}/man5/ssh_config.5*
572 %lang(it) %{_mandir}/it/man1/ssh.1*
573 %lang(it) %{_mandir}/it/man5/ssh_config.5*
574 %lang(pl) %{_mandir}/pl/man1/scp.1*
575 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
576
577 # for host-based auth (suid required for accessing private host key)
578 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
579 #%{_mandir}/man8/ssh-keysign.8*
580
581 %files server
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_sbindir}/sshd
584 %attr(755,root,root) %{_libexecdir}/sftp-server
585 %attr(755,root,root) %{_libexecdir}/ssh-keysign
586 %dir %{_libexecdir}
587 %{_mandir}/man8/sshd.8*
588 %{_mandir}/man8/sftp-server.8*
589 %{_mandir}/man8/ssh-keysign.8*
590 %{_mandir}/man5/sshd_config.5*
591 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
592 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
593 %attr(640,root,root) %{_sysconfdir}/moduli
594 %attr(754,root,root) /etc/rc.d/init.d/sshd
595 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
596 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
597
598 %if %{with gnome} || %{with gtk}
599 %files gnome-askpass
600 %defattr(644,root,root,755)
601 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/GNOME_SSH_ASKPASS*
602 %dir %{_libexecdir}/ssh
603 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
604 %attr(755,root,root) %{_libexecdir}/ssh-askpass
605 %endif
This page took 0.103295 seconds and 4 git commands to generate.