]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
3466ae539350b901903c1ccbf0c0965366933b17
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 #
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14 Summary:        OpenSSH free Secure Shell (SSH) implementation
15 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
16 Summary(es):    Implementación libre de SSH
17 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
18 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
19 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
20 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
21 Summary(pt_BR): Implementação livre do SSH
22 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
23 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
24 Name:           openssh
25 Version:        4.1p1
26 Release:        5
27 Epoch:          2
28 License:        BSD
29 Group:          Applications/Networking
30 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
31 # Source0-md5:  959c663e709c981f07a3315bfd64f3d0
32 Source1:        %{name}d.conf
33 Source2:        %{name}.conf
34 Source3:        %{name}d.init
35 Source4:        %{name}d.pamd
36 Source5:        %{name}.sysconfig
37 Source6:        passwd.pamd
38 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
39 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
40 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
41 # NoSource9-md5:        e1c3cbed88f08ea778d90813d48cd428
42 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
43 # NoSource10-md5:       ec74f3e3b2ea3a7dc84c7988235b6fcf
44 Source11:       ssh-agent.sh
45 Source12:       ssh-agent.conf
46 Patch0:         %{name}-no_libnsl.patch
47 Patch2:         %{name}-linux-ipv6.patch
48 Patch3:         %{name}-pam_misc.patch
49 Patch4:         %{name}-sigpipe.patch
50 # http://www.opendarwin.org/projects/openssh-lpk/
51 Patch5:         %{name}-lpk-4.0p1-0.3.patch
52 Patch6:         %{name}-heimdal.patch
53 Patch7:         %{name}-pam-conv.patch
54 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
55 Patch8:         %{name}-chroot.patch
56 Patch9:         %{name}-selinux.patch
57 Patch10:        %{name}-selinux-pld.patch
58 URL:            http://www.openssh.com/
59 BuildRequires:  autoconf
60 BuildRequires:  automake
61 %{?with_gnome:BuildRequires:    gnome-libs-devel}
62 %{?with_gtk:BuildRequires:      gtk+2-devel}
63 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
64 %{?with_libedit:BuildRequires:  libedit-devel}
65 %{?with_selinux:BuildRequires:  libselinux-devel}
66 BuildRequires:  libwrap-devel
67 %{?with_ldap:BuildRequires:     openldap-devel}
68 BuildRequires:  openssl-devel >= 0.9.7d
69 BuildRequires:  pam-devel
70 BuildRequires:  %{__perl}
71 %{?with_gtk:BuildRequires:      pkgconfig}
72 BuildRequires:  rpmbuild(macros) >= 1.202
73 BuildRequires:  zlib-devel
74 PreReq:         FHS >= 2.1-24
75 PreReq:         openssl >= 0.9.7d
76 Requires:       pam >= 0.79.0
77 Obsoletes:      ssh
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _sysconfdir     /etc/ssh
81 %define         _libexecdir     %{_libdir}/%{name}
82 %define         _privsepdir     /usr/share/empty
83
84 %description
85 Ssh (Secure Shell) a program for logging into a remote machine and for
86 executing commands in a remote machine. It is intended to replace
87 rlogin and rsh, and provide secure encrypted communications between
88 two untrusted hosts over an insecure network. X11 connections and
89 arbitrary TCP/IP ports can also be forwarded over the secure channel.
90
91 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
92 it up to date in terms of security and features, as well as removing
93 all patented algorithms to seperate libraries (OpenSSL).
94
95 This package includes the core files necessary for both the OpenSSH
96 client and server. To make this package useful, you should also
97 install openssh-clients, openssh-server, or both.
98
99 %description -l de
100 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
101 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
102 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
103 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
104 andere TCP/IP Ports können ebenso über den sicheren Channel
105 weitergeleitet werden.
106
107 %description -l es
108 SSH es un programa para accesar y ejecutar órdenes en computadores
109 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
110 seguro entre dos servidores en una red insegura. Conexiones X11 y
111 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
112 seguro.
113
114 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
115 continuar la última versión gratuita de SSH, actualizándolo en
116 términos de seguridad y recursos,así también eliminando todos los
117 algoritmos patentados y colocándolos en bibliotecas separadas
118 (OpenSSL).
119
120 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
121 también el paquete openssh-clients u openssh-server o ambos.
122
123 %description -l fr
124 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
125 remplace telnet, rlogin, rexec et rsh, tout en assurant des
126 communications cryptées securisées entre deux hôtes non fiabilisés sur
127 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
128 arbitraires peuvent également être transmis sur le canal sécurisé.
129
130 %description -l it
131 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
132 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
133 sicure e crittate tra due host non fidati su una rete non sicura. Le
134 connessioni X11 ad una porta TCP/IP arbitraria possono essere
135 inoltrate attraverso un canale sicuro.
136
137 %description -l pl
138 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
139 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
140 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
141 pomiêdzy dwoma hostami.
142
143 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
144 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
145 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
146
147 %description -l pt
148 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
149 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
150 cifradas entre duas máquinas sem confiança mútua sobre uma rede
151 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
152 reenviados pelo canal seguro.
153
154 %description -l pt_BR
155 SSH é um programa para acessar e executar comandos em máquinas
156 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
157 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
158 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
159
160 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
161 última versão gratuita do SSH, atualizando-o em termos de segurança e
162 recursos, assim como removendo todos os algoritmos patenteados e
163 colocando-os em bibliotecas separadas (OpenSSL).
164
165 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
166 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
167
168 %description -l ru
169 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
170 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
171 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
172 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
173 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
174 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
175
176 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
177 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
178 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
179 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
180
181 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
182 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
183 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
184
185 %description -l uk
186 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
187 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
188 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
189 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
190 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
191 ËÁÎÁÌ.
192
193 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
194 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
195 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
196 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
197
198 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
199 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
200 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
201
202 %package clients
203 Summary:        OpenSSH Secure Shell protocol clients
204 Summary(es):    Clientes de OpenSSH
205 Summary(pl):    Klienci protoko³u Secure Shell
206 Summary(pt_BR): Clientes do OpenSSH
207 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
208 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
209 Group:          Applications/Networking
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 %{?with_sshagentsh:Requires:    xinitrc}
212 Provides:       ssh-clients
213 Obsoletes:      ssh-clients
214
215 %description clients
216 Ssh (Secure Shell) a program for logging into a remote machine and for
217 executing commands in a remote machine. It is intended to replace
218 rlogin and rsh, and provide secure encrypted communications between
219 two untrusted hosts over an insecure network. X11 connections and
220 arbitrary TCP/IP ports can also be forwarded over the secure channel.
221
222 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
223 it up to date in terms of security and features, as well as removing
224 all patented algorithms to seperate libraries (OpenSSL).
225
226 This package includes the clients necessary to make encrypted
227 connections to SSH servers.
228
229 %description clients -l es
230 Este paquete incluye los clientes que se necesitan para hacer
231 conexiones codificadas con servidores SSH.
232
233 %description clients -l pl
234 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
235 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
236 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
237 pomiêdzy dwoma hostami.
238
239 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
240
241 %description clients -l pt_BR
242 Esse pacote inclui os clientes necessários para fazer conexões
243 encriptadas com servidores SSH.
244
245 %description clients -l ru
246 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
247 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
248
249 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
250 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
251
252 %description clients -l uk
253 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
254 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
255
256 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
257 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
258
259 %package server
260 Summary:        OpenSSH Secure Shell protocol server (sshd)
261 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
262 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
263 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
264 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
265 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
266 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
267 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
268 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
269 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
270 Group:          Networking/Daemons
271 PreReq:         %{name} = %{epoch}:%{version}-%{release}
272 PreReq:         rc-scripts >= 0.3.1-15
273 Requires(pre):  /bin/id
274 Requires(pre):  /usr/sbin/useradd
275 Requires(post,preun):   /sbin/chkconfig
276 Requires(post): chkconfig >= 0.9
277 Requires(post): grep
278 Requires(postun):       /usr/sbin/userdel
279 Requires:       /bin/login
280 Requires:       util-linux
281 Requires:       pam >= 0.77.3
282 Provides:       user(sshd)
283 Provides:       ssh-server
284
285 %description server
286 Ssh (Secure Shell) a program for logging into a remote machine and for
287 executing commands in a remote machine. It is intended to replace
288 rlogin and rsh, and provide secure encrypted communications between
289 two untrusted hosts over an insecure network. X11 connections and
290 arbitrary TCP/IP ports can also be forwarded over the secure channel.
291
292 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
293 it up to date in terms of security and features, as well as removing
294 all patented algorithms to seperate libraries (OpenSSL).
295
296 This package contains the secure shell daemon. The sshd is the server
297 part of the secure shell protocol and allows ssh clients to connect to
298 your host.
299
300 %description server -l de
301 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
302
303 %description server -l es
304 Este paquete contiene el servidor SSH. sshd es la parte servidor del
305 protocolo secure shell y permite que clientes ssh se conecten a su
306 servidor.
307
308 %description server -l fr
309 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
310
311 %description server -l it
312 Questo pacchetto installa sshd, il server di OpenSSH.
313
314 %description server -l pl
315 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
316 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
317 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
318 pomiêdzy dwoma hostami.
319
320 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
321 ssh).
322
323 %description server -l pt
324 Este pacote intala o sshd, o servidor do OpenSSH.
325
326 %description server -l pt_BR
327 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
328 protocolo secure shell e permite que clientes ssh se conectem ao seu
329 host.
330
331 %description server -l ru
332 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
333 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
334
335 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
336 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
337 ×ÁÛÉÍ ÈÏÓÔÏÍ.
338
339 %description server -l uk
340 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
341 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
342
343 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
344 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
345 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
346
347 %package gnome-askpass
348 Summary:        OpenSSH GNOME passphrase dialog
349 Summary(de):    OpenSSH GNOME Passwort-Dialog
350 Summary(es):    Diálogo para introducción de passphrase para GNOME
351 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
352 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
353 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
354 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
355 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
356 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
357 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
358 Group:          Applications/Networking
359 Requires:       %{name} = %{epoch}:%{version}-%{release}
360 Obsoletes:      ssh-extras
361 Obsoletes:      ssh-askpass
362 Obsoletes:      openssh-askpass
363
364 %description gnome-askpass
365 Ssh (Secure Shell) a program for logging into a remote machine and for
366 executing commands in a remote machine. It is intended to replace
367 rlogin and rsh, and provide secure encrypted communications between
368 two untrusted hosts over an insecure network. X11 connections and
369 arbitrary TCP/IP ports can also be forwarded over the secure channel.
370
371 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
372 it up to date in terms of security and features, as well as removing
373 all patented algorithms to seperate libraries (OpenSSL).
374
375 This package contains the GNOME passphrase dialog.
376
377 %description gnome-askpass -l es
378 Este paquete contiene un programa que abre una caja de diálogo para
379 entrada de passphrase en GNOME.
380
381 %description gnome-askpass -l pl
382 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
383 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
384 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
385 pomiêdzy dwoma hostami.
386
387 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
388
389 %description gnome-askpass -l pt_BR
390 Esse pacote contém um programa que abre uma caixa de diálogo para
391 entrada de passphrase no GNOME.
392
393 %description gnome-askpass -l ru
394 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
395 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
396
397 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
398 GNOME.
399
400 %description gnome-askpass -l uk
401 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
402 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
403
404 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
405 GNOME.
406
407 %prep
408 %setup -q
409 %patch0 -p1
410 %patch2 -p1
411 %patch3 -p1
412 %patch4 -p1
413 %{?with_ldap:%patch5 -p1}
414 %{?with_kerberos5:%patch6 -p1}
415 #%patch7 -p1
416 %patch8 -p1
417 %{?with_selinux:%patch9 -p1}
418 %{?with_selinux:%patch10 -p1}
419
420 %build
421 cp %{_datadir}/automake/config.sub .
422 %{__aclocal}
423 %{__autoconf}
424 %{?with_chroot:CPPFLAGS="-DCHROOT"}
425 %configure \
426         PERL=%{__perl} \
427         --with-dns \
428         --with-pam \
429         --with-mantype=man \
430         --with-md5-passwords \
431         --with-ipaddr-display \
432         %{?with_libedit:--with-libedit} \
433         --with-4in6 \
434         --disable-suid-ssh \
435         --with-tcp-wrappers \
436         %{?with_ldap:--with-libs="-lldap -llber"} \
437         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
438         %{?with_kerberos5:--with-kerberos5} \
439         --with-privsep-path=%{_privsepdir} \
440         --with-pid-dir=%{_localstatedir}/run \
441         --with-xauth=/usr/X11R6/bin/xauth
442
443 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
444
445 %{__make}
446
447 cp -f %{SOURCE9} .
448 cp -f %{SOURCE10} .
449 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
450
451 cd contrib
452 %if %{with gnome}
453 %{__make} gnome-ssh-askpass1 \
454         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
455 %endif
456 %if %{with gtk}
457 %{__make} gnome-ssh-askpass2 \
458         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
459 %endif
460
461 %install
462 rm -rf $RPM_BUILD_ROOT
463 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
464         $RPM_BUILD_ROOT%{_libexecdir}/ssh
465 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
466
467 %{__make} install \
468         DESTDIR=$RPM_BUILD_ROOT
469
470 install connect    $RPM_BUILD_ROOT%{_bindir}
471 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
472 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
473 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
474 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
475 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
476 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
477 %if %{with sshagentsh}
478 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
479 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
480 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
481 %endif
482
483 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
484
485 %if %{with gnome}
486 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
487 %endif
488 %if %{with gtk}
489 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
490 %endif
491 %if %{with gnome} || %{with gtk}
492 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
493 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
494 EOF
495 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
496 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
497 EOF
498 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
499 %endif
500
501 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
502 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
503
504 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
505
506 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
507 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
508 EOF
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513 %pre server
514 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
515
516 %post server
517 /sbin/chkconfig --add sshd
518 if [ -f /var/lock/subsys/sshd ]; then
519         /etc/rc.d/init.d/sshd restart 1>&2
520 else
521         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
522 fi
523 if ! grep -qs ssh /etc/security/passwd.conf ; then
524         umask 022
525         echo "ssh" >> /etc/security/passwd.conf
526 fi
527
528 %preun server
529 if [ "$1" = "0" ]; then
530         if [ -f /var/lock/subsys/sshd ]; then
531                 /etc/rc.d/init.d/sshd stop 1>&2
532         fi
533         /sbin/chkconfig --del sshd
534 fi
535
536 %postun server
537 if [ "$1" = "0" ]; then
538         %userremove sshd
539 fi
540
541 %files
542 %defattr(644,root,root,755)
543 %doc *.RNG TODO README OVERVIEW CREDITS Change*
544 %attr(755,root,root) %{_bindir}/ssh-key*
545 %{_mandir}/man1/ssh-key*.1*
546 %dir %{_sysconfdir}
547 %dir %{_libexecdir}
548
549 %files clients
550 %defattr(644,root,root,755)
551 %doc connect.html
552 %attr(755,root,root) %{_bindir}/connect
553 %attr(755,root,root) %{_bindir}/ssh
554 %attr(755,root,root) %{_bindir}/slogin
555 %attr(755,root,root) %{_bindir}/sftp
556 %attr(755,root,root) %{_bindir}/ssh-agent
557 %attr(755,root,root) %{_bindir}/ssh-add
558 %attr(755,root,root) %{_bindir}/scp
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
560 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
561 %if %{with sshagentsh}
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
563 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
564 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
565 %endif
566 %{_mandir}/man1/scp.1*
567 %{_mandir}/man1/ssh.1*
568 %{_mandir}/man1/slogin.1*
569 %{_mandir}/man1/sftp.1*
570 %{_mandir}/man1/ssh-agent.1*
571 %{_mandir}/man1/ssh-add.1*
572 %{_mandir}/man5/ssh_config.5*
573 %lang(it) %{_mandir}/it/man1/ssh.1*
574 %lang(it) %{_mandir}/it/man5/ssh_config.5*
575 %lang(pl) %{_mandir}/pl/man1/scp.1*
576 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
577
578 # for host-based auth (suid required for accessing private host key)
579 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
580 #%{_mandir}/man8/ssh-keysign.8*
581
582 %files server
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_sbindir}/sshd
585 %attr(755,root,root) %{_libexecdir}/sftp-server
586 %attr(755,root,root) %{_libexecdir}/ssh-keysign
587 %{_mandir}/man8/sshd.8*
588 %{_mandir}/man8/sftp-server.8*
589 %{_mandir}/man8/ssh-keysign.8*
590 %{_mandir}/man5/sshd_config.5*
591 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
592 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
593 %attr(640,root,root) %{_sysconfdir}/moduli
594 %attr(754,root,root) /etc/rc.d/init.d/sshd
595 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
597
598 %if %{with gnome} || %{with gtk}
599 %files gnome-askpass
600 %defattr(644,root,root,755)
601 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
602 %dir %{_libexecdir}/ssh
603 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
604 %attr(755,root,root) %{_libexecdir}/ssh-askpass
605 %endif
This page took 0.489296 seconds and 3 git commands to generate.