]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- added selinux support
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # without gnome-askpass utility
4 %bcond_without  gtk             # without gtk (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  chroot          # without chrooted user environment support
8
9 # default to gtk2-based gnome-askpass
10 %{?with_gtk:%define _without_gnome 1}
11 Summary:        OpenSSH free Secure Shell (SSH) implementation
12 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
13 Summary(es):    Implementación libre de SSH
14 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
15 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
16 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
17 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
18 Summary(pt_BR): Implementação livre do SSH
19 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
20 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
21 Name:           openssh
22 Version:        3.7.1p2
23 Release:        4.3
24 Epoch:          2
25 License:        BSD
26 Group:          Applications/Networking
27 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
28 # Source0-md5:  61cf5b059938718308836d00f6764a94
29 Source1:        %{name}d.conf
30 Source2:        %{name}.conf
31 Source3:        %{name}d.init
32 Source4:        %{name}d.pamd
33 Source5:        %{name}.sysconfig
34 Source6:        passwd.pamd
35 Source7:        %{name}-askpass.sh
36 Source8:        %{name}-askpass.csh
37 Source9:        http://www.imasy.or.jp/~gotoh/ssh/connect.c
38 # NoSource9-md5:        c78de727e1208799072be78c05d64398
39 Source10:       http://www.imasy.or.jp/~gotoh/ssh/connect.html
40 # NoSource10-md5:       f14cb61fafd067a3f5ce4eaa9643bf05
41 Patch0:         %{name}-no_libnsl.patch
42 Patch2:         %{name}-linux-ipv6.patch
43 Patch3:         %{name}-pam_misc.patch
44 Patch4:         %{name}-sigpipe.patch
45 # http://ldappubkey.gcu-squad.org/
46 Patch5:         ldappubkey-ossh3.6-v2.patch
47 Patch6:         %{name}-heimdal.patch
48 Patch7:         %{name}-pam-conv.patch
49 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
50 Patch8:         %{name}-chroot.patch
51 Patch9:         %{name}-selinux.patch
52 URL:            http://www.openssh.com/
53 BuildRequires:  autoconf
54 BuildRequires:  automake
55 %{?with_gnome:BuildRequires:    gnome-libs-devel}
56 %{?with_gtk:BuildRequires:      gtk+2-devel}
57 BuildRequires:  libwrap-devel
58 BuildRequires:  openssl-devel >= 0.9.7c
59 %{?with_ldap:BuildRequires:     openldap-devel}
60 %{?with_kerberos5:BuildRequires:        heimdal-devel}
61 BuildRequires:  pam-devel
62 BuildRequires:  %{__perl}
63 %{?with_gtk:BuildRequires:      pkgconfig}
64 BuildRequires:  zlib-devel
65 BuildRequires:  libselinux-devel
66 PreReq:         FHS >= 2.1-24
67 PreReq:         openssl >= 0.9.7c
68 Obsoletes:      ssh
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/ssh
72 %define         _libexecdir     %{_libdir}/%{name}
73 %define         _privsepdir     /usr/share/empty
74
75 %description
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine. It is intended to replace
78 rlogin and rsh, and provide secure encrypted communications between
79 two untrusted hosts over an insecure network. X11 connections and
80 arbitrary TCP/IP ports can also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
83 it up to date in terms of security and features, as well as removing
84 all patented algorithms to seperate libraries (OpenSSL).
85
86 This package includes the core files necessary for both the OpenSSH
87 client and server. To make this package useful, you should also
88 install openssh-clients, openssh-server, or both.
89
90 %description -l de
91 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
92 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
93 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
94 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
95 andere TCP/IP Ports können ebenso über den sicheren Channel
96 weitergeleitet werden.
97
98 %description -l es
99 SSH es un programa para accesar y ejecutar órdenes en computadores
100 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
101 seguro entre dos servidores en una red insegura. Conexiones X11 y
102 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
103 seguro.
104
105 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
106 continuar la última versión gratuita de SSH, actualizándolo en
107 términos de seguridad y recursos,así también eliminando todos los
108 algoritmos patentados y colocándolos en bibliotecas separadas
109 (OpenSSL).
110
111 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
112 también el paquete openssh-clients u openssh-server o ambos.
113
114 %description -l fr
115 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
116 remplace telnet, rlogin, rexec et rsh, tout en assurant des
117 communications cryptées securisées entre deux hôtes non fiabilisés sur
118 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
119 arbitraires peuvent également être transmis sur le canal sécurisé.
120
121 %description -l it
122 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
123 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
124 sicure e crittate tra due host non fidati su una rete non sicura. Le
125 connessioni X11 ad una porta TCP/IP arbitraria possono essere
126 inoltrate attraverso un canale sicuro.
127
128 %description -l pl
129 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
130 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
131 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
132 pomiedzy dwoma hostami.
133
134 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
135 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
136 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
137
138 %description -l pt
139 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
140 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
141 cifradas entre duas máquinas sem confiança mútua sobre uma rede
142 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
143 reenviados pelo canal seguro.
144
145 %description -l pt_BR
146 SSH é um programa para acessar e executar comandos em máquinas
147 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
148 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
149 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
150
151 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
152 última versão gratuita do SSH, atualizando-o em termos de segurança e
153 recursos, assim como removendo todos os algoritmos patenteados e
154 colocando-os em bibliotecas separadas (OpenSSL).
155
156 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
157 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
158
159 %description -l ru
160 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
161 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
162 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
163 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
164 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
165 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
166
167 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
168 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
169 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
170 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
171
172 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
173 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
174 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
175
176 %description -l uk
177 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
178 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
179 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
180 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
181 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
182 ËÁÎÁÌ.
183
184 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
185 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
186 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
187 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
188
189 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
190 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
191 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
192
193 %package clients
194 Summary:        OpenSSH Secure Shell protocol clients
195 Summary(es):    Clientes de OpenSSH
196 Summary(pl):    Klienci protoko³u Secure Shell
197 Summary(pt_BR): Clientes do OpenSSH
198 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
199 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
200 Group:          Applications/Networking
201 Provides:       ssh-clients
202 Requires:       %{name} = %{epoch}:%{version}
203 Obsoletes:      ssh-clients
204
205 %description clients
206 Ssh (Secure Shell) a program for logging into a remote machine and for
207 executing commands in a remote machine. It is intended to replace
208 rlogin and rsh, and provide secure encrypted communications between
209 two untrusted hosts over an insecure network. X11 connections and
210 arbitrary TCP/IP ports can also be forwarded over the secure channel.
211
212 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
213 it up to date in terms of security and features, as well as removing
214 all patented algorithms to seperate libraries (OpenSSL).
215
216 This package includes the clients necessary to make encrypted
217 connections to SSH servers.
218
219 %description clients -l es
220 Este paquete incluye los clientes que se necesitan para hacer
221 conexiones codificadas con servidores SSH.
222
223 %description clients -l pl
224 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
225 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
226 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
227 pomiedzy dwoma hostami.
228
229 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
230
231 %description clients -l pt_BR
232 Esse pacote inclui os clientes necessários para fazer conexões
233 encriptadas com servidores SSH.
234
235 %description clients -l ru
236 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
237 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
238
239 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
240 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
241
242 %description clients -l uk
243 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
244 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
245
246 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
247 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
248
249 %package server
250 Summary:        OpenSSH Secure Shell protocol server (sshd)
251 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
252 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
253 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
254 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
255 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
256 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
257 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
258 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
259 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
260 Group:          Networking/Daemons
261 PreReq:         %{name} = %{epoch}:%{version}
262 PreReq:         rc-scripts >= 0.3.1-15
263 Requires(pre):  /bin/id
264 Requires(pre):  /usr/sbin/useradd
265 Requires(post,preun):   /sbin/chkconfig
266 Requires(post): chkconfig >= 0.9
267 Requires(post): grep
268 Requires(postun):       /usr/sbin/userdel
269 Requires:       /bin/login
270 Requires:       util-linux
271 Requires:       pam >= 0.77.3
272 Provides:       ssh-server
273
274 %description server
275 Ssh (Secure Shell) a program for logging into a remote machine and for
276 executing commands in a remote machine. It is intended to replace
277 rlogin and rsh, and provide secure encrypted communications between
278 two untrusted hosts over an insecure network. X11 connections and
279 arbitrary TCP/IP ports can also be forwarded over the secure channel.
280
281 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
282 it up to date in terms of security and features, as well as removing
283 all patented algorithms to seperate libraries (OpenSSL).
284
285 This package contains the secure shell daemon. The sshd is the server
286 part of the secure shell protocol and allows ssh clients to connect to
287 your host.
288
289 %description server -l de
290 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
291
292 %description server -l es
293 Este paquete contiene el servidor SSH. sshd es la parte servidor del
294 protocolo secure shell y permite que clientes ssh se conecten a su
295 servidor.
296
297 %description server -l fr
298 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
299
300 %description server -l it
301 Questo pacchetto installa sshd, il server di OpenSSH.
302
303 %description server -l pl
304 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
305 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
306 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
307 pomiedzy dwoma hostami.
308
309 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
310 ssh).
311
312 %description server -l pt
313 Este pacote intala o sshd, o servidor do OpenSSH.
314
315 %description server -l pt_BR
316 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
317 protocolo secure shell e permite que clientes ssh se conectem ao seu
318 host.
319
320 %description server -l ru
321 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
322 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
323
324 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
325 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
326 ×ÁÛÉÍ ÈÏÓÔÏÍ.
327
328 %description server -l uk
329 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
330 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
331
332 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
333 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
334 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
335
336 %package gnome-askpass
337 Summary:        OpenSSH GNOME passphrase dialog
338 Summary(de):    OpenSSH GNOME Passwort-Dialog
339 Summary(es):    Diálogo para introducción de passphrase para GNOME
340 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
341 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
342 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
343 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
344 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
345 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
346 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
347 Group:          Applications/Networking
348 Requires:       %{name} = %{epoch}:%{version}
349 Obsoletes:      ssh-extras
350 Obsoletes:      ssh-askpass
351 Obsoletes:      openssh-askpass
352
353 %description gnome-askpass
354 Ssh (Secure Shell) a program for logging into a remote machine and for
355 executing commands in a remote machine. It is intended to replace
356 rlogin and rsh, and provide secure encrypted communications between
357 two untrusted hosts over an insecure network. X11 connections and
358 arbitrary TCP/IP ports can also be forwarded over the secure channel.
359
360 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
361 it up to date in terms of security and features, as well as removing
362 all patented algorithms to seperate libraries (OpenSSL).
363
364 This package contains the GNOME passphrase dialog.
365
366 %description gnome-askpass -l es
367 Este paquete contiene un programa que abre una caja de diálogo para
368 entrada de passphrase en GNOME.
369
370 %description gnome-askpass -l pl
371 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
372 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
373 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
374 pomiedzy dwoma hostami.
375
376 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
377
378 %description gnome-askpass -l pt_BR
379 Esse pacote contém um programa que abre uma caixa de diálogo para
380 entrada de passphrase no GNOME.
381
382 %description gnome-askpass -l ru
383 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
384 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
385
386 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
387 GNOME.
388
389 %description gnome-askpass -l uk
390 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
391 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
392
393 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
394 GNOME.
395
396 %prep
397 %setup -q
398 %patch0 -p1
399 %patch2 -p1
400 %patch3 -p1
401 #%patch4 -p1
402 %{?with_ldap:%patch5 -p1}
403 %{?with_kerberos5:%patch6 -p1}
404 %patch7 -p1
405 %patch8 -p1
406 %patch9 -p1
407
408 %build
409 cp /usr/share/automake/config.sub .
410 %{__aclocal}
411 %{__autoconf}
412 %{?with_chroot:CPPFLAGS="-DCHROOT"}
413 %configure \
414         PERL=%{__perl} \
415         --with-dns \
416         --with-pam \
417         --with-mantype=man \
418         --with-md5-passwords \
419         --with-ipaddr-display \
420         --with-4in6 \
421         --disable-suid-ssh \
422         --with-tcp-wrappers \
423         %{?with_ldap:--with-libs="-lldap -llber"} \
424         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
425         %{?with_kerberos5:--with-kerberos5} \
426         --with-privsep-path=%{_privsepdir} \
427         --with-pid-dir=%{_localstatedir}/run \
428         --with-xauth=/usr/X11R6/bin/xauth
429
430 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
431
432 %{__make}
433
434 cp -f %{SOURCE9} .
435 cp -f %{SOURCE10} .
436 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
437
438 cd contrib
439 %if %{with gnome}
440 %{__make} gnome-ssh-askpass1 \
441         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
442 %endif
443 %if %{with gtk}
444 %{__make} gnome-ssh-askpass2 \
445         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
446 %endif
447
448 %install
449 rm -rf $RPM_BUILD_ROOT
450 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,profile.d}} \
451         $RPM_BUILD_ROOT%{_libexecdir}/ssh
452
453 %{__make} install \
454         DESTDIR=$RPM_BUILD_ROOT
455         
456 install connect    $RPM_BUILD_ROOT%{_bindir}
457 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
458 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
459 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
460 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
461 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
462 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
463
464 %if %{with gnome}
465 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
466 %endif
467 %if %{with gtk}
468 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
469 %endif
470 %if %{with gnome}%{with gtk}
471 install %{SOURCE7} %{SOURCE8} $RPM_BUILD_ROOT/etc/profile.d
472 %endif
473
474 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
475 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
476
477 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
478
479 %clean
480 rm -rf $RPM_BUILD_ROOT
481
482 %pre server
483 if [ -n "`id -u sshd 2>/dev/null`" ]; then
484         if [ "`id -u sshd`" != "40" ]; then
485                 echo "Error: user sshd doesn't have uid=40. Correct this before installing ssh server." 1>&2
486                 exit 1
487         fi
488 else
489         /usr/sbin/useradd -u 40 -d %{_privsepdir} -s /bin/false -M -r -c "OpenSSH PrivSep User" -g nobody sshd 1>&2
490 fi
491
492 %post server
493 /sbin/chkconfig --add sshd
494 if [ -f /var/lock/subsys/sshd ]; then
495         /etc/rc.d/init.d/sshd restart 1>&2
496 else
497         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
498 fi
499 if ! grep -qs ssh /etc/security/passwd.conf ; then
500         umask 022
501         echo "ssh" >> /etc/security/passwd.conf
502 fi
503
504 %preun server
505 if [ "$1" = "0" ]; then
506         if [ -f /var/lock/subsys/sshd ]; then
507                 /etc/rc.d/init.d/sshd stop 1>&2
508         fi
509         /sbin/chkconfig --del sshd
510 fi
511
512 %postun server
513 if [ "$1" = "0" ]; then
514         /usr/sbin/userdel sshd
515 fi
516
517 %files
518 %defattr(644,root,root,755)
519 %doc *.RNG TODO README OVERVIEW CREDITS Change*
520 %attr(755,root,root) %{_bindir}/ssh-key*
521 %{_mandir}/man1/ssh-key*.1*
522 %dir %{_sysconfdir}
523
524 %files clients
525 %defattr(644,root,root,755)
526 %doc connect.html
527 %attr(0755,root,root) %{_bindir}/connect
528 %attr(0755,root,root) %{_bindir}/ssh
529 %attr(0755,root,root) %{_bindir}/slogin
530 %attr(0755,root,root) %{_bindir}/sftp
531 %attr(0755,root,root) %{_bindir}/ssh-agent
532 %attr(0755,root,root) %{_bindir}/ssh-add
533 %attr(0755,root,root) %{_bindir}/scp
534 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
535 %{_mandir}/man1/scp.1*
536 %{_mandir}/man1/ssh.1*
537 %{_mandir}/man1/slogin.1*
538 %{_mandir}/man1/sftp.1*
539 %{_mandir}/man1/ssh-agent.1*
540 %{_mandir}/man1/ssh-add.1*
541 %{_mandir}/man5/ssh_config.5*
542
543 # for host-based auth (suid required for accessing private host key)
544 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
545 #%{_mandir}/man8/ssh-keysign.8*
546
547 %files server
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_sbindir}/sshd
550 %attr(755,root,root) %{_libexecdir}/sftp-server
551 %attr(755,root,root) %{_libexecdir}/ssh-keysign
552 %dir %{_libexecdir}
553 %{_mandir}/man8/sshd.8*
554 %{_mandir}/man8/sftp-server.8*
555 %{_mandir}/man8/ssh-keysign.8*
556 %{_mandir}/man5/sshd_config.5*
557 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
558 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
559 %attr(640,root,root) %{_sysconfdir}/moduli
560 %attr(754,root,root) /etc/rc.d/init.d/sshd
561 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
562 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
563
564 %if %{with gnome}%{with gtk}
565 %files gnome-askpass
566 %defattr(644,root,root,755)
567 %dir %{_libexecdir}/ssh
568 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
569 %attr(755,root,root) /etc/profile.d/*
570 %endif
This page took 0.077605 seconds and 3 git commands to generate.