]> git.pld-linux.org Git - packages/openjade.git/blob - openjade.spec
- fix for stupid types size assumptions
[packages/openjade.git] / openjade.spec
1 %define         snap    20020409
2 Summary:        OpenJade -- DSSSL parser
3 Summary(pl):    OpenJade -- parser DSSSL
4 Name:           openjade
5 Version:        1.4
6 Release:        10.%{snap}
7 License:        Free (Copyright (C) 1999 The OpenJade group)
8 Group:          Applications/Publishing/SGML
9 Source0:        %{name}-%{snap}.tar.gz
10 Patch0:         %{name}-table.patch
11 Patch1:         %{name}-ac25x.patch
12 URL:            http://openjade.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  gettext-devel
17 BuildRequires:  opensp-devel >= 1.5pre5
18 BuildRequires:  perl
19 Provides:       jade
20 Provides:       dssslparser
21 Requires:       sgmlparser
22 Requires:       opensp >= 1.5pre5
23 Prereq:         sgml-common
24 Prereq:         /sbin/ldconfig
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      jade
27
28 %description
29 Jade (James' DSSSL Engine) is an implementation of the DSSSL style
30 language. OpenJade is successor of Jade.
31
32 %description -l pl
33 Jade (James' DSSSL Engine) jest implementacj± parsera DSSSL. OpenJade
34 jest nastêpc± Jade.
35
36 %package devel
37 Summary:        OpenJade header files
38 Summary(pl):    Pliki nag³ówkowe do bibliotek OpenJade
39 Group:          Development/Libraries
40 Prereq:         /sbin/ldconfig
41 Requires:       %{name} = %{version}
42
43 %description devel
44 Openjade header files.
45
46 %description devel -l pl
47 Pliki nag³ówkowe do bibliotek OpenJade.
48
49 %package static
50 Summary:        OpenJade static libraries
51 Summary(pl):    Biblioteki statyczne OpenJade
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}
54
55 %description static
56 OpenJade static libraries.
57
58 %description static -l pl
59 Biblioteki statyczne OpenJade.
60
61 %prep
62 %setup -q -n %{name}-%{snap}
63 %patch0 -p0
64 %patch1 -p1
65
66 %build
67 #remove CVS dirs
68 find . -type d -name CVS | xargs rm -rf
69 #missing files required by Makefile.am
70 touch ChangeLog
71 %{__gettextize}
72 %{__libtoolize}
73 aclocal
74 echo "#undef SIZEOF_WCHAR_T" >> acconfig.h
75 autoheader
76 %{__automake}
77 #aclocal
78 %{__autoconf}
79 %ifarch alpha
80 CXXFLAGS="-O0 %{?debug:-g}"
81 %endif
82 %configure \
83         --enable-default-catalog=/etc/sgml/catalog \
84         --enable-default-search-path=/usr/share/sgml
85
86 # it has /usr/share/Openjade hardcoded somewhere so it does not work
87         # --datadir=%{_datadir}/sgml
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_datadir}/sgml
94
95 %{__make} install DESTDIR=$RPM_BUILD_ROOT
96
97 cp -a unicode $RPM_BUILD_ROOT%{_datadir}/sgml
98 ln -sf "../OpenJade" $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}-%{version}
99
100 ##ln -s "../OpenJade" $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}
101 #install dsssl/catalog \
102 #       dsssl/builtins.dsl dsssl/extensions.dsl \
103 #       dsssl/dsssl.dtd dsssl/fot.dtd dsssl/spec.dtd dsssl/style-sheet.dtd \
104 #       $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}-%{version}/
105 #grep -v SYSTEM $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}/catalog > \
106 #       $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}/%{name}.cat
107
108
109 # simulate jade
110 ln -sf openjade $RPM_BUILD_ROOT%{_bindir}/jade
111
112 gzip -9nf COPYING README
113
114 %find_lang OpenJade
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 /sbin/ldconfig
121 /usr/bin/install-catalog --add /etc/sgml/dsssl-%{version}-%{release}.cat \
122         %{_datadir}/sgml/%{name}-%{version}/catalog
123 /usr/bin/install-catalog --add /etc/sgml/jade-unicode-%{version}-%{release}.cat \
124         %{_datadir}/sgml/unicode/catalog
125
126 %postun
127 /sbin/ldconfig
128 /usr/bin/install-catalog --remove /etc/sgml/dsssl-%{version}.cat \
129         %{_datadir}/sgml/%{name}-%{version}/catalog
130 /usr/bin/install-catalog --remove /etc/sgml/jade-unicode-%{version}-%{release}.cat \
131         %{_datadir}/sgml/unicode/catalog
132
133 %files -f OpenJade.lang
134 %defattr(644,root,root,755)
135 %doc jadedoc/ dsssl/ README.gz COPYING.gz
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138 %{_datadir}/sgml/*
139 %{_datadir}/OpenJade
140
141 %files devel
142 %defattr(644,root,root,755)
143 %{_includedir}/OpenJade
144 %attr(755,root,root) %{_libdir}/lib*.so
145 %attr(755,root,root) %{_libdir}/lib*.la
146
147 %files static
148 %defattr(644,root,root,755)
149 %attr(644,root,root) %{_libdir}/lib*.a
This page took 0.055903 seconds and 3 git commands to generate.