]> git.pld-linux.org Git - packages/openjade.git/blob - openjade.spec
35a17d3d186fa0d72e464cf0a11365eb3d638567
[packages/openjade.git] / openjade.spec
1 %define         snap    20020409
2 Summary:        OpenJade -- DSSSL parser
3 Summary(pl):    OpenJade -- parser DSSSL
4 Name:           openjade
5 Version:        1.4
6 Release:        13.%{snap}
7 License:        Free (Copyright (C) 1999 The OpenJade group)
8 Group:          Applications/Publishing/SGML
9 Source0:        %{name}-%{snap}.tar.gz
10 Patch0:         %{name}-table.patch
11 Patch1:         %{name}-ac25x.patch
12 Patch2:         %{name}-types.patch
13 URL:            http://openjade.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  gettext-devel
18 BuildRequires:  opensp-devel >= 1.5pre5
19 BuildRequires:  perl
20 Provides:       jade
21 Provides:       dssslparser
22 Requires:       sgmlparser
23 Requires:       opensp >= 1.5pre5
24 Prereq:         sgml-common
25 Prereq:         /sbin/ldconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      jade
28
29 %description
30 Jade (James' DSSSL Engine) is an implementation of the DSSSL style
31 language. OpenJade is successor of Jade.
32
33 %description -l pl
34 Jade (James' DSSSL Engine) jest implementacj± parsera DSSSL. OpenJade
35 jest nastêpc± Jade.
36
37 %package devel
38 Summary:        OpenJade header files
39 Summary(pl):    Pliki nag³ówkowe do bibliotek OpenJade
40 Group:          Development/Libraries
41 Prereq:         /sbin/ldconfig
42 Requires:       %{name} = %{version}
43
44 %description devel
45 Openjade header files.
46
47 %description devel -l pl
48 Pliki nag³ówkowe do bibliotek OpenJade.
49
50 %package static
51 Summary:        OpenJade static libraries
52 Summary(pl):    Biblioteki statyczne OpenJade
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 OpenJade static libraries.
58
59 %description static -l pl
60 Biblioteki statyczne OpenJade.
61
62 %prep
63 %setup -q -n %{name}-%{snap}
64 %patch0 -p0
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 #remove CVS dirs
70 find . -type d -name CVS | xargs rm -rf
71 #missing files required by Makefile.am
72 touch ChangeLog
73 rm -f missing
74 %{__gettextize}
75 %{__libtoolize}
76 %{__aclocal}
77 echo "#undef SIZEOF_WCHAR_T" >> acconfig.h
78 %{__autoheader}
79 %{__automake}
80 #aclocal
81 %{__autoconf}
82 %ifarch alpha
83 CXXFLAGS="-O0 %{?debug:-g}"
84 %endif
85 %configure \
86         --enable-default-catalog=/etc/sgml/catalog \
87         --enable-default-search-path=/usr/share/sgml
88
89 # it has /usr/share/Openjade hardcoded somewhere so it does not work
90         # --datadir=%{_datadir}/sgml
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_datadir}/sgml
97
98 %{__make} install DESTDIR=$RPM_BUILD_ROOT
99
100 cp -a unicode $RPM_BUILD_ROOT%{_datadir}/sgml
101 ln -sf "../OpenJade" $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}-%{version}
102
103 ##ln -s "../OpenJade" $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}
104 #install dsssl/catalog \
105 #       dsssl/builtins.dsl dsssl/extensions.dsl \
106 #       dsssl/dsssl.dtd dsssl/fot.dtd dsssl/spec.dtd dsssl/style-sheet.dtd \
107 #       $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}-%{version}/
108 #grep -v SYSTEM $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}/catalog > \
109 #       $RPM_BUILD_ROOT%{_datadir}/sgml/%{name}/%{name}.cat
110
111
112 # simulate jade
113 ln -sf openjade $RPM_BUILD_ROOT%{_bindir}/jade
114
115 %find_lang OpenJade
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 /sbin/ldconfig
122 /usr/bin/install-catalog --add /etc/sgml/dsssl-%{version}-%{release}.cat \
123         %{_datadir}/sgml/%{name}-%{version}/catalog
124 /usr/bin/install-catalog --add /etc/sgml/jade-unicode-%{version}-%{release}.cat \
125         %{_datadir}/sgml/unicode/catalog
126
127 %postun
128 /sbin/ldconfig
129 if [ "$1" = "0" ]; then
130         /usr/bin/install-catalog --remove /etc/sgml/dsssl-%{version}.cat \
131                 %{_datadir}/sgml/%{name}-%{version}/catalog
132         /usr/bin/install-catalog --remove /etc/sgml/jade-unicode-%{version}-%{release}.cat \
133                 %{_datadir}/sgml/unicode/catalog
134 fi
135
136 %files -f OpenJade.lang
137 %defattr(644,root,root,755)
138 %doc jadedoc/ dsssl/ README COPYING
139 %attr(755,root,root) %{_bindir}/*
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*
141 %{_datadir}/sgml/*
142 %{_datadir}/OpenJade
143
144 %files devel
145 %defattr(644,root,root,755)
146 %{_includedir}/OpenJade
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %attr(755,root,root) %{_libdir}/lib*.la
149
150 %files static
151 %defattr(644,root,root,755)
152 %attr(644,root,root) %{_libdir}/lib*.a
This page took 0.044108 seconds and 2 git commands to generate.