]> git.pld-linux.org Git - SPECS.git/blob - openinventor.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / openinventor.spec
1 Summary:        Open Inventor 3D toolkit
2 Summary(pl.UTF-8):      Open Inventor - toolkit 3D
3 Name:           openinventor
4 %define ver     2.1.5
5 %define subver  10
6 Version:        %{ver}.%{subver}
7 Release:        1
8 License:        LGPL v2.1+
9 Group:          X11/Applications/Graphics
10 Source0:        ftp://oss.sgi.com/projects/inventor/download/inventor-%{ver}-%{subver}.src.tar.gz
11 # Source0-md5:  82208096f1e0b111160e864e239c3a51
12 Patch0:         %{name}-glibc.patch
13 Patch1:         %{name}-link.patch
14 Patch2:         %{name}-install.patch
15 Patch3:         %{name}-c++.patch
16 Patch4:         %{name}-paths.patch
17 Patch5:         %{name}-nobash.patch
18 Patch7:         %{name}-dprintf.patch
19 Patch8:         %{name}-morearchs.patch
20 Patch9:         %{name}-freetype-includes.patch
21 Patch10:        %{name}-bison.patch
22 URL:            http://oss.sgi.com/projects/inventor/
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  bison
26 BuildRequires:  flex
27 BuildRequires:  freetype >= 2.0.1
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  motif-devel
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXi-devel
34 BuildRequires:  xorg-lib-libXt-devel
35 BuildRequires:  xorg-lib-libXp-devel
36 Requires:       %{name}-libs = %{version}-%{release}
37 Obsoletes:      sgi-OpenInventor-clients
38 Obsoletes:      sgi-OpenInventor-data
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 The Open Inventor 3D Toolkit is an object-oriented toolkit that
43 simplifies and abstracts the task of writing graphics programming into
44 a set of easy to use objects. These objects range from low-level
45 data-centered objects such as Sphere, Camera, Material, Light, and
46 Group, to high-level application-level objects such as Walk Viewer and
47 Material Editor. The foundation concept in Inventor is the "scene
48 database" which defines the objects to be used in an application. When
49 using Inventor, a programmer creates, edits, and composes these
50 objects into hierarchical 3D scene graphs (i.e. database). A variety
51 of fundamental application tasks such as rendering, picking, event
52 handling, and file reading/writing are built-in operations of all
53 objects in the database and thus are simple to invoke.
54
55 %description -l pl.UTF-8
56 Open Inventor jest zorientowanym obiektowo toolkitem 3D, który
57 upraszcza zadanie programowania grafiki do zestawu łatwych w użyciu
58 obiektów. Można używać obiektów począwszy od niskiego poziomu,
59 związanego z danymi (np. sfera, kamera, materiał, światło, grupa) do
60 wysokiego, związanego z aplikacją (np. przeglądarka ścieżki, edytor
61 materiałów). Podstawową ideą w Inventorze jest "bza danych sceny",
62 definiująca obiekty, jakie mają być użyte w aplikacji. Przy użyciu
63 Inventora programista tworzy, modyfikuje i komponuje te obiekty w
64 hierarchiczne grafy sceny trójwymiarowej (czyli bazę danych). Wiele
65 podstawowych zadań aplikacji, takich jak renderowanie, wybieranie,
66 obsługa elementów oraz odczyt/zapis plików są wbudowanymi operacjami
67 wszystkich obiektów w bazie danych, dzięki czemu są łatwe do
68 wywołania.
69
70 %package libs
71 Summary:        Open Inventor shared libraries
72 Summary(pl.UTF-8):      Biblioteki współdzielone Open Inventora
73 Group:          X11/Libraries
74 Conflicts:      openinventor < 2.1.5.10
75
76 %description libs
77 Open Inventor shared libraries.
78
79 %description libs -l pl.UTF-8
80 Biblioteki współdzielone Open Inventora.
81
82 %package devel
83 Summary:        Open Inventor for programmers
84 Summary(pl.UTF-8):      Open Inventor dla programistów
85 Group:          X11/Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87 Obsoletes:      sgi-OpenInventor-devel
88
89 %description devel
90 Package for programmers using Open Inventor. Contains header files,
91 API documentation and examples.
92
93 %description devel -l pl.UTF-8
94 Pakiet dla programistów korzystających z Open Inventora. Zawiera pliki
95 nagłówkowe, dokumentację API i przykłady.
96
97 %package static
98 Summary:        Open Inventor static libraries
99 Summary(pl.UTF-8):      Biblioteki statyczne Open Inventora
100 Group:          X11/Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Open Inventor static libraries.
105
106 %description static -l pl.UTF-8
107 Biblioteki statyczne Open Inventora.
108
109 %package demos
110 Summary:        Open Inventor demos
111 Summary(pl.UTF-8):      Programy demonstracyjne Open Inventora
112 Group:          X11/Applications/Graphics
113 Requires:       %{name} = %{version}-%{release}
114
115 %description demos
116 Demonstration programs for Open Inventor.
117
118 %description demos -l pl.UTF-8
119 Programy demonstrujące możliwości Open Inventora.
120
121 %prep
122 %setup -q -n inventor
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127 %patch4 -p1
128 %patch5 -p1
129 %patch7 -p1
130 %patch8 -p1
131 %patch9 -p1
132 %patch10 -p1
133
134 %build
135 export LD_LIBRARY_PATH="`pwd`/lib:`pwd`/libSoXt"
136 %{__make} \
137         CXX="%{__cxx}" \
138         FREETYPE=1 \
139         IVLIBDIR="\$(IVROOT)%{_libdir}" \
140         OPTIMIZER="%{rpmcflags} %{!?debug:-DNDEBUG}" \
141         X11LIBDIR=%{_libdir} \
142         YACC="bison -y"
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT{%{_libdir}/InventorDSO,%{_mandir}/man7,%{_datadir}/Inventor/demos/data} \
147         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
148
149 %{__make} install \
150         IVROOT=$RPM_BUILD_ROOT \
151         IVLIBDIR="\$(IVROOT)%{_libdir}"
152
153 install apps/nodes/*/*.so $RPM_BUILD_ROOT%{_libdir}/InventorDSO
154 cp -p lib/lib*.a libSoXt/lib*.a $RPM_BUILD_ROOT%{_libdir}
155 cp -rf apps/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
156
157 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man{1/inventor.1,7/inventor.7}
158
159 # move demos data to another dir
160 %{__mv} $RPM_BUILD_ROOT%{_datadir}/Inventor/help/{noodle,qmorf,revo,textomatic}.about \
161         $RPM_BUILD_ROOT%{_datadir}/Inventor/demos/data
162
163 # resolve conflict with gview
164 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{gview,ivgview}
165 # too generic name
166 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{drop,ivdrop}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   libs -p /sbin/ldconfig
172 %postun libs -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc FAQ.misc KNOWN.BUGS README.FIRST
177 %attr(755,root,root) %{_bindir}/SceneViewer
178 %attr(755,root,root) %{_bindir}/iv2toiv1
179 %attr(755,root,root) %{_bindir}/ivcat
180 %attr(755,root,root) %{_bindir}/ivdowngrade
181 %attr(755,root,root) %{_bindir}/ivfix
182 %attr(755,root,root) %{_bindir}/ivinfo
183 %attr(755,root,root) %{_bindir}/ivview
184 %attr(755,root,root) %{_libdir}/InventorDSO/*.so
185 %dir %{_datadir}/Inventor
186 %dir %{_datadir}/Inventor/data
187 %{_datadir}/Inventor/data/models
188 %dir %{_datadir}/Inventor/help
189 %{_datadir}/Inventor/help/SoXt*.help
190 %{_datadir}/Inventor/help/SceneViewer.about
191 %{_datadir}/Inventor/help/ivview.about
192 %{_mandir}/man1/SceneViewer.1*
193 %{_mandir}/man1/iv2toiv1.1*
194 %{_mandir}/man1/ivcat.1*
195 %{_mandir}/man1/ivdowngrade.1*
196 %{_mandir}/man1/ivfix.1*
197 %{_mandir}/man1/ivinfo.1*
198 %{_mandir}/man1/ivview.1*
199
200 %files libs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libInventor.so
203 %attr(755,root,root) %{_libdir}/libInventorXt.so
204 %dir %{_libdir}/InventorDSO
205
206 %files devel
207 %defattr(644,root,root,755)
208 %{_includedir}/Inventor
209 %{_mandir}/man3/Sb*.3iv*
210 %{_mandir}/man3/So*.3iv*
211 %{_mandir}/man7/inventor.7*
212 %{_examplesdir}/%{name}-%{version}
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libInventor.a
217 %{_libdir}/libInventorXt.a
218
219 %files demos
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_bindir}/ivdrop
222 %attr(755,root,root) %{_bindir}/ivgview
223 %attr(755,root,root) %{_bindir}/maze
224 %attr(755,root,root) %{_bindir}/noodle
225 %attr(755,root,root) %{_bindir}/qmorf
226 %attr(755,root,root) %{_bindir}/revo
227 %attr(755,root,root) %{_bindir}/textomatic
228 %{_datadir}/Inventor/demos
This page took 0.986454 seconds and 3 git commands to generate.