]> git.pld-linux.org Git - SPECS.git/blob - openh323.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / openh323.spec
1 #
2 # Conditional build:
3 %bcond_with     transnexusosp   # support for the Transnexus OSP toolkit (huge static lib)
4
5 # TODO:
6 # - separate plugins to subpackages
7 # - gsm-amr plugin (using system amrnb if possible)
8 # - use system libilbc or at least use optflags for plugins/audio/iLBC
9 # - configure: Skipping tests for RFC 2190 H.263 support
10 # - configure: Disabled non-RFC2190 H.263 using ffmpeg
11 # - configure: Disabled H.263 using VIC
12
13 %define         fver    %(echo %{version} | tr . _)
14 Summary:        OpenH323 Library
15 Summary(pl.UTF-8):      Biblioteka OpenH323
16 Name:           openh323
17 Version:        1.19.0.1
18 Release:        5
19 License:        MPL 1.0
20 Group:          Libraries
21 Source0:        http://www.voxgratia.org/releases/%{name}-v%{fver}-src-tar.gz
22 # Source0-md5:  e7ba3ae6b50d0d02c5cbe9ed3a3152c4
23 Patch0:         %{name}-mak_files.patch
24 Patch1:         %{name}-asnparser.patch
25 Patch2:         %{name}-lib.patch
26 Patch3:         %{name}-system-libs.patch
27 Patch4:         %{name}-ffmpeg.patch
28 Patch5:         %{name}-configure_fix.patch
29 Patch6:         %{name}-install64.patch
30 Patch7:         %{name}-inc.patch
31 Patch8:         ptlib-check.patch
32 Patch9:         ptlib-headers.patch
33 URL:            http://www.voxgratia.org/
34 BuildRequires:  autoconf >= 2.50
35 BuildRequires:  automake
36 BuildRequires:  ffmpeg-devel >= 0.4.6
37 BuildRequires:  libgsm-devel >= 1.0.10
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  lpc10-devel >= 1.5
40 BuildRequires:  pwlib-devel >= 1.11
41 %{?with_transnexusosp:BuildRequires:    OSPToolkit}
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  speex-devel >= 1:1.1.5
44 Requires:       speex >= 1:1.1.5
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 The OpenH323 project aims to create a full featured, interoperable,
49 Open Source implementation of the ITU H.323 teleconferencing protocol
50 that can be used by personal developers and commercial users without
51 charge.
52
53 %description -l pl.UTF-8
54 Celem projektu OpenH323 jest stworzenie w pełni funkcjonalnej i
55 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
56 który może być używany przez użytkowników prywatnych i komercyjnych
57 bez opłat.
58
59 %package devel
60 Summary:        OpenH323 development files
61 Summary(pl.UTF-8):      Pliki dla developerów OpenH323
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       ffmpeg-devel
65 Requires:       pwlib-devel >= 1.11
66
67 %description devel
68 Header files and libraries for developing applications that use
69 OpenH323.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
73 używających OpenH323.
74
75 %package static
76 Summary:        OpenH323 static libraries
77 Summary(pl.UTF-8):      Biblioteki statyczne OpenH323
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 OpenH323 static libraries.
83
84 %description static -l pl.UTF-8
85 Biblioteki statyczne OpenH323.
86
87 %prep
88 %setup -q -n %{name}_v%{fver}
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p0
92 %patch3 -p1
93 %patch4 -p1
94 %patch5 -p1
95 %if "%{_lib}" == "lib64"
96 %patch6 -p1
97 sed -i -e 's#/lib#/lib64#g' openh323u.mak.in
98 %endif
99 %patch7 -p1
100 %patch8 -p1
101 %patch9 -p1
102
103 %build
104 export OPENH323DIR=${PWD:-$(pwd)}
105 export OPENH323_BUILD="yes"
106 cp -f /usr/share/automake/config.sub .
107 %{__autoconf}
108 %configure \
109         --enable-localspeex=no \
110         %{!?with_transnexusosp:--disable-transnexusosp} \
111         --enable-plugins
112
113 %{__make} -j1 %{?debug:debug}%{!?debug:opt}shared apps \
114         CC="%{__cc}" \
115         CPLUS="%{__cxx}" \
116         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
121
122 %{__make} -j1 install \
123         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
124         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
125
126 # using cp as install won't preserve links
127 cp -pd %{_lib}/lib*.a $RPM_BUILD_ROOT%{_libdir}
128 install -p samples/simple/obj_*/simph323 $RPM_BUILD_ROOT%{_bindir}
129 cp -a version.h $RPM_BUILD_ROOT%{_includedir}/%{name}
130
131 sed -i -e 's#OH323_INCDIR = .*#OH323_INCDIR = %{_includedir}/%{name}#g' $RPM_BUILD_ROOT%{_datadir}/%{name}/*.mak
132 sed -i -e 's#OH323_LIBDIR = .*#OH323_LIBDIR = %{_libdir}#g' $RPM_BUILD_ROOT%{_datadir}/%{name}/*.mak
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc *.txt
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %{_libdir}/libopenh323.so.*.*.*
145 %dir %{_libdir}/pwlib/codecs
146 %dir %{_libdir}/pwlib/codecs/audio
147 %attr(755,root,root) %{_libdir}/pwlib/codecs/audio/*_pwplugin.so
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libopenh323.so
152 %{_includedir}/openh323
153 %{_datadir}/openh323
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libopenh323.a
This page took 0.33757 seconds and 3 git commands to generate.