]> git.pld-linux.org Git - packages/openct.git/blob - openct.spec
- release 2
[packages/openct.git] / openct.spec
1 Summary:        OpenCT library - library for accessing smart card terminals
2 Summary(pl):    OpenCT - biblioteka dostêpu do terminali kart procesorowych
3 Name:           openct
4 Version:        0.6.2
5 Release:        2
6 License:        BSD-like
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  18d8bca0372515842fec9f366ca461d1
10 Source1:        %{name}.init
11 Patch0:         %{name}-ccid.patch
12 URL:            http://www.opensc.org/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  libusb-devel
17 BuildRequires:  pcsc-lite-devel
18 BuildRequires:  pkgconfig >= 1:0.9.0
19 Requires(post): /sbin/ldconfig
20 Requires(post,preun):   /sbin/chkconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 OpenCT is a library for accessing smart card terminals. It provides a
25 rich set of functions for driver writers, protocol drivers for T=0 and
26 T=1, serial and USB functionality, including USB hotplugging. 
27
28 %description -l pl
29 OpenCT to biblioteka s³u¿±ca do dostêpu do terminali kart
30 procesorowych (smart card). Dostarcza bogaty zbiór funkcji dla
31 pisz±cych sterowniki, sterowniki protoko³ów dla T=0 i T=1,
32 funkcjonalno¶æ dla portów szeregowych i USB, w³±cznie z pod³±czaniem
33 urz±dzeñ USB w locie (hotplug).
34
35 %package -n pcsc-driver-openct
36 Summary:        OpenCT driver for PC/SC
37 Summary(pl):    Sterownik OpenCT dla PC/SC
38 Group:          Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       pcsc-lite
41
42 %description -n pcsc-driver-openct
43 OpenCT driver for PC/SC.
44
45 %description -n pcsc-driver-openct -l pl
46 Sterownik OpenCT dla PC/SC.
47
48 %package devel
49 Summary:        OpenCT development files
50 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenCT
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 OpenSC development files.
56
57 %description devel -l pl
58 Pliki dla programistów u¿ywaj±cych OpenCT.
59
60 %package static
61 Summary:        Static OpenCT libraries
62 Summary(pl):    Bibloteki statyczne OpenCT
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static OpenCT libraries.
68
69 %description static -l pl
70 Statyczne biblioteki OpenCT.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         --with-bundle-dir=%{_libdir}/pcsc/drivers
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hotplug/usb,/var/run/openct}
89 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 install etc/openct.conf $RPM_BUILD_ROOT%{_sysconfdir}
95 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/openct
96
97 rm -f $RPM_BUILD_ROOT%{_libdir}/openct-*.{a,la}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /sbin/ldconfig
104 /sbin/chkconfig --add openct
105 if [ -f /var/lock/subsys/openct ]; then
106         /etc/rc.d/init.d/openct restart >&2
107 else
108         echo "Run \"/etc/rc.d/init.d/openct start\" to start openct."
109 fi
110
111 %preun
112 if [ "$1" = "0" ]; then
113         if [ -f /var/lock/subsys/openct ]; then
114                 /etc/rc.d/init.d/openct stop >&2
115         fi
116         /sbin/chkconfig --del openct
117 fi
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ANNOUNCE ChangeLog NEWS TODO doc/openct.{html,css}
123 %attr(755,root,root) %{_bindir}/openct-tool
124 %attr(755,root,root) %{_sbindir}/ifdhandler
125 %attr(755,root,root) %{_sbindir}/ifdproxy
126 %attr(755,root,root) %{_sbindir}/openct-control
127 %attr(755,root,root) %{_libdir}/lib*.so.*.*
128 %attr(755,root,root) %{_libdir}/libopenctapi.so
129 %attr(755,root,root) %{_libdir}/openct-ifd.so
130 %dir /var/run/openct
131 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/openct.conf
132 %attr(755,root,root) %{_sysconfdir}/hotplug/usb/openct
133 %{_sysconfdir}/hotplug/usb/openct.usermap
134 %attr(754,root,root) /etc/rc.d/init.d/openct
135
136 %files -n pcsc-driver-openct
137 %defattr(644,root,root,755)
138 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle
139 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents
140 %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Linux
141 %attr(755,root,root) %dir %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Linux/openct-ifd
142 %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/Info.plist
143 %{_libdir}/pcsc/drivers/openct-ifd.bundle/Contents/PkgInfo
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libifd.so
148 %attr(755,root,root) %{_libdir}/libopenct.so
149 %{_libdir}/lib*.la
150 %{_includedir}/openct
151 %{_pkgconfigdir}/*.pc
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib*.a
This page took 0.345716 seconds and 3 git commands to generate.