]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
f0a5939e662b868c2163a799fe08a230b55ab04a
[packages/ogre.git] / ogre.spec
1 # TODO:
2 # - better fix for --as-needed (im too stupid to fix this in a correct way:/)
3 #
4 # Conditional build:
5 %bcond_without  cg              # don't build with cg
6
7 %ifnarch %{ix86} %{x8664}
8 %undefine       with_cg
9 %endif
10
11 %define _ver    %(echo %{version} | tr . -)
12 Summary:        Object-oriented Graphics Rendering Engine
13 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
14 Name:           ogre
15 Version:        1.4.8
16 Release:        1
17 License:        LGPL
18 Group:          Applications
19 Source0:        http://dl.sourceforge.net/ogre/%{name}-v%{_ver}.tar.bz2
20 # Source0-md5:  c9034bdbd4c7cd79a4dd38811765262a
21 URL:            http://www.ogre3d.org/
22 BuildRequires:  CEGUI-devel
23 BuildRequires:  FreeImage-devel
24 BuildRequires:  OpenEXR-devel
25 BuildRequires:  OpenGL-GLU-devel
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake
28 %{?with_cg:BuildRequires:       cg-devel}
29 BuildRequires:  cppunit-devel >= 1.10.0
30 BuildRequires:  freetype-devel >= 2.1.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  xorg-lib-libXaw-devel
36 BuildRequires:  xorg-lib-libXrandr-devel
37 BuildRequires:  xorg-lib-libXxf86vm-devel
38 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
39 BuildRequires:  zlib-devel
40 BuildRequires:  zziplib-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         filterout_ld    -Wl,--as-needed
44
45 %description
46 Object-oriented Graphics Rendering Engine.
47
48 %description -l pl.UTF-8
49 OGRE - zorientowany obiektowo silnik renderowania grafiki
50
51 %package devel
52 Summary:        Header files for OGRE library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       FreeImage-devel
57 Requires:       freetype-devel >= 2.1.0
58 Requires:       libstdc++-devel
59 Requires:       zlib-devel
60 Requires:       zziplib-devel
61 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
62
63 %description devel
64 This is the package containing the header files for OGRE library.
65
66 %description devel -l pl.UTF-8
67 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
68
69 %package examples
70 Summary:        OGRE samples
71 Summary(pl.UTF-8):      Przykłady do OGRE
72 Group:          Applications
73
74 %description examples
75 OGRE samples.
76
77 %description examples -l pl.UTF-8
78 Przykłady do OGRE.
79
80 %prep
81 %setup -q -n %{name}
82
83 find -name CVS -print0 | xargs -0 rm -rf
84
85 sed -i -e 's,"-L/usr/X11R6/lib ,"-L/usr/X11R6/%{_lib} ,' acinclude.m4
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{!?with_cg:--disable-cg} \
95         --disable-devil \
96         --enable-openexr
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 rm -f $RPM_BUILD_ROOT%{_libdir}/OGRE/*.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS BUGS README INSTALL
120 %attr(755,root,root) %{_bindir}/Ogre*
121 %attr(755,root,root) %{_libdir}/libOgre*.so
122 %attr(755,root,root) %{_libdir}/libCEGUIOgre*.so
123 %dir %{_libdir}/OGRE
124 %attr(755,root,root) %{_libdir}/OGRE/Plugin_BSPSceneManager.so
125 %attr(755,root,root) %{_libdir}/OGRE/Plugin_EXRCodec.so
126 %attr(755,root,root) %{_libdir}/OGRE/Plugin_OctreeSceneManager.so
127 %attr(755,root,root) %{_libdir}/OGRE/Plugin_ParticleFX.so
128 %attr(755,root,root) %{_libdir}/OGRE/RenderSystem_GL.so
129 %{?with_cg:%attr(755,root,root) %{_libdir}/OGRE/Plugin_CgProgramManager.so}
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libOgre*.so
134 %attr(755,root,root) %{_libdir}/libCEGUIOgre*.so
135 %{_libdir}/libOgreMain.la
136 %{_libdir}/libCEGUIOgreRenderer.la
137 %{_includedir}/OGRE
138 %{_pkgconfigdir}/OGRE.pc
139 %{_pkgconfigdir}/CEGUI-OGRE.pc
140
141 %files examples
142 %defattr(644,root,root,755)
143 %{_examplesdir}/%{name}-%{version}
This page took 0.053487 seconds and 2 git commands to generate.