]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
- builds on 64 bits
[packages/ogre.git] / ogre.spec
1 #
2 # TODO: - bconds for rest of the plugins
3 #
4 # Conditional build:
5 %bcond_with     cg              # build with cg
6
7 %ifnarch %{ix86} %{x8664}
8 %undefine       with_cg
9 %endif
10
11 %define _ver    %(echo %{version} | tr . -)
12 Summary:        Object-oriented Graphics Rendering Engine
13 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
14 Name:           ogre
15 Version:        1.7.2
16 Release:        1
17 License:        LGPL
18 Group:          Applications
19 Source0:        http://downloads.sourceforge.net/ogre/%{name}_src_v%{_ver}.tar.bz2
20 # Source0-md5:  dd6574b8d906a74950c1e05633b2e96f
21 URL:            http://www.ogre3d.org/
22 BuildRequires:  CEGUI-devel
23 BuildRequires:  FreeImage-devel
24 BuildRequires:  OpenEXR-devel
25 BuildRequires:  OpenGL-GLU-devel
26 %{?with_cg:BuildRequires:       cg-devel}
27 BuildRequires:  cmake
28 BuildRequires:  cppunit-devel >= 1.10.0
29 BuildRequires:  freetype-devel >= 2.1.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libXaw-devel
33 BuildRequires:  xorg-lib-libXrandr-devel
34 BuildRequires:  xorg-lib-libXxf86vm-devel
35 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
36 BuildRequires:  zlib-devel
37 BuildRequires:  zziplib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Object-oriented Graphics Rendering Engine.
42
43 %description -l pl.UTF-8
44 OGRE - zorientowany obiektowo silnik renderowania grafiki
45
46 %package devel
47 Summary:        Header files for OGRE library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       FreeImage-devel
52 Requires:       freetype-devel >= 2.1.0
53 Requires:       libstdc++-devel
54 Requires:       zlib-devel
55 Requires:       zziplib-devel
56 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
57
58 %description devel
59 This is the package containing the header files for OGRE library.
60
61 %description devel -l pl.UTF-8
62 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
63
64 %package examples
65 Summary:        OGRE samples
66 Summary(pl.UTF-8):      Przykłady do OGRE
67 Group:          Applications
68
69 %description examples
70 OGRE samples.
71
72 %description examples -l pl.UTF-8
73 Przykłady do OGRE.
74
75 %prep
76 %setup -q -n %{name}_src_v%{_ver}
77
78 %build
79 install -d build
80 cd build
81 %cmake .. \
82         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
83         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
84 %if "%{_lib}" == "lib64"
85         -DWANT_LIB64=TRUE
86 %endif
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96 %{__make} -C build install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 rm -f $RPM_BUILD_ROOT%{_libdir}/OGRE/*.la
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS BUGS README
110 %attr(755,root,root) %{_bindir}/Ogre*
111 %dir %{_libdir}/OGRE
112 %attr(755,root,root) %{_libdir}/OGRE/*.so
113 %attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
114 %attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
115 %attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
116 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libOgreMain.so
122 %attr(755,root,root) %{_libdir}/libOgrePaging.so
123 %attr(755,root,root) %{_libdir}/libOgreProperty.so
124 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
125 %attr(755,root,root) %{_libdir}/libOgreTerrain.so
126 %{_includedir}/OGRE
127 %{_pkgconfigdir}/OGRE.pc
128 %{_pkgconfigdir}/OGRE-PCZ.pc
129 %{_pkgconfigdir}/OGRE-Paging.pc
130 %{_pkgconfigdir}/OGRE-Property.pc
131 %{_pkgconfigdir}/OGRE-RTShaderSystem.pc
132 %{_pkgconfigdir}/OGRE-Terrain.pc
133
134 %files examples
135 %defattr(644,root,root,755)
136 %{_examplesdir}/%{name}-%{version}
This page took 0.080236 seconds and 3 git commands to generate.