]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
- missing %%{__make}
[packages/ogre.git] / ogre.spec
1 #
2 # TODO: - bconds for rest of the plugins
3 #       - fix build on 64 bits
4 #
5 # Conditional build:
6 %bcond_with     cg              # build with cg
7
8 %ifnarch %{ix86} %{x8664}
9 %undefine       with_cg
10 %endif
11
12 %define _ver    %(echo %{version} | tr . -)
13 Summary:        Object-oriented Graphics Rendering Engine
14 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
15 Name:           ogre
16 Version:        1.7.1
17 Release:        0.1
18 License:        LGPL
19 Group:          Applications
20 Source0:        http://downloads.sourceforge.net/ogre/%{name}_src_v%{_ver}.tar.bz2
21 # Source0-md5:  85083083dc65d49572654ea8c8b5c552
22 URL:            http://www.ogre3d.org/
23 BuildRequires:  CEGUI-devel
24 BuildRequires:  FreeImage-devel
25 BuildRequires:  OpenEXR-devel
26 BuildRequires:  OpenGL-GLU-devel
27 %{?with_cg:BuildRequires:       cg-devel}
28 BuildRequires:  cmake
29 BuildRequires:  cppunit-devel >= 1.10.0
30 BuildRequires:  freetype-devel >= 2.1.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  xorg-lib-libXaw-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  xorg-lib-libXxf86vm-devel
36 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
37 BuildRequires:  zlib-devel
38 BuildRequires:  zziplib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Object-oriented Graphics Rendering Engine.
43
44 %description -l pl.UTF-8
45 OGRE - zorientowany obiektowo silnik renderowania grafiki
46
47 %package devel
48 Summary:        Header files for OGRE library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       FreeImage-devel
53 Requires:       freetype-devel >= 2.1.0
54 Requires:       libstdc++-devel
55 Requires:       zlib-devel
56 Requires:       zziplib-devel
57 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
58
59 %description devel
60 This is the package containing the header files for OGRE library.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
64
65 %package examples
66 Summary:        OGRE samples
67 Summary(pl.UTF-8):      Przykłady do OGRE
68 Group:          Applications
69
70 %description examples
71 OGRE samples.
72
73 %description examples -l pl.UTF-8
74 Przykłady do OGRE.
75
76 %prep
77 %setup -q -n %{name}_src_v%{_ver}
78
79 %build
80 install -d build
81 cd build
82 %cmake .. \
83         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
84         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
85 %if "%{_lib}" == "lib64"
86         -DLIB_SUFFIX=64
87 %endif
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96
97 %{__make} -C build install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 rm -f $RPM_BUILD_ROOT%{_libdir}/OGRE/*.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS BUGS README
111 %attr(755,root,root) %{_bindir}/Ogre*
112 %dir %{_libdir}/OGRE
113 %attr(755,root,root) %{_libdir}/OGRE/*.so
114 %attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
115 %attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
116 %attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libOgreMain.so
123 %attr(755,root,root) %{_libdir}/libOgrePaging.so
124 %attr(755,root,root) %{_libdir}/libOgreProperty.so
125 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
126 %attr(755,root,root) %{_libdir}/libOgreTerrain.so
127 %{_includedir}/OGRE
128 %{_pkgconfigdir}/OGRE.pc
129 %{_pkgconfigdir}/OGRE-PCZ.pc
130 %{_pkgconfigdir}/OGRE-Paging.pc
131 %{_pkgconfigdir}/OGRE-Property.pc
132 %{_pkgconfigdir}/OGRE-RTShaderSystem.pc
133 %{_pkgconfigdir}/OGRE-Terrain.pc
134
135 %files examples
136 %defattr(644,root,root,755)
137 %{_examplesdir}/%{name}-%{version}
This page took 0.085589 seconds and 3 git commands to generate.