]> git.pld-linux.org Git - SPECS.git/blob - ocaml-xstr.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ocaml-xstr.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        Thread-safe Str replacement
3 Summary(pl.UTF-8):      Wielowątkowy zastępca modułu Str
4 Name:           ocaml-xstr
5 Version:        0.2.1
6 Release:        8
7 License:        BSD
8 Group:          Libraries
9 URL:            http://www.ocaml-programming.de/packages/
10 Source0:        http://www.ocaml-programming.de/packages/xstr-%{version}.tar.gz
11 # Source0-md5:  81598c438d6ab5c5d544ea7cc6ed8a34
12 BuildRequires:  ocaml >= %{ocaml_ver}
13 BuildRequires:  ocaml-findlib
14 %requires_eq    ocaml-runtime
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This package implements frequent string operations: searching,
19 replacing, splitting, matching. It is independent from the Str
20 library, and can replace Str in many cases. Unlike Str, xstr is
21 thread-safe. xstr does not implement regular expressions in general,
22 but an important subset.
23
24 %description -l pl.UTF-8
25 Pakiet ten implementuje częste operacje na łańcuchach znaków:
26 szukanie, zamianę, dzielenie i dopasowywanie wzorca. Jest niezależny
27 od biblioteki Str, i może ją w wielu wypadkach zastąpić. W
28 przeciwieństwie do Str można go używać w programach wielowątkowych.
29 Xstr nie implementuje wyrażeń regularnych w całości, tylko pewien
30 ważny podzbiór.
31
32 %package devel
33 Summary:        Thread-safe Str replacement - development part
34 Summary(pl.UTF-8):      Wielowątkowy zastępca modułu Str - cześć programistyczna
35 Group:          Development/Libraries
36 %requires_eq    ocaml
37
38 %description devel
39 This package implements frequent string operations: searching,
40 replacing, splitting, matching. It is independent from the Str
41 library, and can replace Str in many cases. Unlike Str, xstr is
42 thread-safe. xstr does not implement regular expressions in general,
43 but an important subset.
44
45 This package contains files needed to develop OCaml programs using
46 this library.
47
48 %description devel -l pl.UTF-8
49 Pakiet ten implementuje częste operacje na łańcuchach znaków:
50 szukanie, zamianę, dzielenie i dopasowywanie wzorca. Jest niezależny
51 od biblioteki Str, i może ją w wielu wypadkach zastąpić. W
52 przeciwieństwie do Str można go używać w programach wielowątkowych.
53 Xstr nie implementuje wyrażeń regularnych w całości, tylko pewien
54 ważny podzbiór.
55
56 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
57 tej biblioteki.
58
59 %prep
60 %setup -q -n xstr
61
62 %build
63 sed -e 's/-g//; s/\*.cmxa/& \*.cmx/' Makefile > Makefile.tmp
64 mv -f Makefile.tmp Makefile
65 %{__make} all opt
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/xstr
71 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml %{__make} install
72 echo 'directory = "+xstr"' >> $RPM_BUILD_ROOT%{_libdir}/ocaml/xstr/META
73 mv -f $RPM_BUILD_ROOT%{_libdir}/ocaml/xstr/META \
74         $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/xstr/META
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files devel
80 %defattr(644,root,root,755)
81 %doc LICENSE README *.mli
82 %{_libdir}/ocaml/xstr/*.cm[ixa]*
83 %{_libdir}/ocaml/xstr/*.a
84 %{_libdir}/ocaml/site-lib/xstr
This page took 0.22173 seconds and 3 git commands to generate.