]> git.pld-linux.org Git - SPECS.git/blob - ocaml-mysql.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / ocaml-mysql.spec
1 # TODO
2 # - (build time) security http://security.gentoo.org/glsa/glsa-200506-08.xml
3 %define         ocaml_ver       1:3.09.2
4 Summary:        MySQL binding for OCaml
5 Summary(pl.UTF-8):      Wiązania MySQL dla OCamla
6 Name:           ocaml-mysql
7 Version:        1.0.3
8 Release:        7
9 License:        LGPL v2.1+
10 Group:          Libraries
11 Source0:        http://raevnos.pennmush.org/code/ocaml-mysql/%{name}-%{version}.tar.gz
12 # Source0-md5:  3254be1cb6ef8801701a5628e60cfee4
13 URL:            http://raevnos.pennmush.org/code/ocaml-mysql/index.html
14 BuildRequires:  autoconf
15 BuildRequires:  mysql-devel
16 BuildRequires:  ocaml >= %{ocaml_ver}
17 BuildRequires:  ocaml-findlib
18 %requires_eq    ocaml-runtime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This library allows OCaml programs to access MySQL databases. This
23 package contains files needed to run bytecode OCaml programs using
24 this library.
25
26 %description -l pl.UTF-8
27 Biblioteka ta umożliwia programom pisanym w OCamlu dostęp do baz
28 danych MySQL. Pakiet ten zawiera binaria potrzebne do uruchamiania
29 programów używających tej biblioteki.
30
31 %package devel
32 Summary:        MySQL binding for OCaml - development part
33 Summary(pl.UTF-8):      Wiązania MySQL dla OCamla - cześć programistyczna
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 %requires_eq    ocaml
37
38 %description devel
39 This library allows OCaml programs to access MySQL databases. This
40 package contains files needed to develop OCaml programs using this
41 library.
42
43 %description devel -l pl.UTF-8
44 Biblioteka ta umożliwia programom pisanym w OCamlu dostęp do baz
45 danych MySQL. Pakiet ten zawiera pliki niezbędne do tworzenia
46 programów używających tej biblioteki.
47
48 %prep
49 %setup -q
50
51 %build
52 %{__autoconf}
53 %configure \
54         CFLAGS="%{rpmcflags} \
55         -fPIC" \
56
57
58 %{__make} all opt
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{stublibs,mysql,site-lib/mysql}
63
64 install *.a mysql.cm{[ixa],xa} $RPM_BUILD_ROOT%{_libdir}/ocaml/mysql
65 install *.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
66 ln -s mysql.cma $RPM_BUILD_ROOT%{_libdir}/ocaml/mysql/mysqlstatic.cma
67
68 install META $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/mysql/
69 echo 'directory = "+mysql"' >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/mysql/META
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc CHANGES README
77 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
78
79 %files devel
80 %defattr(644,root,root,755)
81 %doc demo.ml doc
82 %{_libdir}/ocaml/mysql
83 %{_libdir}/ocaml/site-lib/mysql
This page took 0.145275 seconds and 3 git commands to generate.