]> git.pld-linux.org Git - packages/ocaml-lablgl.git/blob - ocaml-lablgl.spec
- rel 2
[packages/ocaml-lablgl.git] / ocaml-lablgl.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        OpenGL binding for OCaml
3 Summary(pl.UTF-8):      Wiązania OpenGL dla OCamla
4 Name:           ocaml-lablgl
5 Version:        1.04
6 Release:        2
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/lablgl-%{version}.tar.gz
10 # Source0-md5:  dcf05a0cffffdf06cbe0fe55f9eff974
11 URL:            http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html
12 BuildRequires:  OpenGL-GLX-devel
13 BuildRequires:  OpenGL-glut-devel >= 3.7
14 BuildRequires:  ocaml >= %{ocaml_ver}
15 BuildRequires:  ocaml-camlp4
16 BuildRequires:  ocaml-labltk-devel
17 BuildRequires:  tcl-devel
18 BuildRequires:  tk-devel >= 4.0
19 BuildRequires:  xorg-lib-libXmu-devel
20 %requires_eq    ocaml-runtime
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LablGL is an OpenGL interface for Objective Caml. All of the GL and
25 GLU libraries are available.
26
27 This package contains files needed to run bytecode executables using
28 this library.
29
30 %description -l pl.UTF-8
31 LablGL umożliwia używanie OpenGL w OCamlu. Dostępne są wszystkie
32 biblioteki GL i GLU.
33
34 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
35 używających tej biblioteki.
36
37 %package devel
38 Summary:        OpenGL binding for OCaml - development part
39 Summary(pl.UTF-8):      Wiązania OpenGL dla OCamla - cześć programistyczna
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 %requires_eq    ocaml
43
44 %description devel
45 LablGL is an OpenGL interface for Objective Caml. All of the GL and
46 GLU libraries are available.
47
48 This package contains files needed to develop OCaml programs using
49 this library.
50
51 %description devel -l pl.UTF-8
52 LablGL umożliwia używanie OpenGL w OCamlu. Dostępne są wszystkie
53 biblioteki GL i GLU.
54
55 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
56 tej biblioteki.
57
58 %package togl
59 Summary:        Tk widget for lablGL
60 Summary(pl.UTF-8):      Widget Tk dla lablGL
61 Group:          Libraries
62 Requires:       %{name} = %{version}-%{release}
63 %requires_eq    ocaml-labltk
64 %requires_eq    ocaml-runtime
65
66 %description togl
67 Togl Tk widget for lablGL, to be used with labltk.
68
69 This package contains files needed to run bytecode executables using
70 this library.
71
72 %description togl -l pl.UTF-8
73 Widget Togl używający Tk dla lablGL. Może być on używany wraz z
74 labltk.
75
76 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
77 używających tej biblioteki.
78
79 %package togl-devel
80 Summary:        Tk widget for lablGL - development part
81 Summary(pl.UTF-8):      Widget Tk dla lablGL - cześć programistyczna
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 %requires_eq    ocaml
85 %requires_eq    ocaml-labltk-devel
86
87 %description togl-devel
88 Togl Tk widget for lablGL, to be used with labltk.
89
90 This package contains files needed to develop OCaml programs using
91 this library.
92
93 %description togl-devel -l pl.UTF-8
94 Widget Togl używający Tk dla lablGL. Może być on używany wraz z
95 labltk.
96
97 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
98 tej biblioteki.
99
100 %package glut
101 Summary:        GLUT binding for OCaml
102 Summary(pl.UTF-8):      Wiązanie OCamla dla biblioteki GLUT
103 Group:          Libraries
104 Requires:       %{name} = %{version}-%{release}
105 %requires_eq    ocaml-runtime
106
107 %description glut
108 The lablglut library is an OCaml binding for GLUT version 3.7. GLUT
109 (GL Utility Toolkit) is a portable windowing library for OpenGL,
110 written by Mark Kilgard.
111
112 %description glut -l pl.UTF-8
113 Biblioteka lablglut to wiązanie OCamla dla biblioteki GLUT w wersji
114 3.7. GLUT (czyli GL Utility Toolkit) to przenośna biblioteka okienkowa
115 dla OpenGL-a, napisana przez Marka Kilgarda.
116
117 %package glut-devel
118 Summary:        GLUT binding for OCaml - development part
119 Summary(pl.UTF-8):      Wiązanie OCamla dla biblioteki GLUT - część programistyczna
120 Group:          Development/Libraries
121 Requires:       %{name} = %{version}-%{release}
122 %requires_eq    ocaml
123
124 %description glut-devel
125 This package contains development files for GLUT binding for OCaml.
126
127 %description glut-devel -l pl.UTF-8
128 Ten pakiet zawiera pliki programistyczne wiązania OCamla dla
129 biblioteki GLUT.
130
131 %package toplevel
132 Summary:        OpenGL binding for OCaml - interactive system
133 Summary(pl.UTF-8):      Wiązania OpenGL dla OCamla - system interaktywny
134 Group:          Development/Libraries
135 Requires:       %{name} = %{version}-%{release}
136 %requires_eq    ocaml
137
138 %description toplevel
139 LablGL is an OpenGL interface for Objective Caml. All of the GL and
140 GLU libraries are available.
141
142 This package contains OCaml toplevel interactive system linked with
143 lablgl.
144
145 %description toplevel -l pl.UTF-8
146 LablGL umożliwia używanie OpenGL w OCamlu. Dostępne są wszystkie
147 biblioteki GL i GLU.
148
149 Pakiet ten zawiera system interaktywny OCamla skonsolidowany z lablgl.
150
151 %prep
152 %setup -q -n lablGL-%{version}
153
154 %build
155 sed -e 's|^\(X\|TK\)INCLUDES|#&|;
156         s|^GLLIBS.*|GLLIBS = -lGL -lGLU -lXmu|;
157         s|^COPTS.*|COPTS = %{rpmcflags} -c -fPIC|;' \
158         Makefile.config.ex > Makefile.config
159 %{__make} -j1 all opt
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/ocaml/{stublibs,site-lib/{lablgl,togl}}} \
164         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/{LablGlut,Togl}
165
166 %{__make} install \
167         INSTALLDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/lablGL \
168         DLLDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs \
169         LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
170         BINDIR=$RPM_BUILD_ROOT%{_bindir}
171
172 mv -f $RPM_BUILD_ROOT%{_libdir}/ocaml/lablGL/*.mli .
173
174 cp -r LablGlut/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/LablGlut
175 cp -r Togl/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/Togl
176
177 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/lablgl/META <<EOF
178 # Specifications for the "lablgl" library:
179 requires = ""
180 version = "%{version}"
181 directory = "+lablGL"
182 archive(byte) = "lablgl.cma"
183 archive(native) = "lablgl.cmxa"
184 linkopts = ""
185 EOF
186
187 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/togl/META <<EOF
188 # Specifications for the "togl" library:
189 requires = "lablgl"
190 version = "%{version}"
191 directory = "+lablGL"
192 archive(byte) = "togl.cma"
193 archive(native) = "togl.cmxa"
194 linkopts = ""
195 EOF
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %files
201 %defattr(644,root,root,755)
202 %doc COPYRIGHT CHANGES README
203 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dlllablgl.so
204
205 %files devel
206 %defattr(644,root,root,755)
207 %doc *.mli
208 %dir %{_libdir}/ocaml/lablGL
209 %{_libdir}/ocaml/lablGL/gl*
210 %{_libdir}/ocaml/lablGL/lablgl.*
211 %{_libdir}/ocaml/lablGL/liblablgl.a
212 %{_libdir}/ocaml/lablGL/raw.*
213 %{_libdir}/ocaml/site-lib/lablgl
214 %{_examplesdir}/%{name}-%{version}
215
216 %files glut
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dlllablglut.so
219
220 %files glut-devel
221 %defattr(644,root,root,755)
222 %{_libdir}/ocaml/lablGL/lablglut.*
223 %{_libdir}/ocaml/lablGL/liblablglut.a
224
225 %files togl
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dlltogl.so
228
229 %files togl-devel
230 %defattr(644,root,root,755)
231 %{_libdir}/ocaml/lablGL/togl.*
232 %{_libdir}/ocaml/lablGL/libtogl.a
233 %{_libdir}/ocaml/site-lib/togl
234
235 %files toplevel
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_bindir}/*
This page took 0.077639 seconds and 4 git commands to generate.