]> git.pld-linux.org Git - packages/ocaml-lablgl.git/blob - ocaml-lablgl.spec
- added missing BR: ocaml-camlp4
[packages/ocaml-lablgl.git] / ocaml-lablgl.spec
1 Summary:        OpenGL binding for OCaml
2 Summary(pl):    Wi±zania OpenGL dla OCamla
3 Name:           ocaml-lablgl
4 Version:        0.97
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 URL:            http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html
9 Source0:        http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/lablgl-%{version}.tar.gz
10 BuildRequires:  ocaml >= 3.04-7
11 BuildRequires:  ocaml-camlp4
12 BuildRequires:  ocaml-labltk-devel
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  XFree86-devel
15 BuildRequires:  tcl-devel
16 BuildRequires:  tk-devel
17 %requires_eq    ocaml-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 LablGL is an OpenGL interface for Objective Caml. All of the GL and
22 GLU libraries are available.
23
24 This package contains files needed to run bytecode executables using
25 this library.
26
27 %description -l pl
28 LablGL umo¿liwia u¿ywanie OpenGL w OCamlu. Dostêpne s± wszystkie
29 biblioteki GL i GLU.
30
31 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
32 u¿ywaj±cych tej biblioteki.
33
34 %package devel
35 Summary:        OpenGL binding for OCaml - development part
36 Summary(pl):    Wi±zania OpenGL dla OCamla - cze¶æ programistyczna
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 %requires_eq    ocaml
40
41 %description devel
42 LablGL is an OpenGL interface for Objective Caml. All of the GL and
43 GLU libraries are available.
44
45 This package contains files needed to develop OCaml programs using
46 this library.
47
48 %description devel -l pl
49 LablGL umo¿liwia u¿ywanie OpenGL w OCamlu. Dostêpne s± wszystkie
50 biblioteki GL i GLU.
51
52 Pakiet ten zawiera pliki niezbêdne do tworzenia programów u¿ywaj±cych
53 tej biblioteki.
54
55 %package togl
56 Summary:        Tk widget for lablGL
57 Summary(pl):    Widget Tk dla lablGL
58 Group:          Libraries
59 Requires:       %{name} = %{version}-%{release}
60 %requires_eq    ocaml-runtime
61 %requires_eq    ocaml-labltk
62
63 %description togl
64 Togl Tk widget for lablGL, to be used with labltk.
65
66 This package contains files needed to run bytecode executables using
67 this library.
68
69 %description togl -l pl
70 Widget Togl u¿ywaj±cy Tk dla lablGL. Mo¿e byæ on u¿ywany wraz z
71 labltk.
72
73 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
74 u¿ywaj±cych tej biblioteki.
75
76 %package togl-devel
77 Summary:        Tk widget for lablGL - development part
78 Summary(pl):    Widget Tk dla lablGL - cze¶æ programistyczna
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 %requires_eq    ocaml
82 %requires_eq    ocaml-labltk-devel
83
84 %description togl-devel
85 Togl TK widget for lablGL, to be used with labltk.
86
87 This package contains files needed to develop OCaml programs using
88 this library.
89
90 %description togl-devel -l pl
91 Widget Togl u¿ywaj±cy TK dla lablGL. Mo¿e byæ on u¿ywany wraz z
92 labltk.
93
94 Pakiet ten zawiera pliki niezbêdne do tworzenia programów u¿ywaj±cych
95 tej biblioteki.
96
97 %package toplevel
98 Summary:        OpenGL binding for OCaml - interactive system
99 Summary(pl):    Wi±zania OpenGL dla OCamla - system interaktywny
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 %requires_eq    ocaml
103
104 %description toplevel
105 LablGL is an OpenGL interface for Objective Caml. All of the GL and
106 GLU libraries are available.
107
108 This package contains OCaml toplevel interactive system linked with
109 lablgl.
110
111 %description toplevel -l pl
112 LablGL umo¿liwia u¿ywanie OpenGL w OCamlu. Dostêpne s± wszystkie
113 biblioteki GL i GLU.
114
115 Pakiet ten zawiera system interaktywny OCamla zlinkowany z lablgl.
116
117 %prep
118 %setup -q -n lablGL-%{version}
119
120 %build
121 sed -e 's|^TKINCLUDES|#&|;
122         s|^GLLIBS.*|GLLIBS = -L%{_prefix}/X11R6/lib -lGL -lGLU -lXmu|;
123         s|^COPTS.*|COPTS = %{rpmcflags} -c -fPIC|;' \
124         Makefile.config.ex > Makefile.config
125 %{__make} all opt
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 install -d $RPM_BUILD_ROOT%{_bindir}
131
132 %{__make} install \
133         INSTALLDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/lablgl \
134         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
135         BINDIR=$RPM_BUILD_ROOT%{_bindir}
136
137 gzip -9nf $RPM_BUILD_ROOT%{_libdir}/ocaml/lablgl/*.mli
138 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/lablgl/*.mli.gz .
139
140 (cd $RPM_BUILD_ROOT%{_libdir}/ocaml && ln -s lablgl/dll*.so .)
141
142 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
143 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
144
145 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/{lablgl,togl}
146 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/lablgl/META <<EOF
147 # Specifications for the "lablgl" library:
148 requires = ""
149 version = "%{version}"
150 directory = "+lablgl"
151 archive(byte) = "lablgl.cma"
152 archive(native) = "lablgl.cmxa"
153 linkopts = ""
154 EOF
155
156 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/togl/META <<EOF
157 # Specifications for the "lablgl" library:
158 requires = "labgl"
159 version = "%{version}"
160 directory = "+lablgl"
161 archive(byte) = "togl.cma"
162 archive(native) = "togl.cmxa"
163 linkopts = ""
164 EOF
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171 %dir %{_libdir}/ocaml/lablgl
172 %attr(755,root,root) %{_libdir}/ocaml/lablgl/dlllablgl.so
173 %{_libdir}/ocaml/dlllablgl.so
174
175 %files togl
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/ocaml/lablgl/dlltogl.so
178 %{_libdir}/ocaml/dlltogl.so
179
180 %files togl-devel
181 %defattr(644,root,root,755)
182 %{_libdir}/ocaml/lablgl/togl.*
183 %{_libdir}/ocaml/lablgl/libtogl.*
184 %{_libdir}/ocaml/site-lib/togl
185
186 %files devel
187 %defattr(644,root,root,755)
188 %doc COPYRIGHT CHANGES README
189 %{_libdir}/ocaml/lablgl/gl*
190 %{_libdir}/ocaml/lablgl/lablgl.*
191 %{_libdir}/ocaml/lablgl/liblablgl.a
192 %{_libdir}/ocaml/lablgl/raw.*
193 %{_examplesdir}/%{name}-%{version}
194 %{_libdir}/ocaml/site-lib/lablgl
195
196 %files toplevel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/*
199 %attr(755,root,root) %{_libdir}/ocaml/lablgl/lablgltop
This page took 0.070638 seconds and 4 git commands to generate.