]> git.pld-linux.org Git - SPECS.git/blob - ocaml-cryptgps.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / ocaml-cryptgps.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Ocaml Blowfish, DES, and 3DES implementation
11 Summary(pl.UTF-8):      Implementacja Blowfish, DES, and 3DES w Ocamlu
12 Name:           ocaml-cryptgps
13 Version:        0.2.1
14 Release:        6
15 License:        MIT
16 Group:          Libraries
17 Source0:        http://download.camlcity.org/download/cryptgps-%{version}.tar.gz
18 # Source0-md5:  656afb40fa681079296551b546cb02df
19 Patch0:         %{name}-bytes.patch
20 URL:            http://projects.camlcity.org/projects/cryptgps.html
21 BuildRequires:  ocaml >= 3.04-7
22 %requires_eq    ocaml-runtime
23 Conflicts:      ocaml-cryptgps-devel < 0.2.1-6
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         debug_package   %{nil}
27
28 %description
29 This library implements the symmetric cryptographic algorithms
30 Blowfish, DES, and 3DES. The algorithms are written in O'Caml,
31 i.e. this is not a binding to some C library, but the implementation
32 itself. 
33
34 This package contains files needed to run bytecode executables using
35 cryptgps library.
36
37 %description -l pl.UTF-8
38 Biblioteka implementuje algorytmy szyfrów symetrycznych Blowfish, DES
39 oraz 3DES. Algorytmy zostały napisane w OCamlu, więc nie jest to
40 wiązanie do biblioteki w C, ale sama implementacja.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki cryptgps.
44
45 %package devel
46 Summary:        Ocaml Blowfish, DES, and 3DES implementation - development part
47 Summary(pl.UTF-8):      Implementacja Blowfish, DES, and 3DES w Ocamlu - część programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51
52 %description devel
53 This package contains files needed to develop OCaml programs using
54 cryptgps library.
55
56 %description devel -l pl.UTF-8
57 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
58 używających biblioteki cryptgps.
59
60 %prep
61 %setup -q -n cryptgps
62 %patch0 -p1
63
64 %build
65 %{__make} all %{?with_ocaml_opt:opt} \
66         CC="%{__cc} %{rpmcflags} -fPIC"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptgps
71
72 cp -p META *.cm[ai] *.mli $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptgps
73 %if %{with ocaml_opt}
74 cp -p *.cmx* *.a $RPM_BUILD_ROOT%{_libdir}/ocaml/cryptgps
75 %endif
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc LICENSE README
83 %dir %{_libdir}/ocaml/cryptgps
84 %{_libdir}/ocaml/cryptgps/META
85 %{_libdir}/ocaml/cryptgps/*.cma
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_libdir}/ocaml/cryptgps/*.cmi
90 %{_libdir}/ocaml/cryptgps/*.mli
91 %if %{with ocaml_opt}
92 %{_libdir}/ocaml/cryptgps/*.a
93 %{_libdir}/ocaml/cryptgps/*.cmx
94 %{_libdir}/ocaml/cryptgps/*.cmxa
95 %endif
This page took 0.668449 seconds and 3 git commands to generate.