]> git.pld-linux.org Git - SPECS.git/blob - ntdb.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ntdb.spec
1 Summary:        A not-so trivial keyword/data database system
2 Summary(pl.UTF-8):      Nie-Trywialna Baza danych
3 Name:           ntdb
4 Version:        1.0
5 Release:        4
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        http://samba.org/ftp/tdb/%{name}-%{version}.tar.gz
9 # Source0-md5:  57848538a61704505a6d73294d019ef3
10 URL:            http://tdb.samba.org/
11 BuildRequires:  python-devel
12 BuildRequires:  rpm-pythonprov
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 NTDB is a Not-so Trivial Database. In concept, it is very much like
17 GDBM, and BSD's DB except that it allows multiple simultaneous writers
18 and uses locking internally to keep writers from trampling on each
19 other. NTDB is also extremely small.
20
21 %description -l pl.UTF-8
22 NTDB to Not-so Trivial Database, czyli już nie tak prosta baza danych
23 jak TDB. W założeniach jest bardzo podobna do GDBM lub DB z BSD z
24 wyjątkiem tego, że pozwala na zapis wielu procesom jednocześnie i
25 używa wewnętrznie blokowania, aby nie pozwolić piszącym na zadeptanie
26 się nawzajem. NTDB jest ponadto ekstremalnie mała.
27
28 %package devel
29 Summary:        Header files for NTDB library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki NTDB
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for NTDB library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki NTDB.
39
40 %package -n python-ntdb
41 Summary:        Python bindings for NTDB
42 Summary(pl.UTF-8):      Pythonowy interfejs do NTDB
43 Group:          Libraries/Python
44 Requires:       %{name} = %{version}-%{release}
45 %pyrequires_eq  python-libs
46
47 %description -n python-ntdb
48 Python bindings for NTDB.
49
50 %description -n python-ntdb -l pl.UTF-8
51 Pythonowy interfejs do NTDB.
52
53 %prep
54 %setup -q
55
56 %build
57 # note: configure in fact is waf call
58 CC="%{__cc}" \
59 CFLAGS="%{rpmcflags}" \
60 PYTHONDIR=%{py_sitedir} \
61 ./configure \
62         --prefix=%{_prefix} \
63         --libdir=%{_libdir} \
64         --disable-rpath
65
66 %{__make} \
67         V=1
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/ntdbbackup
84 %attr(755,root,root) %{_bindir}/ntdbdump
85 %attr(755,root,root) %{_bindir}/ntdbrestore
86 %attr(755,root,root) %{_bindir}/ntdbtool
87 %attr(755,root,root) %{_libdir}/libntdb.so.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libntdb.so.1
89 %{_mandir}/man8/ntdbbackup.8*
90 %{_mandir}/man8/ntdbdump.8*
91 %{_mandir}/man8/ntdbrestore.8*
92 %{_mandir}/man8/ntdbtool.8*
93
94 %files devel
95 %defattr(644,root,root,755)
96 %doc doc/*.txt doc/*.pdf
97 %attr(755,root,root) %{_libdir}/libntdb.so
98 %{_includedir}/ntdb.h
99 %{_pkgconfigdir}/ntdb.pc
100 %{_mandir}/man3/ntdb.3*
101
102 %files -n python-ntdb
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{py_sitedir}/ntdb.so
This page took 0.31616 seconds and 3 git commands to generate.