]> git.pld-linux.org Git - SPECS.git/blob - nodejs-retry.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / nodejs-retry.spec
1 %define         pkg     retry
2 Summary:        Abstraction for exponential and custom retry strategies for failed operations
3 Name:           nodejs-%{pkg}
4 Version:        0.6.0
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 URL:            https://github.com/tim-kos/retry
9 Source0:        http://registry.npmjs.org/%{pkg}/-/%{pkg}-%{version}.tgz
10 # Source0-md5:  1f8567a864418f39263a4f6f81eac30e
11 BuildRequires:  rpmbuild(macros) >= 1.634
12 BuildRequires:  sed >= 4.0
13 Requires:       nodejs
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Abstraction for exponential and custom retry strategies for failed operations.
19
20 %prep
21 %setup -qc
22 mv package/* .
23
24 %install
25 rm -rf $RPM_BUILD_ROOT
26 install -d $RPM_BUILD_ROOT{%{_bindir},%{nodejs_libdir}/%{pkg}}
27 cp -a package.json *.js lib $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
28
29 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
30 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
31
32 %clean
33 rm -rf $RPM_BUILD_ROOT
34
35 %files
36 %defattr(644,root,root,755)
37 %doc Readme.md License equation.gif
38 %{nodejs_libdir}/%{pkg}
39 %{_examplesdir}/%{name}-%{version}
This page took 0.121495 seconds and 3 git commands to generate.