]> git.pld-linux.org Git - SPECS.git/blob - nodejs-minimist.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / nodejs-minimist.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 %define         pkg     minimist
6 Summary:        Parse argument options in Node.js
7 Name:           nodejs-%{pkg}
8 Version:        0.0.8
9 Release:        1
10 License:        MIT
11 Group:          Development/Libraries
12 Source0:        https://registry.npmjs.org/minimist/-/minimist-%{version}.tgz
13 # Source0-md5:  2cf431b6650eef21fbace17b133be31e
14 URL:            https://github.com/substack/minimist
15 %if %{with tests}
16 BuildRequires:  nodejs-tap
17 BuildRequires:  nodejs-tape
18 %endif
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Parse argument options in Node.js
24
25 This module is the guts of nodejs-optimist's argument parser without
26 all the fanciful decoration.
27
28 %prep
29 %setup -qc
30 mv package/* .
31
32 %build
33 %if %{with tests}
34 tap test/*.js
35 %endif
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
40 cp -pr package.json index.js $RPM_BUILD_ROOT%{nodejs_libdir}/minimist
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc readme.markdown LICENSE example
48 %{nodejs_libdir}/%{pkg}
This page took 0.247178 seconds and 3 git commands to generate.