]> git.pld-linux.org Git - SPECS.git/blob - nodejs-minimatch.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / nodejs-minimatch.spec
1 %define         pkg     minimatch
2 Summary:        JavaScript glob matcher
3 Name:           nodejs-%{pkg}
4 Version:        1.0.0
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://registry.npmjs.org/minimatch/-/minimatch-%{version}.tgz
9 # Source0-md5:  cb1ce5c0b763576ed9ee77a72fc95668
10 URL:            https://github.com/isaacs/minimatch
11 BuildRequires:  rpmbuild(macros) >= 1.634
12 Requires:       nodejs
13 Requires:       nodejs-lru-cache < 3
14 Requires:       nodejs-lru-cache >= 2
15 Requires:       nodejs-sigmund < 1.1.0
16 Requires:       nodejs-sigmund >= 1.0.0
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Converts glob expressions to JavaScript "RegExp" objects.
22
23 %prep
24 %setup -qc
25 mv package/* .
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29
30 install -d $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
31 cp -p %{pkg}.js package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{pkg}
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %files
37 %defattr(644,root,root,755)
38 %doc README.md LICENSE
39 %doc test/
40 %{nodejs_libdir}/%{pkg}
This page took 0.806026 seconds and 3 git commands to generate.