]> git.pld-linux.org Git - SPECS.git/blob - nodejs-glob.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / nodejs-glob.spec
1 Summary:        A little globber
2 Name:           nodejs-glob
3 Version:        4.0.5
4 Release:        1
5 License:        ISC
6 Group:          Development/Libraries
7 Source0:        http://registry.npmjs.org/glob/-/glob-%{version}.tgz
8 # Source0-md5:  bca4be8504515a5d01d0205a20f9f8d6
9 URL:            https://github.com/isaacs/node-glob
10 BuildRequires:  rpmbuild(macros) >= 1.634
11 Requires:       nodejs
12 Requires:       nodejs-inherits < 3
13 Requires:       nodejs-inherits >= 2
14 Requires:       nodejs-minimatch < 2
15 Requires:       nodejs-minimatch >= 1.0.0
16 Requires:       nodejs-once < 2
17 Requires:       nodejs-once >= 1.3.0
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a glob implementation in JavaScript. It uses the minimatch
23 library to do its matching.
24
25 %prep
26 %setup -qc
27 mv package/* .
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{nodejs_libdir}/glob
32 cp -pr glob.js package.json $RPM_BUILD_ROOT%{nodejs_libdir}/glob
33
34 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
35 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc README.md
43 %{nodejs_libdir}/glob
44 %{_examplesdir}/%{name}-%{version}
This page took 0.11977 seconds and 3 git commands to generate.