]> git.pld-linux.org Git - SPECS.git/blob - nocache.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / nocache.spec
1 Summary:        Minimize filesystem caching effects
2 Summary(pl.UTF-8):      Minimalizowanie efektów buforowania systemu plików
3 Name:           nocache
4 Version:        1.1
5 Release:        1
6 License:        BSD
7 Group:          Base
8 #Source0Download: https://github.com/Feh/nocache/releases
9 Source0:        https://github.com/Feh/nocache/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  a9d37fb73036a02b0e910985dd9ed643
11 URL:            https://github.com/Feh/nocache
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 The nocache tool tries to minimize the effect an application has on
16 the Linux file system cache. This is done by intercepting the open and
17 close system calls and calling posix_fadvise with the
18 POSIX_FADV_DONTNEED parameter. Because the library remembers which
19 pages (ie., 4K-blocks of the file) were already in file system cache
20 when the file was opened, these will not be marked as "don't need",
21 because other applications might need that, although they are not
22 actively used (think: hot standby).
23
24 Use case: backup processes that should not interfere with the present
25 state of the cache.
26
27 %description -l pl.UTF-8
28 Narzędzie nocache próbuje zminimalizować wpływ buforowania systemu
29 plików w pamięci podręcznej na aplikację. Dokonuje tego poprzez
30 przechwycenie wywołań systemowych open i close i wywoływanie funkcji
31 posix_fadvise z parametrem POSIX_FADV_DONTNEED. Ponieważ biblioteka
32 zapamiętuje, które strony (tj. 4kB bloki pliku) były już w pamięci
33 podręcznej systemu plików przy otwieraniu pliku, te strony nie są
34 oznaczane jako niepotrzebne, ponieważ inne aplikacje mogą ich
35 potrzebować, mimo że nie są aktualnie używane.
36
37 Przypadek użycia: procesy kopii zapasowych, które nie powinny wpływać
38 na bieżący stan pamięci podręcznej.
39
40 %prep
41 %setup -q
42
43 %build
44 %{__make} \
45         CC="%{__cc}" \
46         CFLAGS+="%{rpmcppflags} %{rpmcflags}" \
47         LDFLAGS+="%{rpmldflags}"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT \
54         PREFIX= \
55         LIBDIR=%{_libdir} \
56         BINDIR=%{_bindir} \
57         MANDIR=%{_mandir}/man1
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README
65 %attr(755,root,root) %{_bindir}/cachedel
66 %attr(755,root,root) %{_bindir}/cachestats
67 %attr(755,root,root) %{_bindir}/nocache
68 %attr(755,root,root) %{_libdir}/nocache.so
69 %{_mandir}/man1/cachedel.1*
70 %{_mandir}/man1/cachestats.1*
71 %{_mandir}/man1/nocache.1*
This page took 0.156207 seconds and 3 git commands to generate.