]> git.pld-linux.org Git - SPECS.git/blob - njs.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / njs.spec
1 Summary:        NGS JavaScript Interpreter
2 Summary(pl.UTF-8):      Interpreter Javascriptu z NGS
3 Name:           njs
4 Version:        0.2.5
5 Release:        1
6 License:        LGPL
7 Group:          Development/Languages
8 Source0:        http://people.ssh.fi/mtr/js/js-%{version}.tar.gz
9 # Source0-md5:  b299c678e388a170eea09b6e12375152
10 Patch0:         %{name}-amfix.patch
11 URL:            http://people.ssh.fi/mtr/js/
12 # also http://www.bbassett.net/njs/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 Requires(post,postun):  /sbin/ldconfig
17 Conflicts:      js
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The NGS JavaScript is a GPL free interpreter for the JavaScript
22 language. The JavaScript language is an interpreted C-like language,
23 developed by Netscape et al.
24
25 This implementation is not 100% compatible with the JavaScript
26 language, found from the Netscape's WWW browsers and servers. To
27 achieve the following design goals, some shortcuts have been taken in
28 the implementation, as compared to the Netscape's implementation.
29
30 %description -l pl.UTF-8
31 NGS JavaScript to wolnodostępny interpreter języka JavaScript.
32 JavaScript jest interpretowanym językiem podobnym do C, rozwijanym
33 przez Netscape.
34
35 Ta implementacja nie jest w 100% zgodna z językiem JavaScript jaki
36 można znaleźć w przeglądarkach WWW i serwerach Netscape. Aby osiągnąć
37 zamierzone cele, niezbędne były pewne uproszczenia w porównaniu z
38 implementacją Netscape.
39
40 %package devel
41 Summary:        Header files for NGS JavaScript library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki NGS JavaScript
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Conflicts:      js-devel
46
47 %description devel
48 Header files for NGS JavaScript library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki NGS JavaScript.
52
53 %package static
54 Summary:        Static NGS JavaScript library
55 Summary(pl.UTF-8):      Statyczna biblioteka NGS JavaScript
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58 Conflicts:      js-static
59
60 %description static
61 Static version of NGS JavaScript library.
62
63 %description static -l pl.UTF-8
64 Statyczna wersja biblioteki NGS JavaScript.
65
66 %prep
67 %setup -q -n js-%{version}
68 %patch0 -p1
69
70 %build
71 rm -f missing
72 %{__libtoolize}
73 %{__aclocal} -I am
74 %{__autoconf}
75 %{__automake}
76 %configure \
77         --enable-shared \
78         --with-pthreads
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 /sbin/ldconfig
93 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
94
95 %postun
96 /sbin/ldconfig
97 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS NEWS README THANKS TODO
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104 %{_infodir}/js*.info*
105 %{_mandir}/man1/*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/lib*.so
110 %{_libdir}/lib*.la
111 %{_includedir}/*.h
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
This page took 1.197645 seconds and 3 git commands to generate.