]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
update rtmp plugin to 1.0.2, enable bcond
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - nginx should have own group (and work with it) or use http group ?
5 #
6 # Conditional build for nginx:
7 %bcond_without  light           # don't build light version
8 %bcond_without  mail            # don't build imap/mail proxy
9 %bcond_without  perl            # don't build with perl module
10 %bcond_without  addition        # adds module
11 %bcond_without  dav             # WebDAV
12 %bcond_without  flv             # FLV stream
13 %bcond_without  ipv6            # build without ipv6 support
14 %bcond_without  sub             # ngx_http_sub_module
15 %bcond_without  poll            # poll
16 %bcond_without  realip          # real ip (behind proxy)
17 %bcond_without  rtsig           # rtsig
18 %bcond_without  select          # select
19 %bcond_without  status          # stats module
20 %bcond_without  ssl             # ssl support
21 %bcond_with     http_browser    # header "User-agent" parser
22 %bcond_without  rtmp            # rtmp support
23
24 %define         rtmp_version    1.0.2
25 Summary:        High perfomance HTTP and reverse proxy server
26 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
27 Name:           nginx
28 Version:        1.4.1
29 Release:        3
30 License:        BSD-like
31 Group:          Networking/Daemons/HTTP
32 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
33 # Source0-md5:  fea7dfab995545ce27fe4c49dc21a972
34 Source1:        http://nginx.net/favicon.ico
35 # Source1-md5:  14054e0d276e25545c9f801c91164f69
36 Source2:        proxy.conf
37 Source3:        %{name}.logrotate
38 Source4:        %{name}.mime
39 Source5:        %{name}-light.conf
40 Source6:        %{name}-light.monitrc
41 Source7:        %{name}-light.init
42 Source8:        %{name}-mail.conf
43 Source9:        %{name}-mail.monitrc
44 Source10:       %{name}-mail.init
45 Source11:       %{name}-perl.conf
46 Source12:       %{name}-perl.monitrc
47 Source13:       %{name}-perl.init
48 Source14:       %{name}-standard.conf
49 Source15:       %{name}-standard.monitrc
50 Source16:       %{name}-standard.init
51 Source17:       %{name}-mime.types.sh
52 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}.tar.gz
53 # Source101-md5:        989659b13382e4ee3649fcaa6573c08e
54 Patch0:         nginx-no-Werror.patch
55 URL:            http://nginx.net/
56 BuildRequires:  mailcap
57 BuildRequires:  openssl-devel
58 BuildRequires:  pcre-devel
59 %{?with_perl:BuildRequires: perl-CGI}
60 %{?with_perl:BuildRequires: perl-devel}
61 %{?with_perl:BuildRequires: python}
62 %{?with_perl:BuildRequires: rpm-perlprov}
63 BuildRequires:  rpmbuild(macros) >= 1.268
64 BuildRequires:  zlib-devel
65 Requires(post,preun):   /sbin/chkconfig
66 Requires(postun):       /usr/sbin/groupdel
67 Requires(postun):       /usr/sbin/userdel
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/bin/getgid
70 Requires(pre):  /usr/sbin/groupadd
71 Requires(pre):  /usr/sbin/useradd
72 #Requires:      nginx-daemon
73 Requires:       openssl
74 Requires:       pcre
75 Requires:       rc-scripts >= 0.2.0
76 Requires:       zlib
77 Suggests:       nginx-standard
78 Provides:       group(http)
79 Provides:       group(nginx)
80 Provides:       user(nginx)
81 Provides:       webserver
82 Conflicts:      logrotate < 3.8.0
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     /etc/%{name}
86 %define         _nginxdir       /home/services/%{name}
87
88 %description
89 nginx ("engine x") is a high-performance HTTP server and reverse
90 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
91 Sysoev for Rambler.ru, Russia's second-most visited website, where it
92 has been running in production for over two and a half years. Igor has
93 released the source code under a BSD-like license. Although still in
94 beta, nginx is known for its stability, rich feature set, simple
95 configuration, and low resource consumption.
96
97 Common files for nginx daemon.
98
99 %description -l pl.UTF-8
100 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
101 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
102 na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
103 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
104 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
105 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
106 prostej konfiguracji oraz małej "zasobożerności".
107
108 Niezbędne pliki dla nginx.
109
110 %package light
111 Summary:        High perfomance HTTP and reverse proxy server
112 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
113 Group:          Networking/Daemons/HTTP
114 Requires(post,preun):   /sbin/chkconfig
115 Requires(postun):       /usr/sbin/groupdel
116 Requires(postun):       /usr/sbin/userdel
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       openssl
119 Requires:       pcre
120 Requires:       zlib
121 Provides:       group(http)
122 Provides:       group(nginx)
123 Provides:       nginx-daemon
124 Provides:       user(nginx)
125 Provides:       webserver
126
127 %description light
128 The smallest, but also the fastest nginx edition. No additional
129 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
130
131 %description light -l pl.UTF-8
132 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
133 FLV oraz IMAP, POP3, SMTP proxy.
134
135 %package perl
136 Summary:        High perfomance HTTP and reverse proxy server
137 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
138 Group:          Networking/Daemons/HTTP
139 Requires(post,preun):   /sbin/chkconfig
140 Requires(postun):       /usr/sbin/groupdel
141 Requires(postun):       /usr/sbin/userdel
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       openssl
144 Provides:       group(http)
145 Provides:       group(nginx)
146 Provides:       nginx-daemon
147 Provides:       user(nginx)
148 Provides:       webserver
149
150 %description perl
151 nginx with Perl support. Mail modules not included.
152
153 %description perl -l pl.UTF-8
154 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
155
156 %package mail
157 Summary:        High perfomance IMAP, POP3, SMTP proxy server
158 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
159 Group:          Networking/Daemons/HTTP
160 Requires(post,preun):   /sbin/chkconfig
161 Requires(postun):       /usr/sbin/groupdel
162 Requires(postun):       /usr/sbin/userdel
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       openssl
165 Requires:       pcre
166 Requires:       zlib
167 Provides:       group(http)
168 Provides:       group(nginx)
169 Provides:       nginx-daemon
170 Provides:       user(nginx)
171 Provides:       webserver
172
173 %description mail
174 nginx with mail support. Only mail modules included.
175
176 %description mail -l pl.UTF-8
177 nginx ze wsparciem tylko dla modułów poczty.
178
179 %package standard
180 Summary:        High perfomance HTTP and reverse proxy server
181 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
182 Group:          Networking/Daemons/HTTP
183 Requires(post,preun):   /sbin/chkconfig
184 Requires(postun):       /usr/sbin/groupdel
185 Requires(postun):       /usr/sbin/userdel
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       openssl
188 Provides:       group(http)
189 Provides:       group(nginx)
190 Provides:       nginx-daemon
191 Conflicts:      logrotate < 3.7-4
192
193 %description standard
194 This is standard nginx version, without Perl support and IMAP, POP3,
195 SMTP proxy. 
196
197 %description standard -l pl.UTF-8
198 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
199 IMAP, POP3, SMTP.
200
201 %package -n monit-rc-nginx
202 Summary:        nginx support for monit
203 Summary(pl.UTF-8):      Wsparcie nginx dla monit
204 Group:          Applications/System
205 URL:            http://nginx.eu/
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       monit
208
209 %description -n monit-rc-nginx
210 monitrc file for monitoring nginx webserver.
211
212 %description -n monit-rc-nginx -l pl.UTF-8
213 Plik monitrc do monitorowania serwera WWW nginx.
214
215 %prep
216 %setup -q %{?with_rtmp:-a101}
217 %patch0 -p0
218
219 %if %{with rtmp}
220 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
221 %endif
222
223 # build mime.types.conf
224 #sh %{SOURCE17} /etc/mime.types
225
226 %build
227 # NB: not autoconf generated configure
228 cp -f configure auto/
229 #
230 %if %{with perl}
231 ./configure \
232         --prefix=%{_prefix} \
233         --sbin-path=%{_sbindir}/%{name}-perl \
234         --conf-path=%{_sysconfdir}/%{name}-perl.conf \
235         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
236         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
237         --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
238         --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
239         --user=nginx \
240         --group=nginx \
241         --with-http_perl_module \
242         --without-mail_pop3_module \
243         --without-mail_imap_module \
244         --without-mail_smtp_module \
245         %{?with_addition:--with-http_addition_module} \
246         %{?with_dav:--with-http_dav_module} \
247         %{?with_flv:--with-http_flv_module} \
248         %{?with_ipv6:--with-ipv6} \
249         %{?with_sub:--with-http_sub_module} \
250         %{?with_poll:--with-poll_module} \
251         %{?with_realip:--with-http_realip_module} \
252         %{?with_rtsig:--with-rtsig_module} \
253         %{?with_select:--with-select_module} \
254         %{?with_status:--with-http_stub_status_module} \
255         %{?with_ssl:--with-http_ssl_module} \
256         %{!?with_http_browser:--without-http_browser_module} \
257         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
258         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
259         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
260         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
261         --with-cc="%{__cc}" \
262         --with-cc-opt="%{rpmcflags}" \
263         --with-ld-opt="%{rpmldflags}"
264 %{__make}
265 mv -f objs/nginx contrib/nginx-perl
266 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
267 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
268 mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
269 %endif
270
271 %if %{with mail}
272 ./configure \
273         --prefix=%{_prefix} \
274         --sbin-path=%{_sbindir}/%{name}-mail \
275         --conf-path=%{_sysconfdir}/%{name}-mail.conf \
276         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
277         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
278         --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
279         --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
280         --user=nginx \
281         --group=nginx \
282         --with-imap \
283         --with-mail \
284         --with-mail_ssl_module \
285         --without-http \
286         %{?with_ipv6:--with-ipv6} \
287         %{?with_poll:--with-poll_module} \
288         %{?with_rtsig:--with-rtsig_module} \
289         %{?with_select:--with-select_module} \
290         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
291         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
292         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
293         --with-cc="%{__cc}" \
294         --with-cc-opt="%{rpmcflags}" \
295         --with-ld-opt="%{rpmldflags}" \
296         %{?debug:--with-debug}
297 %{__make}
298 mv -f objs/nginx contrib/nginx-mail
299 %endif
300
301 %if %{with light}
302 ./configure \
303         --prefix=%{_prefix} \
304         --sbin-path=%{_sbindir}/%{name}-light \
305         --conf-path=%{_sysconfdir}/%{name}-light.conf \
306         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
307         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
308         --pid-path=%{_localstatedir}/run/%{name}-light.pid \
309         --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
310         --user=nginx \
311         --group=nginx \
312         %{?with_ipv6:--with-ipv6} \
313         %{?with_poll:--with-poll_module} \
314         %{?with_realip:--with-http_realip_module} \
315         %{?with_rtsig:--with-rtsig_module} \
316         %{?with_select:--with-select_module} \
317         %{?with_status:--with-http_stub_status_module} \
318         %{?with_ssl:--with-http_ssl_module} \
319         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
320         --without-http_browser_module \
321         --without-mail_pop3_module \
322         --without-mail_imap_module \
323         --without-mail_smtp_module \
324         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
325         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
326         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
327         --with-cc="%{__cc}" \
328         --with-cc-opt="%{rpmcflags}" \
329         --with-ld-opt="%{rpmldflags}" \
330         %{?debug:--with-debug}
331 %{__make}
332 mv -f objs/nginx contrib/nginx-light
333 %endif
334
335 ./configure \
336         --prefix=%{_prefix} \
337         --sbin-path=%{_sbindir}/%{name}-standard \
338         --conf-path=%{_sysconfdir}/%{name}-standard.conf \
339         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
340         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
341         --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
342         --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
343         --user=nginx \
344         --group=nginx \
345         %{?with_addition:--with-http_addition_module} \
346         %{?with_dav:--with-http_dav_module} \
347         %{?with_flv:--with-http_flv_module} \
348         %{?with_ipv6:--with-ipv6} \
349         %{?with_sub:--with-http_sub_module} \
350         %{?with_poll:--with-poll_module} \
351         %{?with_realip:--with-http_realip_module} \
352         %{?with_rtsig:--with-rtsig_module} \
353         %{?with_select:--with-select_module} \
354         %{?with_status:--with-http_stub_status_module} \
355         %{?with_ssl:--with-http_ssl_module} \
356         %{!?with_http_browser:--without-http_browser_module} \
357         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
358         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
359         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
360         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
361         --with-cc="%{__cc}" \
362         --with-cc-opt="%{rpmcflags}" \
363         --with-ld-opt="%{rpmldflags}" \
364         %{?debug:--with-debug}
365 %{__make}
366
367
368 %install
369 rm -rf $RPM_BUILD_ROOT
370 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
371         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
372         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
373         $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
374         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
375         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
376         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
377
378 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
379 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
380 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
381 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
382 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
383 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
384 install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
385 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
386 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
387 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
388 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
389 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
390 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
391 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
392
393 %if %{with light}
394 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
395 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
396 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
397 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
398 %endif
399
400 %if %{with mail}
401 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
402 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
403 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
404 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
405 %endif
406
407 %if %{with perl}
408 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
409 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
410 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
411 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
412 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
413 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
414 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
415 install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
416 %endif
417
418 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
419 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %pre
425 %groupadd -r -g 213 %{name}
426 %groupadd -g 51 http
427 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
428 %addusertogroup %{name} http
429
430 %post standard
431 for a in access.log error.log; do
432         if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
433                 umask 022
434                 touch /var/log/%{name}/nginx-standard_$a
435                 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
436                 chmod 644 /var/log/%{name}/nginx-standard_$a
437         fi
438 done
439 /sbin/chkconfig --add %{name}-standard
440 %service %{name}-standard restart
441 echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
442
443 %post light
444 for a in access.log error.log; do
445         if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
446                 umask 022
447                 touch /var/log/%{name}/nginx-light_$a
448                 chown nginx:nginx /var/log/%{name}/nginx-light_$a
449                 chmod 644 /var/log/%{name}/nginx-light_$a
450         fi
451 done
452 /sbin/chkconfig --add %{name}-light
453 %service %{name}-light restart
454 echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
455
456 %post perl
457 for a in access.log error.log; do
458         if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
459                 umask 022
460                 touch /var/log/%{name}/nginx-perl_$a
461                 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
462                 chmod 644 /var/log/%{name}/nginx-perl_$a
463         fi
464 done
465 /sbin/chkconfig --add %{name}-perl
466 %service %{name}-perl restart
467 echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
468
469 %post mail
470 for a in access.log error.log; do
471         if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
472                 umask 022
473                 touch /var/log/%{name}/nginx-mail_$a
474                 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
475                 chmod 644 /var/log/%{name}/nginx-mail_$a
476         fi
477 done
478 /sbin/chkconfig --add %{name}-mail
479 %service %{name}-mail restart
480 echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
481
482 %preun standard
483 if [ "$1" = "0" ];then
484         %service %{name}-standard stop
485         /sbin/chkconfig --del %{name}-standard
486 fi
487
488 %preun light
489 if [ "$1" = "0" ]; then
490         %service %{name}-light stop
491         /sbin/chkconfig --del %{name}-light
492 fi
493
494 %preun perl
495 if [ "$1" = "0" ]; then
496         %service %{name}-perl stop
497         /sbin/chkconfig --del %{name}-perl
498 fi
499
500 %preun mail
501 if [ "$1" = "0" ]; then
502         %service %{name}-mail stop
503         /sbin/chkconfig --del %{name}-mail
504 fi
505
506 %postun
507 if [ "$1" = "0" ]; then
508         %userremove %{name}
509         %groupremove %{name}
510 fi
511
512 %files
513 %defattr(644,root,root,755)
514 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
515 %doc %lang(ru) CHANGES.ru
516 %dir %attr(754,root,root) %{_sysconfdir}
517 %dir %{_nginxdir}
518 %dir %{_nginxdir}/cgi-bin
519 %dir %{_nginxdir}/html
520 %dir %{_nginxdir}/errors
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
522 # XXX: duplicates, don't use such glob here
523 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
525 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
526 %attr(640,root,root) %{_sysconfdir}/mime.types
527 %attr(640,root,root) %{_sysconfdir}/koi-utf
528 %attr(640,root,root) %{_sysconfdir}/koi-win
529 %attr(640,root,root) %{_sysconfdir}/win-utf
530 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
531 %attr(750,nginx,logs) /var/log/%{name}
532 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
533 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
534
535 %files standard
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_sbindir}/%{name}-standard
538 %attr(770,root,%{name}) /var/cache/%{name}-standard
539 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
541
542 %if %{with mail}
543 %files mail
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_sbindir}/%{name}-mail
546 %attr(770,root,%{name}) /var/cache/%{name}-mail
547 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
548 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
549 %endif
550
551 %if %{with light}
552 %files light
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_sbindir}/%{name}-light
555 %attr(770,root,%{name}) /var/cache/%{name}-light
556 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
558 %endif
559
560 %if %{with perl}
561 %files perl
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_sbindir}/%{name}-perl
564 %attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
565 %attr(770,root,%{name}) /var/cache/%{name}-perl
566 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
567 %dir %{perl_vendorarch}/auto/%{name}
568 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
569 %{perl_vendorarch}/auto/%{name}/%{name}.bs
570 %{perl_vendorarch}/%{name}.pm
571 %endif
572
573 %files -n monit-rc-nginx
574 %defattr(644,root,root,755)
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
576 %if %{with perl}
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
578 %endif
579 %if %{with light}
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
581 %endif
582 %if %{with mail}
583 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
584 %endif
This page took 0.07312 seconds and 4 git commands to generate.