]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- clean up with bconds
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - more bconds (??)
3 # - subpackage with error pages
4 # - /etc/sysconfig/nginx file
5 # - prepare style like nginx.conf
6 #
7 # Conditional build for nginx:
8 %bcond_without  stub_status             # stats module
9 %bcond_without  rtsig
10 %bcond_without  select
11 %bcond_without  poll
12 %bcond_without  ssl                     # ssl support
13 %bcond_without  imap                    # imap proxy
14 %bcond_with     http_browser            # header "User-agent" parser
15 #
16 Summary:        High perfomance HTTP and reverse proxy server
17 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
18 Name:           nginx
19 Version:        0.5.31
20 Release:        3
21 License:        BSD-like
22 Group:          Networking/Daemons
23 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
24 # Source0-md5:  d84ef8e624b8953faf9cee2b5da535c1
25 Source1:        %{name}.init
26 Source2:        %{name}-mime.types.sh
27 Source3:        http://www.nginx.eu/favicon.ico
28 # Source3-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
29 Source4:        http://www.nginx.eu/download/proxy.conf
30 # Source4-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
31 Source5:        http://www.nginx.eu/download/%{name}.monitrc
32 # Source5-md5:  1d3f5eedfd34fe95213f9e0fc19daa88
33 Source6:        http://www.nginx.eu/download/%{name}.conf
34 # Source6-md5:  1c112d6f03d0f365e4acc98c1d96261a
35 Source7:        %{name}.logrotate
36 Patch0:         %{name}-config.patch
37 URL:            http://nginx.net/
38 BuildRequires:  mailcap
39 BuildRequires:  openssl-devel
40 BuildRequires:  pcre-devel
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 BuildRequires:  zlib-devel
43 Requires(post,preun):   /sbin/chkconfig
44 Requires(postun):       /usr/sbin/groupdel
45 Requires(postun):       /usr/sbin/userdel
46 Requires(pre):  /bin/id
47 Requires(pre):  /usr/bin/getgid
48 Requires(pre):  /usr/sbin/groupadd
49 Requires(pre):  /usr/sbin/useradd
50 Requires:       rc-scripts
51 Provides:       group(http)
52 Provides:       group(nginx)
53 Provides:       user(nginx)
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _sysconfdir     /etc/%{name}
57 %define         _nginxdir       /home/services/%{name}
58
59 %description
60 Nginx ("engine x") is a high-performance HTTP server and reverse
61 proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
62 Sysoev for Rambler.ru, Russia's second-most visited website, where it
63 has been running in production for over two and a half years. Igor has
64 released the source code under a BSD-like license. Although still in
65 beta, Nginx is known for its stability, rich feature set, simple
66 configuration, and low resource consumption.
67
68 %description -l pl.UTF-8
69 Serwer HTTP i odwrotne proxy o wysokiej wydajności.
70
71
72 %package -n monit-rc-nginx
73 Summary:        Nginx  support for monit
74 Summary(pl.UTF-8):      Wsparcie nginx dla monit
75 Group:          Applications/System
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       monit
78
79 %description -n monit-rc-nginx
80 monitrc file for monitoring nginx webserver server.
81
82 %description -n monit-rc-nginx -l pl.UTF-8
83 Plik monitrc do monitorowania serwera www nginx.
84
85
86 %prep
87 %setup -q
88 %patch0 -p0
89
90 # build mime.types.conf
91 sh %{SOURCE2} /etc/mime.types
92
93 %build
94 # NB: not autoconf generated configure
95 ./configure \
96         --prefix=%{_prefix} \
97         --sbin-path=%{_sbindir}/%{name} \
98         --conf-path=%{_sysconfdir}/%{name}.conf \
99         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
100         --pid-path=%{_localstatedir}/run/%{name}.pid \
101         --user=nginx \
102         --group=nginx \
103         %{?with_stub_status:--with-http_stub_status_module} \
104         %{?with_rtsig:--with-rtsig_module} \
105         %{?with_select:--with-select_module} \
106         %{?with_poll:--with-poll_module} \
107         %{?with_ssl:--with-http_ssl_module} \
108         %{?with_imap:--with-imap} \
109         %{!?with_http_browser:--without-http_browser_module} \
110         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
111         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
112         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
113         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
114         --with-cc="%{__cc}" \
115         --with-cc-opt="%{rpmcflags}" \
116         --with-ld-opt="%{rpmldflags}" \
117         %{?debug:--with-debug}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
124         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
125         $RPM_BUILD_ROOT{%{_localstatedir}/log/{%{name},archive/%{name}},%{_localstatedir}/cache/%{name}} \
126         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
127         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
128
129 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
130 install mime.types $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
131 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
132 install %{SOURCE3} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
133 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
134 install %{SOURCE5} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
135 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
136 install %{SOURCE7} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
137
138 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
139
140 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
141 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %pre
147 %groupadd -r -g 213 %{name}
148 %groupadd -g 51 http
149 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
150 %addusertogroup %{name} http
151
152 %post
153 for a in access.log error.log; do
154         if [ ! -f /var/log/%{name}/$a ]; then
155                 touch /var/log/%{name}/$a
156                 chown nginx:nginx /var/log/%{name}/$a
157                 chmod 644 /var/log/%{name}/$a
158         fi
159 done
160 /sbin/chkconfig --add %{name}
161 %service %{name} restart
162
163 %preun
164 if [ "$1" = "0" ]; then
165         %service -q %{name} stop
166         /sbin/chkconfig --del %{name}
167 fi
168
169 %postun
170 if [ "$1" = "0" ]; then
171         %userremove %{name}
172         %groupremove %{name}
173 fi
174
175 %files
176 %defattr(644,root,root,755)
177 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
178 %doc %lang(ru) CHANGES.ru
179 %attr(754,root,root) /etc/rc.d/init.d/%{name}
180 %dir %attr(754,root,root) %{_sysconfdir}
181 %dir %{_nginxdir}
182 %dir %{_nginxdir}/cgi-bin
183 %dir %{_nginxdir}/html
184 %dir %{_nginxdir}/errors
185 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
186 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
187 %attr(640,root,root) %{_sysconfdir}/*[_-]*
188 %attr(640,root,root) %{_sysconfdir}/proxy.conf
189 %attr(640,root,root) %{_sysconfdir}/mime.types
190 %attr(755,root,root) %{_sbindir}/%{name}
191 %attr(770,root,%{name}) /var/cache/%{name}
192 %attr(750,%{name},logs) /var/log/%{name}
193 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
194
195 %files -n monit-rc-nginx
196 %defattr(644,root,root,755)
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.142667 seconds and 4 git commands to generate.