]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- added index.html and 50x.html pages
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - more bconds (??)
3 # - /etc/sysconfig/nginx file
4 # - prepare style like nginx.conf
5 #
6 # Conditional build for nginx:
7 %bcond_without  stub_status             # stats module
8 %bcond_without  rtsig
9 %bcond_without  select
10 %bcond_without  poll
11 %bcond_without  ssl                     # ssl support
12 %bcond_without  imap                    # imap proxy
13 %bcond_with     http_browser            # header "User-agent" parser
14 #
15 Summary:        High perfomance HTTP and reverse proxy server
16 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
17 Name:           nginx
18 Version:        0.5.31
19 Release:        3.1
20 License:        BSD-like
21 Group:          Networking/Daemons
22 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
23 # Source0-md5:  d84ef8e624b8953faf9cee2b5da535c1
24 Source1:        %{name}.init
25 Source2:        %{name}-mime.types.sh
26 Source3:        http://www.nginx.eu/favicon.ico
27 # Source3-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
28 Source4:        http://www.nginx.eu/download/proxy.conf
29 # Source4-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
30 Source5:        http://www.nginx.eu/download/%{name}.monitrc
31 # Source5-md5:  1d3f5eedfd34fe95213f9e0fc19daa88
32 Source6:        http://www.nginx.eu/download/%{name}.conf
33 # Source6-md5:  1c112d6f03d0f365e4acc98c1d96261a
34 Source7:        %{name}.logrotate
35 Patch0:         %{name}-config.patch
36 URL:            http://nginx.net/
37 BuildRequires:  mailcap
38 BuildRequires:  openssl-devel
39 BuildRequires:  pcre-devel
40 BuildRequires:  rpmbuild(macros) >= 1.268
41 BuildRequires:  zlib-devel
42 Requires(post,preun):   /sbin/chkconfig
43 Requires(postun):       /usr/sbin/groupdel
44 Requires(postun):       /usr/sbin/userdel
45 Requires(pre):  /bin/id
46 Requires(pre):  /usr/bin/getgid
47 Requires(pre):  /usr/sbin/groupadd
48 Requires(pre):  /usr/sbin/useradd
49 Requires:       rc-scripts
50 Provides:       group(http)
51 Provides:       group(nginx)
52 Provides:       user(nginx)
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         _sysconfdir     /etc/%{name}
56 %define         _nginxdir       /home/services/%{name}
57
58 %description
59 Nginx ("engine x") is a high-performance HTTP server and reverse
60 proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
61 Sysoev for Rambler.ru, Russia's second-most visited website, where it
62 has been running in production for over two and a half years. Igor has
63 released the source code under a BSD-like license. Although still in
64 beta, Nginx is known for its stability, rich feature set, simple
65 configuration, and low resource consumption.
66
67 %description -l pl.UTF-8
68 Serwer HTTP i odwrotne proxy o wysokiej wydajności.
69
70
71 %package -n monit-rc-nginx
72 Summary:        Nginx  support for monit
73 Summary(pl.UTF-8):      Wsparcie nginx dla monit
74 Group:          Applications/System
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       monit
77
78 %description -n monit-rc-nginx
79 monitrc file for monitoring nginx webserver server.
80
81 %description -n monit-rc-nginx -l pl.UTF-8
82 Plik monitrc do monitorowania serwera www nginx.
83
84
85 %prep
86 %setup -q
87 %patch0 -p0
88
89 # build mime.types.conf
90 sh %{SOURCE2} /etc/mime.types
91
92 %build
93 # NB: not autoconf generated configure
94 ./configure \
95         --prefix=%{_prefix} \
96         --sbin-path=%{_sbindir}/%{name} \
97         --conf-path=%{_sysconfdir}/%{name}.conf \
98         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
99         --pid-path=%{_localstatedir}/run/%{name}.pid \
100         --user=nginx \
101         --group=nginx \
102         %{?with_stub_status:--with-http_stub_status_module} \
103         %{?with_rtsig:--with-rtsig_module} \
104         %{?with_select:--with-select_module} \
105         %{?with_poll:--with-poll_module} \
106         %{?with_ssl:--with-http_ssl_module} \
107         %{?with_imap:--with-imap} \
108         %{!?with_http_browser:--without-http_browser_module} \
109         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
110         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
111         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
112         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
113         --with-cc="%{__cc}" \
114         --with-cc-opt="%{rpmcflags}" \
115         --with-ld-opt="%{rpmldflags}" \
116         %{?debug:--with-debug}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
123         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
124         $RPM_BUILD_ROOT{%{_localstatedir}/log/{%{name},archive/%{name}},%{_localstatedir}/cache/%{name}} \
125         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
126         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
127
128 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
129 install mime.types $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
130 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
131 install %{SOURCE3} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
132 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
133 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
134 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
135 install %{SOURCE5} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
136 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
137 install %{SOURCE7} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
138
139 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
140
141 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
142 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %pre
148 %groupadd -r -g 213 %{name}
149 %groupadd -g 51 http
150 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
151 %addusertogroup %{name} http
152
153 %post
154 for a in access.log error.log; do
155         if [ ! -f /var/log/%{name}/$a ]; then
156                 touch /var/log/%{name}/$a
157                 chown nginx:nginx /var/log/%{name}/$a
158                 chmod 644 /var/log/%{name}/$a
159         fi
160 done
161 /sbin/chkconfig --add %{name}
162 %service %{name} restart
163
164 %preun
165 if [ "$1" = "0" ]; then
166         %service -q %{name} stop
167         /sbin/chkconfig --del %{name}
168 fi
169
170 %postun
171 if [ "$1" = "0" ]; then
172         %userremove %{name}
173         %groupremove %{name}
174 fi
175
176 %files
177 %defattr(644,root,root,755)
178 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
179 %doc %lang(ru) CHANGES.ru
180 %attr(754,root,root) /etc/rc.d/init.d/%{name}
181 %dir %attr(754,root,root) %{_sysconfdir}
182 %dir %{_nginxdir}
183 %dir %{_nginxdir}/cgi-bin
184 %dir %{_nginxdir}/html
185 %dir %{_nginxdir}/errors
186 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
187 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
188 %attr(640,root,root) %{_sysconfdir}/*[_-]*
189 %attr(640,root,root) %{_sysconfdir}/proxy.conf
190 %attr(640,root,root) %{_sysconfdir}/mime.types
191 %attr(755,root,root) %{_sbindir}/%{name}
192 %attr(770,root,%{name}) /var/cache/%{name}
193 %attr(750,root,root) %dir /var/log/archive/%{name}
194 %attr(750,%{name},logs) /var/log/%{name}
195 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
196 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
197
198 %files -n monit-rc-nginx
199 %defattr(644,root,root,755)
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.085742 seconds and 4 git commands to generate.