]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
mod_stream_geoip requires mod_stream
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 #
5 # Conditional build for nginx:
6 # Features
7 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
8 %bcond_without  threads         # thread pool support
9 # Modules
10 %bcond_without  addition        # http addition module
11 %bcond_without  auth_request    # auth_request module
12 %bcond_without  dav             # WebDAV
13 %bcond_without  flv             # http FLV module
14 %bcond_without  gd              # without http image filter module
15 %bcond_without  geoip           # without http geoip module and stream geoip module
16 %bcond_without  http2           # HTTP/2 module
17 %bcond_without  mail            # don't build imap/mail proxy
18 %bcond_without  perl            # don't build with perl module
19 %bcond_without  poll            # poll module
20 %bcond_without  realip          # real ip (behind proxy)
21 %bcond_without  select          # select module
22 %bcond_without  ssl             # ssl support and http ssl module
23 %bcond_without  stream          # TCP/UDP proxy module
24 %bcond_without  stub_status     # http stub status module
25 %bcond_without  sub             # ngx_http_sub_module
26 %bcond_without  xslt            # without http xslt module
27 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
28 %bcond_with     modsecurity     # modsecurity module
29 %bcond_with     rtmp            # rtmp support
30
31 %ifarch x32
32 %undefine       with_rtsig
33 %endif
34
35 %define         ssl_version     1.0.2
36 %define         rtmp_version    1.1.7
37 %define         modsecurity_version     2.9.1
38 Summary:        High perfomance HTTP and reverse proxy server
39 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
40 # nginx lines:
41 # - stable: production quality with stable API
42 # - mainline: production quality but API can change
43 Name:           nginx
44 Version:        1.11.5
45 Release:        0.5
46 License:        BSD-like
47 Group:          Networking/Daemons/HTTP
48 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
49 # Source0-md5:  db43f2b19746f6f47401c3afc3924dc6
50 Source1:        http://nginx.net/favicon.ico
51 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
52 Source2:        proxy.conf
53 Source3:        %{name}.logrotate
54 Source4:        %{name}.mime
55 Source6:        %{name}.monitrc
56 Source7:        %{name}.init
57 Source14:       %{name}.conf
58 Source17:       %{name}-mime.types.sh
59 Source18:       %{name}.service
60 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
61 # Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
62 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
63 # Source101-md5:        8006de2560db3e55bb15d110220076ac
64 Patch0:         %{name}-no-Werror.patch
65 Patch1:         %{name}-modsecurity-xheaders.patch
66 URL:            http://nginx.net/
67 BuildRequires:  mailcap
68 BuildRequires:  pcre-devel
69 BuildRequires:  rpmbuild(macros) >= 1.644
70 BuildRequires:  zlib-devel
71 %if %{with geoip}
72 BuildRequires:  GeoIP-devel
73 %endif
74 %if %{with gd}
75 BuildRequires:  gd-devel
76 %endif
77 %if %{with modsecurity}
78 BuildRequires:  lua-devel
79 %endif
80 %if %{with perl}
81 BuildRequires:  perl-CGI
82 BuildRequires:  perl-devel
83 BuildRequires:  python
84 BuildRequires:  rpm-perlprov
85 %endif
86 %if %{with ssl}
87 BuildRequires:  openssl-devel >= %{ssl_version}
88 Requires:       openssl >= %{ssl_version}
89 %endif
90 %if %{with xslt}
91 BuildRequires:  libxslt-devel
92 %endif
93 Provides:       group(http)
94 Provides:       group(nginx)
95 Provides:       user(nginx)
96 Provides:       webserver
97 Provides:       webserver(access)
98 Provides:       webserver(alias)
99 Provides:       webserver(auth)
100 Provides:       webserver(expires)
101 Provides:       webserver(headers)
102 Provides:       webserver(indexfile)
103 Provides:       webserver(log)
104 Provides:       webserver(mime)
105 Provides:       webserver(reqtimeout)
106 Provides:       webserver(rewrite)
107 Provides:       webserver(setenv)
108 Conflicts:      logrotate < 3.8.0
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(post,preun,postun):    systemd-units >= 38
111 Requires(postun):       /usr/sbin/groupdel
112 Requires(postun):       /usr/sbin/userdel
113 Requires(pre):  /bin/id
114 Requires(pre):  /usr/bin/getgid
115 Requires(pre):  /usr/sbin/groupadd
116 Requires(pre):  /usr/sbin/useradd
117 Requires:       rc-scripts >= 0.2.0
118 Requires:       systemd-units >= 38
119 Suggests:       vim-syntax-nginx
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sysconfdir     /etc/%{name}
123 %define         _nginxdir       /home/services/%{name}
124
125 %description
126 nginx ("engine x") is a high-performance HTTP server and reverse
127 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
128 Sysoev for Rambler.ru, Russia's second-most visited website, where it
129 has been running in production for over two and a half years. Igor has
130 released the source code under a BSD-like license. Although still in
131 beta, nginx is known for its stability, rich feature set, simple
132 configuration, and low resource consumption.
133
134 %description -l pl.UTF-8
135 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
136 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
137 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
138 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
139 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
140 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
141 prostej konfiguracji oraz małej "zasobożerności".
142
143 %package mod_http_geoip
144 Summary:        Nginx HTTP geoip module
145 Group:          Daemons
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       GeoIP
148
149 %description mod_http_geoip
150 Nginx HTTP geoip module.
151
152 %package mod_stream_geoip
153 Summary:        Nginx stream geoip module
154 Group:          Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       %{name}-mod_stream = %{version}-%{release}
157 Requires:       GeoIP
158
159 %description mod_stream_geoip
160 Nginx stream geoip module.
161
162 %package mod_http_image_filter
163 Summary:        Nginx HTTP image filter module
164 Group:          Daemons
165 Requires:       %{name} = %{version}-%{release}
166
167 %description mod_http_image_filter
168 Nginx HTTP image filter module.
169
170 %package mod_http_perl
171 Summary:        Nginx HTTP Perl module
172 Group:          Networking/Daemons/HTTP
173 Requires:       %{name} = %{version}-%{release}
174
175 %description mod_http_perl
176 Nginx HTTP Perl module.
177
178 %package mod_http_xslt_filter
179 Summary:        Nginx XSLT module
180 Group:          Daemons
181 Requires:       %{name} = %{version}-%{release}
182
183 %description mod_http_xslt_filter
184 Nginx XSLT module.
185
186 %package mod_mail
187 Summary:        Nginx mail module
188 Group:          Networking/Daemons/HTTP
189 Requires:       %{name} = %{version}-%{release}
190
191 %description mod_mail
192 Nginx mail module.
193
194 %package mod_stream
195 Summary:        Nginx stream modules
196 Group:          Daemons
197 Requires:       %{name} = %{version}-%{release}
198
199 %description mod_stream
200 Nginx stream modules.
201
202 %package -n monit-rc-nginx
203 Summary:        nginx support for monit
204 Summary(pl.UTF-8):      Wsparcie nginx dla monit
205 Group:          Applications/System
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       monit
208
209 %description -n monit-rc-nginx
210 monitrc file for monitoring nginx webserver.
211
212 %description -n monit-rc-nginx -l pl.UTF-8
213 Plik monitrc do monitorowania serwera WWW nginx.
214
215 %prep
216 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
217 %patch0 -p0
218 %{?with_modsecurity:%patch1 -p0}
219
220 %if %{with rtmp}
221 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
222 %endif
223
224 # build mime.types.conf
225 #sh %{SOURCE17} /etc/mime.types
226
227 %build
228 # NB: not autoconf generated configure
229 cp -f configure auto/
230
231 ./configure \
232         --prefix=%{_prefix} \
233         --modules-path=%{_libdir}/%{name}/modules \
234         --sbin-path=%{_sbindir}/%{name} \
235         --conf-path=%{_sysconfdir}/%{name}.conf \
236         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
237         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
238         --pid-path=%{_localstatedir}/run/%{name}.pid \
239         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
240         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
241         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
242         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
243         --user=nginx \
244         --group=nginx \
245         %{?with_select:--with-select_module} \
246         %{?with_poll:--with-poll_module} \
247         %{?with_rtsig:--with-rtsig_module} \
248         %{?with_perl:--with-http_perl_module=dynamic} \
249         %{?with_gd:--with-http_image_filter_module=dynamic} \
250         %{?with_xslt:--with-http_xslt_module=dynamic} \
251         %{?with_geoip:--with-http_geoip_module=dynamic} \
252         %{?with_geoip:--with-stream_geoip_module=dynamic} \
253 %if %{with mail}
254         --with-mail=dynamic \
255         --with-mail_ssl_module \
256 %endif
257 %if %{with stream}
258         --with-stream=dynamic \
259         --with-stream_ssl_module \
260 %endif
261         --with-cc="%{__cc}" \
262         --with-cc-opt="%{rpmcflags}" \
263         --with-ld-opt="%{rpmldflags}" \
264         %{?with_debug:--with-debug} \
265         %{?with_addition:--with-http_addition_module} \
266         %{?with_dav:--with-http_dav_module} \
267         %{?with_flv:--with-http_flv_module} \
268         %{?with_sub:--with-http_sub_module} \
269         %{?with_realip:--with-http_realip_module} \
270         %{?with_stub_status:--with-http_stub_status_module} \
271         %{?with_ssl:--with-http_ssl_module} \
272         %{!?with_http_browser:--without-http_browser_module} \
273         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
274         %{?with_auth_request:--with-http_auth_request_module} \
275         %{?with_threads:--with-threads} \
276         %{?with_http2:--with-http_v2_module} \
277         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
278         --with-http_secure_link_module \
279         %{nil}
280
281 %{__make}
282
283 %if %{with modsecurity}
284 cd modsecurity-%{modsecurity_version}
285 ./autogen.sh
286 %configure \
287         --enable-standalone-module \
288         --disable-mlogc \
289         --enable-alp2 \
290         --with-lua=/usr
291 %{__make}
292 cd ..
293 %endif
294
295 %install
296 rm -rf $RPM_BUILD_ROOT
297 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
298         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
299         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
300         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
301         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
302         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
303         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
304         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
305
306 %{__make} install \
307         INSTALLDIRS=vendor \
308         DESTDIR=$RPM_BUILD_ROOT
309
310 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
311
312 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
313 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
314 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
315 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
316
317 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
318 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
319 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
320 rm -r $RPM_BUILD_ROOT%{_prefix}/html
321 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
322 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
323 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
324
325 load_module() {
326         local module=ngx_${1}_module.so conffile=mod_$1.conf
327         printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
328                 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
329 }
330
331 %if %{with perl}
332 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
333 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
334 load_module http_perl
335 %endif
336
337 %if %{with geoip}
338 load_module http_geoip
339 load_module stream_geoip
340 %endif
341 %if %{with gd}
342 load_module http_image_filter
343 %endif
344 %if %{with xslt}
345 load_module http_xslt_filter
346 %endif
347 %if %{with mail}
348 load_module mail
349 %endif
350 %if %{with stream}
351 load_module stream
352 %endif
353
354 %clean
355 rm -rf $RPM_BUILD_ROOT
356
357 %pre
358 %groupadd -r -g 213 %{name}
359 %groupadd -g 51 http
360 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
361 %addusertogroup %{name} http
362
363 %post
364 for a in access.log error.log; do
365         if [ ! -f /var/log/%{name}/$a ]; then
366                 umask 022
367                 touch /var/log/%{name}/$a
368                 chown nginx:nginx /var/log/%{name}/$a
369                 chmod 644 /var/log/%{name}/$a
370         fi
371 done
372 /sbin/chkconfig --add %{name}
373 %systemd_post %{name}.service
374 %service %{name} force-reload
375
376 %preun
377 if [ "$1" = "0" ];then
378         %service %{name} stop
379         /sbin/chkconfig --del %{name}
380 fi
381 %systemd_preun %{name}.service
382
383 %postun
384 if [ "$1" = "0" ]; then
385         %userremove %{name}
386         %groupremove %{name}
387 fi
388 %systemd_reload
389
390 %files
391 %defattr(644,root,root,755)
392 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
393 %doc %lang(ru) CHANGES.ru
394 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
395 %attr(754,root,root) /etc/rc.d/init.d/%{name}
396 %dir %attr(750,root,nginx) %{_sysconfdir}
397 %dir %{_sysconfdir}/conf.d
398 %dir %{_sysconfdir}/modules.d
399 %dir %{_sysconfdir}/vhosts.d
400 %dir %{_sysconfdir}/webapps.d
401 %attr(640,root,root) %{_sysconfdir}/mime.types
402 %attr(640,root,root) %{_sysconfdir}/koi-utf
403 %attr(640,root,root) %{_sysconfdir}/koi-win
404 %attr(640,root,root) %{_sysconfdir}/win-utf
405 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
406 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
407 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
408 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
409 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
410 %attr(755,root,root) %{_sbindir}/%{name}
411 %dir %{_libdir}/%{name}
412 %dir %{_libdir}/%{name}/modules
413 %{systemdunitdir}/%{name}.service
414
415 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
416 %attr(750,nginx,logs) /var/log/%{name}
417 %attr(770,root,nginx) /var/cache/%{name}
418
419 %dir %{_nginxdir}
420 %dir %{_nginxdir}/cgi-bin
421 %dir %{_nginxdir}/html
422 %dir %{_nginxdir}/errors
423 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
424 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
425
426 %if %{with geoip}
427 %files mod_http_geoip
428 %defattr(644,root,root,755)
429 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
430 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
431
432 %files mod_stream_geoip
433 %defattr(644,root,root,755)
434 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
435 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
436 %endif
437
438 %if %{with gd}
439 %files mod_http_image_filter
440 %defattr(644,root,root,755)
441 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
442 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
443 %endif
444
445 %if %{with perl}
446 %files mod_http_perl
447 %defattr(644,root,root,755)
448 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
449 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
450 %dir %{perl_vendorarch}/auto/%{name}
451 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
452 %{perl_vendorarch}/%{name}.pm
453 %{_mandir}/man3/nginx.3pm*
454 %endif
455
456 %if %{with xslt}
457 %files mod_http_xslt_filter
458 %defattr(644,root,root,755)
459 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
460 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
461 %endif
462
463 %if %{with mail}
464 %files mod_mail
465 %defattr(644,root,root,755)
466 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
467 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
468 %endif
469
470 %if %{with stream}
471 %files mod_stream
472 %defattr(644,root,root,755)
473 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
474 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
475 %endif
476
477 %files -n monit-rc-nginx
478 %defattr(644,root,root,755)
479 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.786642 seconds and 4 git commands to generate.