]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- logrotate script
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - more bconds (??)
3 # - subpackage with error pages
4 # Conditional build for nginx:
5 %bcond_with     stub_status             # stats module
6 %bcond_with     rtsig
7 %bcond_with     select
8 %bcond_with     poll
9 %bcond_with     ssl                     # ssl support
10 %bcond_with     imap                    # imap proxy
11 %bcond_without  http_browser            # parse header "User-agent"
12 #
13 Summary:        High perfomance HTTP and reverse proxy server
14 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
15 Name:           nginx
16 Version:        0.5.31
17 Release:        3
18 License:        BSD-like
19 Group:          Networking/Daemons
20 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
21 # Source0-md5:  d84ef8e624b8953faf9cee2b5da535c1
22 Source1:        %{name}.init
23 Source2:        %{name}-mime.types.sh
24 Source3:        http://www.nginx.eu/favicon.ico
25 # Source3-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
26 Source4:        http://www.nginx.eu/download/proxy.conf
27 # Source4-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
28 Source5:        http://www.nginx.eu/download/nginx.monitrc
29 # Source5-md5:  1d3f5eedfd34fe95213f9e0fc19daa88
30 Source6:        http://www.nginx.eu/download/nginx.conf
31 # Source6-md5:  1c112d6f03d0f365e4acc98c1d96261a
32 Source7:        %{name}.logrotate
33 Patch0:         %{name}-config.patch
34 URL:            http://nginx.net/
35 BuildRequires:  mailcap
36 BuildRequires:  openssl-devel
37 BuildRequires:  pcre-devel
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 BuildRequires:  zlib-devel
40 Requires(post,preun):   /sbin/chkconfig
41 Requires(postun):       /usr/sbin/groupdel
42 Requires(postun):       /usr/sbin/userdel
43 Requires(pre):  /bin/id
44 Requires(pre):  /usr/bin/getgid
45 Requires(pre):  /usr/sbin/groupadd
46 Requires(pre):  /usr/sbin/useradd
47 Requires:       rc-scripts
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _sysconfdir     /etc/%{name}
51 %define         _nginxdir       /home/services/%{name}
52
53 %description
54 High perfomance HTTP and reverse proxy server.
55 Nginx ("engine x") is a high-performance HTTP server and reverse proxy, 
56 as well as an IMAP/POP3 proxy server. Nginx was written by Igor Sysoev 
57 for Rambler.ru, Russia's second-most visited website, where it has been 
58 running in production for over two and a half years. 
59 Igor has released the source code under a BSD-like license. 
60 Although still in beta, Nginx is known for its stability, rich feature set, 
61 simple configuration, and low resource consumption.
62
63 %description -l pl.UTF-8
64 Serwer HTTP i odwrotne proxy o wysokiej wydajności.
65
66
67 %package -n monit-rc-nginx
68 Summary:        Nginx  support for monit
69 Summary(pl.UTF-8):      Wsparcie nginx dla monit
70 Group:          Applications/System
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       monit
73
74 %description -n monit-rc-nginx
75 monitrc file for monitoring nginx webserver server.
76
77 %description -n monit-rc-nginx -l pl.UTF-8
78 Plik monitrc do monitorowania serwera www nging.
79
80
81 %prep
82 %setup -q
83 %patch0 -p0
84
85 # build mime.types.conf
86 sh %{SOURCE2} /etc/mime.types
87
88 %build
89 # NB: not autoconf generated configure
90 ./configure \
91         --prefix=%{_prefix} \
92         --sbin-path=%{_sbindir}/%{name} \
93         --conf-path=%{_sysconfdir}/%{name}.conf \
94         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
95         --pid-path=%{_localstatedir}/run/%{name}.pid \
96         --user=nginx \
97         --group=nginx \
98         %{?with_stub_status:--with-http_stub_status_module} \
99         %{?with_rtsig:--with-rtsig_module} \
100         %{?with_select:--with-select_module} \
101         %{?with_poll:--with-poll_module} \
102         %{?with_ssl:--with-http_ssl_module} \
103         %{?with_imap:--with-imap} \
104         %{?with_http_browser:--without-http_browser_module} \
105         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
106         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
107         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
108         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
109         --with-cc="%{__cc}" \
110         --with-cc-opt="%{rpmcflags}" \
111         --with-ld-opt="%{rpmldflags}" \
112         %{?debug:--with-debug}
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
119         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
120         $RPM_BUILD_ROOT{%{_localstatedir}/log/{%{name},archive/%{name}},%{_localstatedir}/cache/%{name}} \
121         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
122         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
123
124 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
125 install mime.types $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
127 install %{SOURCE3} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
128 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
129 install %{SOURCE5} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
130 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
131 install %{SOURCE7} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
132
133 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
134
135 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
136 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %pre
142 %groupadd -r -g 213 %{name}
143 %groupadd -g 51 http
144 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
145 %addusertogroup %{name} http
146
147 %post
148 for a in access.log error.log; do
149         if [ ! -f /var/log/%{name}/$a ]; then
150                 touch /var/log/%{name}/$a
151                 chown nginx:nginx /var/log/%{name}/$a
152                 chmod 644 /var/log/%{name}/$a
153         fi
154 done
155 /sbin/chkconfig --add %{name}
156 %service %{name} restart
157
158 %preun
159 if [ "$1" = "0" ]; then
160         %service -q %{name} stop
161         /sbin/chkconfig --del %{name}
162 fi
163
164 %postun
165 if [ "$1" = "0" ]; then
166         %userremove %{name}
167         %groupremove %{name}
168 fi
169
170 %files
171 %defattr(644,root,root,755)
172 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
173 %doc %lang(ru) CHANGES.ru
174 %attr(754,root,root) /etc/rc.d/init.d/%{name}
175 %dir %attr(754,root,root) %{_sysconfdir}
176 %dir %{_nginxdir}
177 %dir %{_nginxdir}/cgi-bin
178 %dir %{_nginxdir}/html
179 %dir %{_nginxdir}/errors
180 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
181 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
182 %attr(640,root,root) %{_sysconfdir}/*[_-]*
183 %attr(640,root,root) %{_sysconfdir}/proxy.conf
184 %attr(640,root,root) %{_sysconfdir}/mime.types
185 %attr(755,root,root) %{_sbindir}/%{name}
186 %attr(770,root,%{name}) /var/cache/%{name}
187 %attr(750,%{name},logs) /var/log/%{name}
188 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
189
190 %files -n monit-rc-nginx
191 %defattr(644,root,root,755)
192 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.042239 seconds and 4 git commands to generate.