]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
fea2612f4be419dbd5c6ddab88793227ca81d154
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - nginx should have own group (and work with it) or use http group ?
5 #
6 # Conditional build for nginx:
7 %bcond_without  light           # don't build light version
8 %bcond_without  mail            # don't build imap/mail proxy
9 %bcond_without  perl            # don't build with perl module
10 %bcond_without  addition        # adds module
11 %bcond_without  dav             # WebDAV
12 %bcond_without  flv             # FLV stream
13 %bcond_without  ipv6            # build without ipv6 support
14 %bcond_without  sub             # ngx_http_sub_module
15 %bcond_without  poll            # poll
16 %bcond_without  realip          # real ip (behind proxy)
17 %bcond_without  rtsig           # rtsig
18 %bcond_without  select          # select
19 %bcond_without  status          # stats module
20 %bcond_without  ssl             # ssl support
21 %bcond_with     http_browser    # header "User-agent" parser
22 #
23 Summary:        High perfomance HTTP and reverse proxy server
24 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
25 Name:           nginx
26 Version:        1.0.5
27 Release:        1
28 License:        BSD-like
29 Group:          Networking/Daemons/HTTP
30 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
31 # Source0-md5:  373c7761a7c682b92b164c8ee3d6d243
32 Source1:        http://www.nginx.eu/favicon.ico
33 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
34 Source2:        http://www.nginx.eu/download/proxy.conf
35 # Source2-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
36 Source3:        %{name}.logrotate
37 Source4:        %{name}.mime
38 Source5:        %{name}-light.conf
39 Source6:        %{name}-light.monitrc
40 Source7:        %{name}-light.init
41 Source8:        %{name}-mail.conf
42 Source9:        %{name}-mail.monitrc
43 Source10:       %{name}-mail.init
44 Source11:       %{name}-perl.conf
45 Source12:       %{name}-perl.monitrc
46 Source13:       %{name}-perl.init
47 Source14:       %{name}-standard.conf
48 Source15:       %{name}-standard.monitrc
49 Source16:       %{name}-standard.init
50 Source17:       %{name}-mime.types.sh
51 Patch0:         %{name}-gcc46-build.patch
52 URL:            http://nginx.net/
53 BuildRequires:  mailcap
54 BuildRequires:  openssl-devel
55 BuildRequires:  pcre-devel
56 %{?with_perl:BuildRequires: perl-CGI}
57 %{?with_perl:BuildRequires: perl-devel}
58 %{?with_perl:BuildRequires: python}
59 %{?with_perl:BuildRequires: rpm-perlprov}
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 BuildRequires:  zlib-devel
62 Requires(post,preun):   /sbin/chkconfig
63 Requires(postun):       /usr/sbin/groupdel
64 Requires(postun):       /usr/sbin/userdel
65 Requires(pre):  /bin/id
66 Requires(pre):  /usr/bin/getgid
67 Requires(pre):  /usr/sbin/groupadd
68 Requires(pre):  /usr/sbin/useradd
69 #Requires:      nginx-daemon
70 Requires:       openssl
71 Requires:       pcre
72 Requires:       rc-scripts >= 0.2.0
73 Requires:       zlib
74 Suggests:       nginx-standard
75 Provides:       group(http)
76 Provides:       group(nginx)
77 Provides:       user(nginx)
78 Provides:       webserver
79 Conflicts:      logrotate < 3.7-4
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _sysconfdir     /etc/%{name}
83 %define         _nginxdir       /home/services/%{name}
84
85 %description
86 nginx ("engine x") is a high-performance HTTP server and reverse
87 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
88 Sysoev for Rambler.ru, Russia's second-most visited website, where it
89 has been running in production for over two and a half years. Igor has
90 released the source code under a BSD-like license. Although still in
91 beta, nginx is known for its stability, rich feature set, simple
92 configuration, and low resource consumption.
93
94 Common files for nginx daemon.
95
96 %description -l pl.UTF-8
97 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
98 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva
99 na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
100 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
101 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
102 w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
103 prostej konfiguracji oraz małej "zasobożerności".
104
105 Niezbędne pliki dla nginx.
106
107 %package light
108 Summary:        High perfomance HTTP and reverse proxy server
109 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
110 Group:          Networking/Daemons/HTTP
111 Requires(post,preun):   /sbin/chkconfig
112 Requires(postun):       /usr/sbin/groupdel
113 Requires(postun):       /usr/sbin/userdel
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       openssl
116 Requires:       pcre
117 Requires:       zlib
118 Provides:       group(http)
119 Provides:       group(nginx)
120 Provides:       nginx-daemon
121 Provides:       user(nginx)
122 Provides:       webserver
123
124 %description light
125 The smallest, but also the fastest nginx edition. No additional
126 modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
127
128 %description light -l pl.UTF-8
129 Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
130 FLV oraz IMAP, POP3, SMTP proxy.
131
132 %package perl
133 Summary:        High perfomance HTTP and reverse proxy server
134 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
135 Group:          Networking/Daemons/HTTP
136 Requires(post,preun):   /sbin/chkconfig
137 Requires(postun):       /usr/sbin/groupdel
138 Requires(postun):       /usr/sbin/userdel
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       openssl
141 Provides:       group(http)
142 Provides:       group(nginx)
143 Provides:       nginx-daemon
144 Provides:       user(nginx)
145 Provides:       webserver
146
147 %description perl
148 nginx with Perl support. Mail modules not included.
149
150 %description perl -l pl.UTF-8
151 nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
152
153 %package mail
154 Summary:        High perfomance IMAP, POP3, SMTP proxy server
155 Summary(pl.UTF-8):      IMAP, POP3, SMTP proxy o wysokiej wydajności
156 Group:          Networking/Daemons/HTTP
157 Requires(post,preun):   /sbin/chkconfig
158 Requires(postun):       /usr/sbin/groupdel
159 Requires(postun):       /usr/sbin/userdel
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       openssl
162 Requires:       pcre
163 Requires:       zlib
164 Provides:       group(http)
165 Provides:       group(nginx)
166 Provides:       nginx-daemon
167 Provides:       user(nginx)
168 Provides:       webserver
169
170 %description mail
171 nginx with mail support. Only mail modules included.
172
173 %description mail -l pl.UTF-8
174 nginx ze wsparciem tylko dla modułów poczty.
175
176 %package standard
177 Summary:        High perfomance HTTP and reverse proxy server
178 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
179 Group:          Networking/Daemons/HTTP
180 Requires(post,preun):   /sbin/chkconfig
181 Requires(postun):       /usr/sbin/groupdel
182 Requires(postun):       /usr/sbin/userdel
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       openssl
185 Provides:       group(http)
186 Provides:       group(nginx)
187 Provides:       nginx-daemon
188 Conflicts:      logrotate < 3.7-4
189
190 %description standard
191 This is standard nginx version, without Perl support and IMAP, POP3,
192 SMTP proxy. 
193
194 %description standard -l pl.UTF-8
195 To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
196 IMAP, POP3, SMTP.
197
198 %package -n monit-rc-nginx
199 Summary:        nginx support for monit
200 Summary(pl.UTF-8):      Wsparcie nginx dla monit
201 Group:          Applications/System
202 URL:            http://nginx.eu/
203 Requires:       %{name} = %{version}-%{release}
204 Requires:       monit
205
206 %description -n monit-rc-nginx
207 monitrc file for monitoring nginx webserver.
208
209 %description -n monit-rc-nginx -l pl.UTF-8
210 Plik monitrc do monitorowania serwera WWW nginx.
211
212 %prep
213 %setup -q
214 %patch0 -p1
215
216 # build mime.types.conf
217 #sh %{SOURCE17} /etc/mime.types
218
219 %build
220 # NB: not autoconf generated configure
221 cp -f configure auto/
222 #
223 %if %{with perl}
224 ./configure \
225         --prefix=%{_prefix} \
226         --sbin-path=%{_sbindir}/%{name}-perl \
227         --conf-path=%{_sysconfdir}/%{name}-perl.conf \
228         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
229         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
230         --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
231         --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
232         --user=nginx \
233         --group=nginx \
234         --with-http_perl_module \
235         --without-mail_pop3_module \
236         --without-mail_imap_module \
237         --without-mail_smtp_module \
238         %{?with_addition:--with-http_addition_module} \
239         %{?with_dav:--with-http_dav_module} \
240         %{?with_flv:--with-http_flv_module} \
241         %{?with_ipv6:--with-ipv6} \
242         %{?with_sub:--with-http_sub_module} \
243         %{?with_poll:--with-poll_module} \
244         %{?with_realip:--with-http_realip_module} \
245         %{?with_rtsig:--with-rtsig_module} \
246         %{?with_select:--with-select_module} \
247         %{?with_status:--with-http_stub_status_module} \
248         %{?with_ssl:--with-http_ssl_module} \
249         %{!?with_http_browser:--without-http_browser_module} \
250         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
251         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
252         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
253         --with-cc="%{__cc}" \
254         --with-cc-opt="%{rpmcflags}" \
255         --with-ld-opt="%{rpmldflags}"
256 %{__make}
257 mv -f objs/nginx contrib/nginx-perl
258 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
259 mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
260 mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
261 %endif
262
263 %if %{with mail}
264 ./configure \
265         --prefix=%{_prefix} \
266         --sbin-path=%{_sbindir}/%{name}-mail \
267         --conf-path=%{_sysconfdir}/%{name}-mail.conf \
268         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
269         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
270         --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
271         --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
272         --user=nginx \
273         --group=nginx \
274         --with-imap \
275         --with-mail \
276         --with-mail_ssl_module \
277         --without-http \
278         %{?with_ipv6:--with-ipv6} \
279         %{?with_poll:--with-poll_module} \
280         %{?with_rtsig:--with-rtsig_module} \
281         %{?with_select:--with-select_module} \
282         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
283         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
284         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
285         --with-cc="%{__cc}" \
286         --with-cc-opt="%{rpmcflags}" \
287         --with-ld-opt="%{rpmldflags}" \
288         %{?debug:--with-debug}
289 %{__make}
290 mv -f objs/nginx contrib/nginx-mail
291 %endif
292
293 %if %{with light}
294 ./configure \
295         --prefix=%{_prefix} \
296         --sbin-path=%{_sbindir}/%{name}-light \
297         --conf-path=%{_sysconfdir}/%{name}-light.conf \
298         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
299         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
300         --pid-path=%{_localstatedir}/run/%{name}-light.pid \
301         --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
302         --user=nginx \
303         --group=nginx \
304         %{?with_ipv6:--with-ipv6} \
305         %{?with_poll:--with-poll_module} \
306         %{?with_realip:--with-http_realip_module} \
307         %{?with_rtsig:--with-rtsig_module} \
308         %{?with_select:--with-select_module} \
309         %{?with_status:--with-http_stub_status_module} \
310         %{?with_ssl:--with-http_ssl_module} \
311         --without-http_browser_module \
312         --without-mail_pop3_module \
313         --without-mail_imap_module \
314         --without-mail_smtp_module \
315         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
316         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
317         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
318         --with-cc="%{__cc}" \
319         --with-cc-opt="%{rpmcflags}" \
320         --with-ld-opt="%{rpmldflags}" \
321         %{?debug:--with-debug}
322 %{__make}
323 mv -f objs/nginx contrib/nginx-light
324 %endif
325
326 ./configure \
327         --prefix=%{_prefix} \
328         --sbin-path=%{_sbindir}/%{name}-standard \
329         --conf-path=%{_sysconfdir}/%{name}-standard.conf \
330         --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
331         --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
332         --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
333         --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
334         --user=nginx \
335         --group=nginx \
336         %{?with_addition:--with-http_addition_module} \
337         %{?with_dav:--with-http_dav_module} \
338         %{?with_flv:--with-http_flv_module} \
339         %{?with_ipv6:--with-ipv6} \
340         %{?with_sub:--with-http_sub_module} \
341         %{?with_poll:--with-poll_module} \
342         %{?with_realip:--with-http_realip_module} \
343         %{?with_rtsig:--with-rtsig_module} \
344         %{?with_select:--with-select_module} \
345         %{?with_status:--with-http_stub_status_module} \
346         %{?with_ssl:--with-http_ssl_module} \
347         %{!?with_http_browser:--without-http_browser_module} \
348         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
349         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
350         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
351         --with-cc="%{__cc}" \
352         --with-cc-opt="%{rpmcflags}" \
353         --with-ld-opt="%{rpmldflags}" \
354         %{?debug:--with-debug}
355 %{__make}
356
357
358 %install
359 rm -rf $RPM_BUILD_ROOT
360 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
361         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
362         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
363         $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
364         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
365         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
366         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
367
368 install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
369 install conf/koi-utf $RPM_BUILD_ROOT%{_sysconfdir}/koi-utf
370 install conf/koi-win $RPM_BUILD_ROOT%{_sysconfdir}/koi-win
371 install conf/win-utf $RPM_BUILD_ROOT%{_sysconfdir}/win-utf
372 install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
373 install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
374 install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
375 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
376 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
377 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
378 install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
379 install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
380 install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
381 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
382
383 %if %{with light}
384 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
385 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
386 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
387 install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
388 %endif
389
390 %if %{with mail}
391 install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
392 install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
393 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
394 install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
395 %endif
396
397 %if %{with perl}
398 install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
399 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
400 install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
401 install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
402 install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
403 install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
404 install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
405 install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
406 %endif
407
408 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
409 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
410
411 %clean
412 rm -rf $RPM_BUILD_ROOT
413
414 %pre
415 %groupadd -r -g 213 %{name}
416 %groupadd -g 51 http
417 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
418 %addusertogroup %{name} http
419
420 %post standard
421 for a in access.log error.log; do
422         if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
423                 umask 022
424                 touch /var/log/%{name}/nginx-standard_$a
425                 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
426                 chmod 644 /var/log/%{name}/nginx-standard_$a
427         fi
428 done
429 /sbin/chkconfig --add %{name}-standard
430 %service %{name}-standard restart
431 echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
432
433 %post light
434 for a in access.log error.log; do
435         if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
436                 umask 022
437                 touch /var/log/%{name}/nginx-light_$a
438                 chown nginx:nginx /var/log/%{name}/nginx-light_$a
439                 chmod 644 /var/log/%{name}/nginx-light_$a
440         fi
441 done
442 /sbin/chkconfig --add %{name}-light
443 %service %{name}-light restart
444 echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" as config'
445
446 %post perl
447 for a in access.log error.log; do
448         if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
449                 umask 022
450                 touch /var/log/%{name}/nginx-perl_$a
451                 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
452                 chmod 644 /var/log/%{name}/nginx-perl_$a
453         fi
454 done
455 /sbin/chkconfig --add %{name}-perl
456 %service %{name}-perl restart
457 echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" as config'
458
459 %post mail
460 for a in access.log error.log; do
461         if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
462                 umask 022
463                 touch /var/log/%{name}/nginx-mail_$a
464                 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
465                 chmod 644 /var/log/%{name}/nginx-mail_$a
466         fi
467 done
468 /sbin/chkconfig --add %{name}-mail
469 %service %{name}-mail restart
470 echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" as config'
471
472 %preun standard
473 if [ "$1" = "0" ];then
474         %service %{name}-standard stop
475         /sbin/chkconfig --del %{name}-standard
476 fi
477
478 %preun light
479 if [ "$1" = "0" ]; then
480         %service %{name}-light stop
481         /sbin/chkconfig --del %{name}-light
482 fi
483
484 %preun perl
485 if [ "$1" = "0" ]; then
486         %service %{name}-perl stop
487         /sbin/chkconfig --del %{name}-perl
488 fi
489
490 %preun mail
491 if [ "$1" = "0" ]; then
492         %service %{name}-mail stop
493         /sbin/chkconfig --del %{name}-mail
494 fi
495
496 %postun
497 if [ "$1" = "0" ]; then
498         %userremove %{name}
499         %groupremove %{name}
500 fi
501
502 %files
503 %defattr(644,root,root,755)
504 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
505 %doc %lang(ru) CHANGES.ru
506 %dir %attr(754,root,root) %{_sysconfdir}
507 %dir %{_nginxdir}
508 %dir %{_nginxdir}/cgi-bin
509 %dir %{_nginxdir}/html
510 %dir %{_nginxdir}/errors
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
512 # XXX: duplicates, don't use such glob here
513 #%attr(640,root,root) %{_sysconfdir}/*[_-]*
514 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
515 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.params
516 %attr(640,root,root) %{_sysconfdir}/mime.types
517 %attr(640,root,root) %{_sysconfdir}/koi-utf
518 %attr(640,root,root) %{_sysconfdir}/koi-win
519 %attr(640,root,root) %{_sysconfdir}/win-utf
520 %attr(750,root,root) %dir /var/log/archive/%{name}
521 %attr(750,%{name},logs) /var/log/%{name}
522 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
523 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
524
525 %files standard
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_sbindir}/%{name}-standard
528 %attr(770,root,%{name}) /var/cache/%{name}-standard
529 %attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
530 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
531
532 %if %{with mail}
533 %files mail
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_sbindir}/%{name}-mail
536 %attr(770,root,%{name}) /var/cache/%{name}-mail
537 %attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
539 %endif
540
541 %if %{with light}
542 %files light
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_sbindir}/%{name}-light
545 %attr(770,root,%{name}) /var/cache/%{name}-light
546 %attr(754,root,root) /etc/rc.d/init.d/%{name}-light
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
548 %endif
549
550 %if %{with perl}
551 %files perl
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_sbindir}/%{name}-perl
554 %attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
555 %attr(770,root,%{name}) /var/cache/%{name}-perl
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
557 %dir %{perl_vendorarch}/auto/%{name}
558 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
559 %{perl_vendorarch}/auto/%{name}/%{name}.bs
560 %{perl_vendorarch}/%{name}.pm
561 %endif
562
563 %files -n monit-rc-nginx
564 %defattr(644,root,root,755)
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
566 %if %{with perl}
567 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
568 %endif
569 %if %{with light}
570 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
571 %endif
572 %if %{with mail}
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
574 %endif
This page took 0.087327 seconds and 3 git commands to generate.