]> git.pld-linux.org Git - packages/nfs-utils.git/blob - nfs-utils.spec
- clean up patches
[packages/nfs-utils.git] / nfs-utils.spec
1 Name:           nfs-utils
2 Version:        0.1.3
3 Release:        1
4 Summary:        Kernel NFS server.
5 Summary(pl):    Dzia³aj±cy na poziomie j±dra serwer NFS.
6 Source0:        ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/%{name}-%{version}.tar.gz
7 Source1:        ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/nfs.doc.tar.gz
8 Source2:        nfs.init
9 Source3:        nfslock.init
10 Source4:        nfs.sysconfig
11 Source5:        nfslock.sysconfig
12 Patch0:         nfs-utils-paths.patch
13 Patch1:         nfs-utils-rquotad.patch
14 #Requires:      kernel >= 2.2.5
15 Requires:       portmap >= 4.0
16 Group:          Networking/Daemons
17 Group(pl):      Sieciowe/Serwery
18 Obsoletes:      nfsdaemon nfs-server knfsd
19 Provides:       nfsdaemon
20 Requires:       rc-scripts
21 Copyright:      GPL
22 #Requires:      /dev/nfsd_netlink
23 BuildRoot:      /tmp/%{name}-%{version}-root
24 ExcludeArch:    armv4l
25
26 %description
27 This is the *new* kernel NFS server and related tools.  It provides a much
28 higher level of performance than the traditional Linux user-land NFS server.
29
30 %description -l pl
31 To jest *nowy* dzia³aj±cy na poziomie j±dra serwer NFS oraz zwi±zane
32 z nim narzêdzia. Serwer ten dostarcza znacznie wiêksz± wydajno¶æ
33 ni¿ tradycyjny, dzia³aj±cy na poziomie urzytkownika serwer NFS.
34
35 %package clients
36 Obsoletes:      nfs-server-clients
37 Provides:       nfs-server-clients
38 Summary:        Clients for connecting to a remote NFS server.
39 Summary(pl):    Klienci do ³±czenia siê ze zdalnym serwerem NFS.
40 Group:          Networking
41 Group(pl):      Sieciowe
42 Obsoletes:      nfsclient nfs-server-clients knfsd-clients
43 Provides:       nfsclient
44
45 %description clients
46 The nfs-server-clients package contains the showmount program.
47 Showmount queries the mount daemon on a remote host for information
48 about the NFS (Network File System) server on the remote host.  For
49 example, showmount can display the clients which are mounted on that
50 host.  This package is not needed to mount NFS volumes.
51
52 %description -l pl clients
53 Pakiet zawiera program showmount s³u¿±cy do odpytywania
54 serwera NFS.
55
56 %package lock
57 Summary:        Programs for NFS file locking.
58 Summary(pl):    Programy do obs³ugi blokowania plików poprzez NFS (lock).
59 #Requires:      kernel >= 2.2.5
60 Requires:       portmap >= 4.0
61 Requires:       %{name} = %{version}
62 Obsoletes:      nfslockd knfsd-lock
63 Provides:       nfslockd
64 Group:          Networking
65 Group(pl):      Sieciowe
66
67 %description lock
68 The nfs-lock pacage contains programs which support the NFS file lock.
69 Install nfs-lock if you want to use file lock over NFS.
70
71 %description -l pl lock
72 Ten pakiet zawiera programy umo¿liwiaj±ce wykonywanie
73 blokowania plików (file locking) poprzez NFS.
74
75 %prep
76 %setup  -q -a1
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 %configure \
82         --with-statedir=/var/state/nfs \
83         --enable-nfsv3 \
84         --enable-secure-statd
85 make all
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_mandir}/man{5,8}}
91 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},%{_var}/state/nfs}
92
93 make install install_prefix="$RPM_BUILD_ROOT"
94
95 install -s tools/rpcdebug/rpcdebug $RPM_BUILD_ROOT/sbin
96 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/nfs
97 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/nfslock
98 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/nfsd
99 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/nfslock
100 touch $RPM_BUILD_ROOT/%{_var}/state/nfs/rmtab
101
102 touch $RPM_BUILD_ROOT/etc/exports
103
104 rm $RPM_BUILD_ROOT%{_mandir}/man8/rpc.{mountd,nfsd,rquotad,statd}.8
105 echo ".so mountd.8"  >  $RPM_BUILD_ROOT%{_mandir}/man8/rpc.mountd.8
106 echo ".so nfsd.8"    >  $RPM_BUILD_ROOT%{_mandir}/man8/rpc.nfsd.8
107 echo ".so rquotad.8" >  $RPM_BUILD_ROOT%{_mandir}/man8/rpc.rquotad.8
108 echo ".so statd.8"   >  $RPM_BUILD_ROOT%{_mandir}/man8/rpc.statd.8
109
110 strip --strip-unneeded $RPM_BUILD_ROOT{/sbin/*,%{_sbindir}/*} || :
111
112 touch $RPM_BUILD_ROOT/var/state/nfs/xtab
113
114 gzip -9nf ChangeLog README nfs/*.ps \
115         $RPM_BUILD_ROOT%{_mandir}/man*/*
116
117 mv -f nfs/*.ps.gz ./
118 mv -f nfs html
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 /sbin/chkconfig --add nfs
125 if [ -r /var/lock/subsys/nfs ]; then
126         /etc/rc.d/init.d/nfs restart >&2
127 else
128         echo "Run \"/etc/rc.d/init.d/nfs start\" to start nfs daemon."
129 fi
130 sed -e 's/NFSDTYPE=.*/NFSDTYPE=K/' /etc/sysconfig/nfsd > /etc/sysconfig/nfsd.new
131 mv -f /etc/sysconfig/nfsd.new /etc/sysconfig/nfsd
132
133 %preun
134 if [ "$1" = "0" ]; then
135         /sbin/chkconfig --del nfs
136         /etc/rc.d/init.d/nfs stop >&2
137 fi
138
139 %post lock
140 /sbin/chkconfig --add nfslock
141 if [ -r /var/lock/subsys/nfslock ]; then
142         /etc/rc.d/init.d/nfslock restart >&2
143 else
144         echo "Run \"/etc/rc.d/init.d/nfs start\" to start nfslock daemon."
145 fi
146
147 %preun lock
148 if [ "$1" = "0" ]; then
149         /sbin/chkconfig --del nfslock
150         /etc/rc.d/init.d/nfslock stop >&2
151 fi
152
153 %files
154 %defattr(644,root,root,755)
155 %doc {ChangeLog,README,*.ps}.gz html
156 %attr(755,root,root) /sbin/rpcdebug
157 %attr(755,root,root) %{_sbindir}/exportfs
158 %attr(755,root,root) %{_sbindir}/rpc.mountd
159 %attr(755,root,root) %{_sbindir}/rpc.nfsd
160 %attr(755,root,root) %{_sbindir}/nfsstat
161 %attr(755,root,root) %{_sbindir}/nhfsstone
162
163 %attr(754,root,root) /etc/rc.d/init.d/nfs
164
165 %attr(755,root,root) %dir %{_var}/state/nfs
166
167 %config(noreplace) %verify(not size mtime md5) /etc/exports
168 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/nfsd
169 %config(noreplace) %verify(not size mtime md5) %{_var}/state/nfs/xtab
170 %config(noreplace) %verify(not size mtime md5) %{_var}/state/nfs/etab
171 %config(noreplace) %verify(not size mtime md5) %{_var}/state/nfs/rmtab
172
173 %{_mandir}/man8/exportfs.8*
174 %{_mandir}/man8/mountd.8*
175 %{_mandir}/man8/nfsd.8*
176 %{_mandir}/man8/nfsstat.8*
177 %{_mandir}/man8/rpc.mountd.8*
178 %{_mandir}/man8/rpc.nfsd.8*
179 %{_mandir}/man8/rpc.rquotad.8*
180 %{_mandir}/man5/exports.5*
181
182 %files lock
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_sbindir}/rpc.lockd
185 %attr(755,root,root) %{_sbindir}/rpc.statd
186 %attr(754,root,root) /etc/rc.d/init.d/nfslock
187 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/nfslock
188
189 %{_mandir}/man8/rpc.statd.8*
190 %{_mandir}/man8/statd.8*
191
192 %files clients
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_sbindir}/showmount
195 %{_mandir}/man8/showmount.8*
This page took 0.054871 seconds and 4 git commands to generate.