]> git.pld-linux.org Git - packages/netdata.git/blob - netdata.spec
correcting license version
[packages/netdata.git] / netdata.spec
1 #
2 # Conditional build:
3 %bcond_without  systemd         # systemd
4 %bcond_with     nfacct          # build with nfacct plugin
5
6 Summary:        Linux real time system monitoring, over the web
7 Name:           netdata
8 Version:        1.0.0
9 Release:        0.2
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        https://github.com/firehol/netdata/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  53a432f8849da6bd49b0853dd79551c5
14 URL:            http://netdata.firehol.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libmnl-devel
18 %{?with_nfacct:BuildRequires:   libnetfilter_acct-devel}
19 BuildRequires:  pkgconfig
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 netdata is the fastest way to visualize metrics. It is a resource
25 efficient, highly optimized system for collecting and visualizing any
26 type of realtime timeseries data, from CPU usage, disk activity, SQL
27 queries, API calls, web site visitors, etc.
28
29 netdata tries to visualize the truth of now, in its greatest detail,
30 so that you can get insights of what is happening now and what just
31 happened, on your systems and applications.
32
33 %prep
34 %setup -q
35
36 %build
37 %{__aclocal} -I m4
38 %{__autoconf}
39 %{__autoheader}
40 %{__automake}
41 %configure \
42         --with-zlib \
43         --with-math \
44         %{__enable_disable nfacct plugin-nfacct} \
45         --with-user=netdata
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %{__rm} $RPM_BUILD_ROOT/var/{cache,log}/netdata/.keep
54
55 install -d $RPM_BUILD_ROOT%{systemdunitdir}
56 cp -p system/netdata-systemd $RPM_BUILD_ROOT%{systemdunitdir}/netdata.service
57
58 %if 0
59 %pre
60 %groupadd -r netdata
61 %useradd -r -g netdata -c netdata -s /sbin/nologin -d / netdata
62
63 %post
64 %systemd_post netdata.service
65
66 %preun
67 %systemd_preun netdata.service
68
69 %postun
70 %systemd_postun_with_restart netdata.service
71 %endif
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %dir %{_sysconfdir}/%{name}
79 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
80 %attr(755,root,root) %{_sbindir}/%{name}
81 %{_datadir}/%{name}
82 %dir %{_libexecdir}/%{name}
83 %{systemdunitdir}/netdata.service
84 %attr(755,netdata,netdata) %dir %{_localstatedir}/cache/%{name}
85 %attr(755,netdata,netdata) %dir %{_localstatedir}/log/%{name}
86
87 %defattr(-,root,root,-)
88 %{_libexecdir}/%{name}/charts.d
89 %{_libexecdir}/%{name}/node.d
90 %{_libexecdir}/%{name}/plugins.d
This page took 0.039728 seconds and 4 git commands to generate.