]> git.pld-linux.org Git - packages/mysql.git/blob - mysql.spec
da6979c9ce6b8694dbdabc8ea1151fc080d14d94
[packages/mysql.git] / mysql.spec
1 Name:           MySQL
2 Summary:        MySQL: a very fast and reliable SQL database engine
3 Summary(pl):    MySQL: bardzo szybki i niezawodna baza danych (SQL)
4 Group:          Applications/Databases
5 Group(pl):      Aplikacje/Bazy danych
6 Summary(pt_BR): MySQL: Um servidor SQL rápido e confiável.
7 Group(pt_BR):   Aplicações/Banco_de_Dados
8 Version:        3.22.22
9 Release:        1
10 Copyright:      MySQL FREE PUBLIC LICENSE (See the file PUBLIC)
11 Source:         http://www.mysql.com/Downloads/MySQL-3.22/mysql-%{version}.tar.gz
12 Patch:          mysql-optimization.patch
13 Icon:           mysql.gif
14 URL:            http://www.mysql.com/
15 Provides:       msqlormysql MySQL-server
16 Obsoletes:      mysql
17 BuildRoot:      /tmp/%{name}-%{version}
18
19 %description
20 MySQL is a true multi-user, multi-threaded SQL (Structured Query
21 Language) database server. SQL is the most popular database language
22 in the world. MySQL is a client/server implementation that consists of
23 a server daemon mysqld and many different client programs/libraries.
24
25 The main goals of MySQL are speed, robustness and easy to use.  MySQL
26 was originally developed because we at Tcx needed a SQL server that
27 could handle very big databases with magnitude higher speed than what
28 any database vendor could offer to us. We have now been using MySQL
29 since 1996 in a environment with more than 40 databases, 10,000
30 tables, of which more than 500 have more than 7 million rows. This is
31 about 50G of mission critical data.
32
33 The base upon which MySQL is built is a set of routines that have been
34 used in a highly demanding production environment for many
35 years. While MySQL is still in development, it already offers a rich
36 and highly useful function set.
37
38 %description -l pl
39 MySQL to wielow±tkowy serwer baz danych SQL.
40
41 G³ówne zalety MySQL to szybko¶æ, potêga i ³atwo¶æ u¿ytkowania. MySQL
42 jes wykorzystywany m.in. do obs³ugi 40 baz danych, 10 000 tabeli,
43 gdzie ka¿da tabela zawiera 7 milionów pozycji. To ok 50GB danych.
44
45 %description -l pt_BR
46 O MySQL é um servidor de banco de dados SQL realmente multiusuário e\
47 multi-tarefa. A linguagem SQL é a mais popular linguagem para banco de\
48 dados no mundo. O MySQL é uma implementação cliente/servidor que\
49 consiste de um servidor chamado mysqld e diversos\
50 programas/bibliotecas clientes. Os principais objetivos do MySQL são:\
51 velocidade, robustez e facilidade de uso.  O MySQL foi originalmente\
52 desenvolvido porque nós na Tcx precisávamos de um servidor SQL que\
53 pudesse lidar com grandes bases de dados e com uma velocidade muito\
54 maior do que a que qualquer vendedor podia nos oferecer. Estamos\
55 usando\
56 o MySQL desde 1996 em um ambiente com mais de 40 bases de dados com 10.000\
57 tabelas, das quais mais de 500 têm mais de 7 milhões de linhas. Isto é o\
58 equivalente a aproximadamente 50G de dados críticos. A base da construção do\
59 MySQL é uma série de rotinas que foram usadas em um ambiente de produção com\
60 alta demanda por muitos anos. Mesmo o MySQL estando ainda em desenvolvimento,\
61 ele já oferece um conjunto de funções muito ricas e úteis. Veja a documentação\
62 para maiores informações.
63
64 %package client
65 Requires:       %{name} = %{version}-%{release}
66 Summary:        MySQL - Client
67 Summary(pl):    MySQL - Klient
68 Group:          Applications/Databases
69 Group(pl):      Aplikacje/Bazy danych
70 Summary(pt_BR): MySQL - Cliente
71 Group(pt_BR):   Aplicações/Banco_de_Dados
72 Obsoletes:      mysql-client
73
74 %description client
75 This package contains the standard MySQL clients. 
76
77 %description client -l pl
78 Standardowe programy klienckie MySQL.
79
80 %description client -l pt_BR
81 Este pacote contém os clientes padrão para o MySQL.
82
83 %package bench
84 Requires:       MySQL-client
85 Requires:       MySQL-DBI-perl-bin
86 Requires:       perl
87 Summary:        MySQL - Benchmarks
88 Summary:        mySQL - Programy testuj±ce szybko¶æ dzia³ania bazy
89 Group:          Applications/Databases
90 Group(pl):      Aplikacje/Bazy danych
91 Summary(pt_BR): MySQL - Medições de desempenho
92 Group(pt_BR):   Aplicações/Banco_de_Dados
93 Obsoletes:      mysql-bench
94
95 %description bench
96 This package contains MySQL benchmark scripts and data.
97
98 %description -l pl
99 Programy testuj±ce szybko¶æ serwera MySQL.
100
101 %description bench -l pt_BR
102 Este pacote contém medições de desempenho de scripts e dados do MySQL.
103
104 %package devel
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       MySQL-client
107 Summary:        MySQL - Development header files and libraries
108 Summary(pl):    MySQL - Pliki nag³ówkowe i biblioteki dla developerów
109 Group:          Applications/Databases
110 Group(pl):      Aplikacje/Bazy danych
111 Summary(pt_BR): MySQL - Medições de desempenho
112 Group(pt_BR):   Aplicações/Banco_de_Dados
113 Obsoletes:      mysql-devel
114
115 %description devel
116 This package contains the development header files and libraries
117 necessary to develop MySQL client applications.
118
119 %description -l pl
120 Pliki nag³ówkowe i biblioteki konieczne do rozwijania aplikacji
121 klienckich MySQL.
122
123 %description devel -l pt_BR
124 Este pacote contém os arquivos de cabeçalho (header files) e bibliotecas 
125 necessárias para desenvolver aplicações clientes do MySQL. 
126
127 %prep
128 %setup -q -n mysql-%{version}
129 %patch -p1
130
131 %build
132 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
133 ./configure \
134             --without-debug \
135             --enable-shared \
136             --enable-static \
137             --with-pthread \
138             --enable-thread-safe-client \
139             --enable-assembler \
140             --with-charset=latin2 \
141             --with-mysqld-user=mysql \
142             --with-unix-socket-path=/var/state/mysql/mysql.sock \
143             --prefix=/ \
144             --exec-prefix=%{_exec_prefix} \
145             --libexecdir=%{_sbindir} \
146             --sysconfdir=%{_sysconfdir} \
147             --datadir=%{_datadir} \
148             --localstatedir=/var/state/mysql \
149             --infodir=%{_infodir} \
150             --includedir=%{_includedir} \
151             --mandir=%{_mandir} \
152             --with-comment='Polish Linux Distribution MySQL RPM' \
153             --without-readline \
154             --with-low-memory
155 # If you have much RAM you can remove --with-low-memory
156
157 make benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
158
159
160 %install
161 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{logrotate.d,rc.d/init.d}
162 install -d $RPM_BUILD_ROOT/var/state/mysql/{mysql,test}
163 install -d $RPM_BUILD_ROOT%{_datadir}/sql-bench
164 install -d $RPM_BUILD_ROOT%{_sbindir}
165 install -d $RPM_BUILD_ROOT%{_mandir}
166 install -d $RPM_BUILD_ROOT%{_includedir}
167
168 # Make install
169 make install-strip DESTDIR=$RPM_BUILD_ROOT benchdir=%{_datadir}/sql-bench
170
171 # Install logrotate and autostart
172 install -m644 support-files/mysql-log-rotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/mysql
173 install -m755 support-files/mysql.server     $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/mysql
174
175 find Docs -type f ! -name *.gif ! -name *.html -exec rm {} \;
176 find . -name ./CVS -exec rm -rf {} \;
177
178 mv $RPM_BUILD_ROOT%{_libdir}/mysql/*.so* $RPM_BUILD_ROOT%{_libdir}
179
180 strip $RPM_BUILD_ROOT%{_bindir}/*  || true
181 strip $RPM_BUILD_ROOT%{_sbindir}/* || true
182 strip $RPM_BUILD_ROOT%{_libdir}/*.so* || true
183
184 %pre
185 echo "Creating system group mysql with GID 83"
186 %{_sbindir}/groupadd -f -g 83 mysql
187 echo "Creating system user mysql with UID 83"
188 %{_sbindir}/useradd -u 83 -g mysql -d /var/state/mysql -s /bin/sh mysql 2> /dev/null
189
190 %post
191 /sbin/chkconfig --add mysql
192 mysql_install_db -IN-RPM
193 chown -R mysql /var/state/mysql
194
195 %postun
196 # We do not remove the mysql user since it may still own a lot of
197 # database files.
198
199 %files
200 %defattr(644,root,root,755)
201 %doc Docs
202 %attr(755,root,root) %{_bindir}/isamchk
203 %attr(755,root,root) %{_bindir}/isamlog
204 %attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
205 %attr(755,root,root) %{_bindir}/mysql_install_db
206 %attr(755,root,root) %{_bindir}/mysql_setpermission
207 %attr(755,root,root) %{_bindir}/mysql_zap
208 %attr(755,root,root) %{_bindir}/mysqlbug
209 %attr(755,root,root) %{_bindir}/perror
210 %attr(755,root,root) %{_bindir}/replace
211 %attr(755,root,root) %{_bindir}/resolveip
212 %attr(755,root,root) %{_bindir}/safe_mysqld
213 %attr(644,root,root) %{_infodir}/mysql.info
214 %attr(755,root,root) %{_sbindir}/mysqld
215 %attr(644,root,root) %{_sysconfdir}/logrotate.d/mysql
216 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/mysql
217 %attr(755,root,root) %{_libdir}/mysql/
218
219 %files client
220 %attr(755,root,root) %{_bindir}/msql2mysql
221 %attr(755,root,root) %{_bindir}/mysql
222 %attr(755,root,root) %{_bindir}/mysqlaccess
223 %attr(755,root,root) %{_bindir}/mysqladmin
224 %attr(755,root,root) %{_bindir}/mysqlbug
225 %attr(755,root,root) %{_bindir}/mysqldump
226 %attr(755,root,root) %{_bindir}/mysqlimport
227 %attr(755,root,root) %{_bindir}/mysqlshow
228 %attr(755,root,root) %{_libdir}/*.so*
229 %attr(644,root,root) %{_mandir}/man1/mysql.1
230
231 %post client
232 /sbin/ldconfig
233
234 %postun client
235 /sbin/ldconfig
236
237 %files devel
238 %attr(755,root,root) %{_bindir}/comp_err
239 %attr(755,root,root) %{_includedir}/mysql/
240 %attr(755,root,root) %{_libdir}/mysql/
241
242 %files bench
243 %attr(-,root,root) %{_datadir}/sql-bench
244
245 %changelog
246 * Mon May 31 1999 Arkadiusz Mi¶kiewicz <misiek@pld.org.pl>
247 - PLDized (spec rewrited)
248
249 * Mon Feb 22 1999 David Axmark <david@detron.se>
250 - Removed unportable cc switches from the spec file. The defaults can
251   now be overridden with environment variables. This feature is used
252   to compile the official RPM with optimal (but compiler version
253   specific) switches.
254 - Removed the repetitive description parts for the sub rpms. Maybe add
255   again if RPM gets a multiline macro capability.
256 - Added support for a pt_BR translation. Translation contributed by
257   Jorge Godoy <jorge@bestway.com.br>.
258
259 * Wed Nov 4 1998 David Axmark <david@detron.se>
260 - A lot of changes in all the rpm and install scripts. This may even
261   be a working RPM :-)
262
263 * Sun Aug 16 1998 David Axmark <david@detron.se>
264 - A developers changelog for MySQL is available in the source RPM. And
265   there is a history of major user visible changed in the Reference
266   Manual.  Only RPM specific changes will be documented here.
This page took 0.034656 seconds and 2 git commands to generate.