]> git.pld-linux.org Git - SPECS.git/blob - mujs.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / mujs.spec
1 Summary:        MuJS - lightweight, embeddable JavaScript interpreter in C
2 Summary(pl.UTF-8):      MuJS - lekki, osadzalny interpreter JavaScriptu napisany w C
3 Name:           mujs
4 Version:        1.1.3
5 Release:        1
6 License:        ISC
7 Group:          Development/Languages
8 Source0:        https://www.mujs.com/downloads/%{name}-%{version}.tar.xz
9 # Source0-md5:  509fe19edc13f2173f1d05e1a922c237
10 Patch0:         %{name}-shared.patch
11 URL:            http://www.mujs.com/
12 BuildRequires:  tar >= 1:1.22
13 BuildRequires:  xz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 MuJS is a lightweight JavaScript interpreter designed for embedding in
18 other software to extend them with scripting capabilities.
19
20 %description -l pl.UTF-8
21 MuJS to lekki interpreter JavaScriptu zaprojektowany do osadzania w
22 innych programach w celu rozszerzenia ich o obsługę skryptów.
23
24 %package devel
25 Summary:        Header files for MuJS library
26 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MuJS
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 Header files for MuJS library.
32
33 %description devel -l pl.UTF-8
34 Pliki nagłówkowe biblioteki MuJS.
35
36 %package static
37 Summary:        Static MuJS library
38 Summary(pl.UTF-8):      Statyczna biblioteka MuJS
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}-%{release}
41
42 %description static
43 Static MuJS library.
44
45 %description static -l pl.UTF-8
46 Statyczna biblioteka MuJS.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %build
53 %{__make} \
54         CC="%{__cc}" \
55         CFLAGS="%{rpmcflags} %{rpmcppflags} -std=c99 -Wall -Wextra -Wno-unused-parameter -Wunreachable-code" \
56         LDFLAGS="%{rpmldflags}" \
57         libdir=%{_libdir}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         prefix=%{_prefix} \
65         libdir=%{_libdir}
66
67 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmujs.la
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS COPYING README
78 %attr(755,root,root) %{_bindir}/mujs
79 %attr(755,root,root) %{_libdir}/libmujs.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libmujs.so.0
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc docs/*.{css,html,png,ps}
85 %attr(755,root,root) %{_libdir}/libmujs.so
86 %{_includedir}/mujs.h
87 %{_pkgconfigdir}/mujs.pc
88
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/libmujs.a
This page took 0.129244 seconds and 3 git commands to generate.