]> git.pld-linux.org Git - SPECS.git/blob - mstflint.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / mstflint.spec
1 Summary:        Firmware burning and diagnostic tools for Mellanox HCA/NIC cards
2 Summary(pl.UTF-8):      Narzędzia modyfikujące firmware i diagnostyczne dla kart HCA/NIC Mellanox
3 Name:           mstflint
4 Version:        4.10.0
5 %define upstream_ver    %{version}-3
6 Release:        3
7 License:        BSD or GPL v2
8 Group:          Networking/Utilities
9 Source0:        https://github.com/Mellanox/mstflint/releases/download/v%{upstream_ver}/%{name}-%{upstream_ver}.tar.gz
10 # Source0-md5:  0fd75b78de3fc46d2cf951eead225a5b
11 Patch0:         openssl-1.1.patch
12 Patch1:         x32.patch
13 Patch2:         gcc11.patch
14 URL:            https://github.com/Mellanox/mstflint
15 BuildRequires:  libibmad-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  zlib-devel
19 # see common/compatibility.h
20 ExclusiveArch:  %{ix86} %{x8664} x32 aarch64 ia64 ppc ppc64
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Firmware burning and diagnostic tools for Mellanox HCA/NIC cards.
25
26 %description -l pl.UTF-8
27 Narzędzia modyfikujące firmware i diagnostyczne dla kart HCA/NIC
28 Mellanox.
29
30 %package devel
31 Summary:        Header files for Mellanox HCA/NIC cards access
32 Summary(pl.UTF-8):      Pliki nagłówkowe do dostępu do kart HCA/NIC Mellanox
33 Group:          Development/Libraries
34 # doesn't require base
35
36 %description devel
37 Header files for Mellanox HCA/NIC cards access.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe do dostępu do kart HCA/NIC Mellanox.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47
48 %build
49 %{__libtoolize}
50 %{__aclocal} -I m4
51 %{__automake}
52 %{__autoconf}
53 %configure \
54         --enable-cs \
55         --enable-fw-mgr \
56         --enable-xml2 \
57         --enable-openssl
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -j1 install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc LICENSE README
72 %dir %{_sysconfdir}/mstflint
73 %{_sysconfdir}/mstflint/ca-bundle.crt
74 %attr(755,root,root) %{_bindir}/mstconfig
75 %attr(755,root,root) %{_bindir}/mstflint
76 %attr(755,root,root) %{_bindir}/mstmcra
77 %attr(755,root,root) %{_bindir}/mstmread
78 %attr(755,root,root) %{_bindir}/mstmtserver
79 %attr(755,root,root) %{_bindir}/mstmwrite
80 %attr(755,root,root) %{_bindir}/mstregdump
81 %attr(755,root,root) %{_bindir}/mstvpd
82 %attr(755,root,root) %{_bindir}/mstcongestion
83 %attr(755,root,root) %{_bindir}/mstfwmanager
84 %attr(755,root,root) %{_bindir}/mstfwreset
85 %dir %{_libdir}/mstflint
86 %dir %{_libdir}/mstflint/python_tools
87 %attr(755,root,root) %{_libdir}/mstflint/python_tools/c_dev_mgt.so
88 %attr(755,root,root) %{_libdir}/mstflint/python_tools/ccmdif.so
89 %{_libdir}/mstflint/python_tools/cmdif.py
90 %attr(755,root,root) %{_libdir}/mstflint/python_tools/cmtcr.so
91 %{_libdir}/mstflint/python_tools/dev_mgt.py
92 %dir %{_libdir}/mstflint/python_tools/mstfwreset
93 %dir %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib
94 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/__init__.py
95 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/logger.py
96 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/mcra.py
97 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/mlnx_peripheral_components.py
98 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/mlxfwreset_mlnxdriver.py
99 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/mlxfwreset_status_checker.py
100 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/mlxfwreset_utils.py
101 %{_libdir}/mstflint/python_tools/mstfwreset/mlxfwresetlib/pci_device.py
102 %{_libdir}/mstflint/python_tools/mstfwreset/mstfwreset.py
103 %{_libdir}/mstflint/python_tools/mtcr.py
104 %{_libdir}/mstflint/python_tools/regaccess.py
105 %attr(755,root,root) %{_libdir}/mstflint/python_tools/rreg_access.so
106 %{_libdir}/mstflint/python_tools/tools_version.py
107 %{_datadir}/mstflint
108 %{_mandir}/man1/mstconfig.1*
109 %{_mandir}/man1/mstflint.1*
110 %{_mandir}/man1/mstmcra.1*
111 %{_mandir}/man1/mstmread.1*
112 %{_mandir}/man1/mstmtserver.1*
113 %{_mandir}/man1/mstmwrite.1*
114 %{_mandir}/man1/mstregdump.1*
115 %{_mandir}/man1/mstvpd.1*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %{_libdir}/mstflint/libmtcr_ul.a
120 %{_includedir}/mstflint
This page took 0.32433 seconds and 3 git commands to generate.