]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- runtime cpu detection not supported on sparcs
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_with     osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dshow           # disable DirectShow support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio              # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_with     ssse3   # sse3 optimizations (needs binutils >= 2.16.92)
59
60 %ifnarch %{ix86}
61 %undefine       with_win32
62 %undefine       with_quicktime
63 %undefine       with_vidix
64 %endif
65
66 %ifarch %{x8664} sparc sparc64
67 %undefine       with_runtime
68 %endif
69
70 %if %{_lib} == "lib64"
71 %define        _suf    64
72 %else
73 %define        _suf    32
74 %endif
75
76 %define         _rel    0.4
77 %define         _rc     rc2
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es.UTF-8):      Otro reproductor de películas
82 Summary(ko.UTF-8):      리눅스용 미디어플레이어
83 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR.UTF-8):   Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 Release:        5.%{_rc}.%{_rel}
88 # DO NOT increase epoch unless it's really neccessary!
89 # especially such changes like pre7->pre7try2, increase Release instead!
90 # PS: $ rpmvercmp pre7try2 pre7
91 # pre7try2 > pre7
92 Epoch:          3
93 License:        GPL
94 Group:          Applications/Multimedia
95 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{_rc}.tar.bz2
96 # Source0-md5:  7e27e535c2d267637df34898f1b91707
97 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
99 Source5:        g%{name}.desktop
100 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
102 Source7:        %{name}.png
103 Source8:        %{name}.desktop
104 # http://www.on2.com/gpl/mplayer/
105 Source9:        http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106 # Source9-md5:  2361e56b40f52dfc20131e458e2aed38
107 Patch1:         %{name}-cp1250-fontdesc.patch
108 Patch2:         %{name}-codec.patch
109 Patch3:         %{name}-home_etc.patch
110 Patch4:         %{name}-350.patch
111 Patch5:         %{name}-configure.patch
112 #Patch6:                %{name}-system-amr.patch # outdated via ffmpeg?
113 Patch8:         %{name}-altivec.patch
114 Patch10:        %{name}-pcmsplit.patch
115 Patch13:        %{name}-mythtv.patch
116 Patch14:        %{name}-shared.patch
117 #http://www.openchrome.org/snapshots/mplayer/
118 Patch15:        %{name}-xvmc.patch
119 Patch17:        %{name}-auto-expand.patch
120 #Patch18:       %{name}-gnome-screensaver.patch # update
121 Patch19:        %{name}-on2flix.patch
122 Patch22:        %{name}-ffmpeg.patch
123 Patch23:        %{name}-live.patch
124 Patch24:        %{name}-fontconfig_sub.patch
125 URL:            http://www.mplayerhq.hu/
126 %{?with_directfb:BuildRequires: DirectFB-devel}
127 BuildRequires:  OpenAL-devel
128 BuildRequires:  OpenGL-devel
129 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
130 %{?with_aalib:BuildRequires:    aalib-devel}
131 %{?with_alsa:BuildRequires:     alsa-lib-devel}
132 %if %{with amr}
133 BuildRequires:  amrnb-devel
134 BuildRequires:  amrwb-devel >= 5.3.0
135 %endif
136 %{?with_arts:BuildRequires:     artsc-devel}
137 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
138 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
139 %{?with_doc:BuildRequires:      docbook-style-xsl}
140 %{?with_dxr3:BuildRequires:     em8300-devel}
141 %{?with_enca:BuildRequires:     enca-devel}
142 %{?with_esd:BuildRequires:      esound-devel}
143 BuildRequires:  faac-devel
144 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
145 BuildRequires:  ffmpeg-devel >= 0.4.9-3.20070626.1.1
146 BuildRequires:  freetype-devel
147 BuildRequires:  fribidi-devel
148 %{?with_vidix:BuildRequires:    vidix-devel}
149 %ifarch ppc
150 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
151 %endif
152 %{?with_gif:BuildRequires:      giflib-devel}
153 %if %{with gui}
154 BuildRequires:  gtk+2-devel
155 %endif
156 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
157 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
158 BuildRequires:  lame-libs-devel
159 %{?with_caca:BuildRequires:     libcaca-devel}
160 %{?with_libdts:BuildRequires:   libdts-devel}
161 %{?with_libdv:BuildRequires:    libdv-devel}
162 BuildRequires:  libdvdnav-devel
163 %{?with_ggi:BuildRequires:      libggi-devel}
164 BuildRequires:  libjpeg-devel
165 %{?with_mad:BuildRequires:      libmad-devel}
166 BuildRequires:  libmpcdec-devel >= 1.2.1
167 BuildRequires:  libpng-devel
168 %{?with_smb:BuildRequires:      libsmbclient-devel}
169 %{?with_dshow:BuildRequires:    libstdc++-devel}
170 %{?with_theora:BuildRequires:   libtheora-devel}
171 # tremor is used by default, internal as we don't have system one
172 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
173 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
174 BuildRequires:  libxslt-progs
175 %{?with_lirc:BuildRequires:     lirc-devel}
176 %{?with_live:BuildRequires:     live}
177 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
178 %{?with_nas:BuildRequires:      nas-devel}
179 BuildRequires:  ncurses-devel
180 BuildRequires:  pkgconfig
181 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
182 BuildRequires:  speex-devel >= 1.1
183 %{?with_svga:BuildRequires:     svgalib-devel}
184 %{?with_xmms:BuildRequires:     xmms-libs}
185 BuildRequires:  xorg-lib-libX11-devel
186 BuildRequires:  xorg-lib-libXext-devel
187 BuildRequires:  xorg-lib-libXinerama-devel
188 BuildRequires:  xorg-lib-libXv-devel
189 BuildRequires:  xorg-lib-libXvMC-devel
190 BuildRequires:  xorg-lib-libXxf86dga-devel
191 BuildRequires:  xorg-lib-libXxf86vm-devel
192 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
193 BuildRequires:  zlib-devel
194 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
195 Requires:       OpenGL
196 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
197
198 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
199 %define         specflags_ia32  -fomit-frame-pointer
200 %if %{with altivec}
201 %define         specflags_ppc   -maltivec
202 %endif
203
204 %description
205 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
206 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
207 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
208 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
209 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
210 optionally with SHM extension, X11 using overlays with the Xvideo
211 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
212 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
213
214 If you want to use win32 codecs install w32codec package.
215
216 %description -l de.UTF-8
217 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
218 Kennzeichnend ist die herausragende Format- und
219 Plattform-Kompatibilität.
220
221 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
222 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
223 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
224 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
225 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
226 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
227 installierte Codecs nicht mit MPlayer kollidieren können.
228
229 %description -l es.UTF-8
230 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
231 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
232 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
233 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
234 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
235 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
236 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
237 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
238 v1.1.7 etc.
239
240 Si quiere usar codecs Win32, instale el paquete w32codec.
241
242 %description -l ko.UTF-8
243 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
244 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
245 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
246 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
247 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
248 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
249 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
250 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
251 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
252
253 %description -l pl.UTF-8
254 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
255 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
256 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
257 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
258 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
259 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
260 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
261
262 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
263
264 %description -l pt_BR.UTF-8
265 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
266 áudio. Diferentes mecanismos de reprodução podem também ser
267 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
268
269 %package -n gmplayer
270 Summary:        MPlayer with GTK+ GUI interface
271 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
272 Group:          X11/Applications/Multimedia
273 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
274 Requires:       %{name}-skin
275 Provides:       %{name} = %{epoch}:%{version}-%{release}
276
277 %description -n gmplayer
278 MPlayer with GUI GTK+ interface.
279
280 %description -n gmplayer -l pl.UTF-8
281 MPlayer z graficznym interfejsem GTK+.
282
283 %package common
284 Summary:        Configuration files and documentation for MPlayer
285 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
286 Group:          Applications/Multimedia
287 Obsoletes:      mplayer-vidix
288
289 %description common
290 Configuration files, man page and HTML documentation for MPlayer.
291
292 %description common -l pl.UTF-8
293 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
294
295 %package -n mencoder
296 Summary:        MEncoder - a movie encoder for Linux
297 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
298 Group:          Applications/Multimedia
299 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
300
301 %description -n mencoder
302 MEncoder is a movie encoder for Linux and is a part of the MPlayer
303 package.
304
305 %description -n mencoder -l pl.UTF-8
306 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
307
308 %prep
309 %setup -q -n MPlayer-%{version}%{_rc} -a3 -a6 -a9
310 cp -f etc/codecs.conf etc/codecs.win32.conf
311 %patch1 -p0
312 ##%patch2 -p1
313 ##%patch3 -p1   -- old home_etc behavior
314 %patch4 -p1
315 %patch5 -p1
316 #%patch6 -p1 # - try ffmpeg
317 %patch8 -p1
318 #%%patch10 -p1
319 #%patch13 -p1   # TODO
320 %if %{with shared}
321 %patch14 -p1
322 %endif
323 #%patch15 -p0   # TODO
324 %patch17 -p1
325 %if %{with gnomess}
326 #%patch18 -p1
327 %endif
328
329 # on2flix
330 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
331 rm -f mencoder-on2flixenglinux/version.diff
332 %patch19 -p1
333 for a in mencoder-on2flixenglinux/*.diff; do
334         patch -p0 < $a
335 done
336
337 %patch22 -p1
338 %patch23 -p1
339 %patch24 -p0
340
341 %build
342 %if %{with shared}
343 CFLAGS="%{rpmcflags} -fPIC"
344 %else
345 CFLAGS="%{rpmcflags}"
346 %endif
347 CC="%{__cc}"
348 LDFLAGS="%{rpmldflags}"
349 export CC CFLAGS LDFLAGS
350
351 build() {
352 set -x
353         ./configure \
354         %{?debug:--enable-debug=3} \
355         --prefix=%{_prefix} \
356         --confdir=%{_sysconfdir}/mplayer \
357         --with-extraincdir=%{_includedir}/xvid \
358         --with-extralibdir=%{_x_libraries} \
359         --enable-menu \
360         --disable-libavutil_a \
361         --disable-libavcodec_a \
362         --disable-libavformat_a \
363         --disable-libpostproc_a \
364         --enable-libavutil_so \
365         --enable-libavcodec_so \
366         --enable-libavformat_so \
367         --enable-libpostproc_so \
368 %ifnarch %{ix86} %{x8664}
369         --disable-mmx \
370         --disable-mmxext \
371         --disable-3dnow \
372         --disable-3dnowext \
373         --disable-sse \
374         --disable-sse2 \
375         --disable-fastmemcpy \
376 %endif
377         %{!?with_ssse3:--disable-ssse3} \
378 %ifarch ppc
379 %{!?with_altivec:--disable-altivec} \
380 %endif
381 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
382 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
383 %{?with_directfb:--enable-directfb} \
384 %{!?with_directfb:--disable-directfb} \
385 %{!?with_dxr3:--disable-dxr3} \
386 %{!?with_ggi:--disable-ggi} \
387 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
388 %{!?with_live:--disable-live} \
389 %{!?with_lzo:--disable-liblzo} \
390 %{!?with_nas:--disable-nas} \
391 %{!?with_svga:--disable-svga} \
392 %{!?with_aalib:--disable-aa} \
393 %{!?with_jack:--disable-jack} \
394 %{!?with_alsa:--disable-alsa} \
395 %{?with_alsa:--enable-alsa --disable-select} \
396 %{!?with_arts:--disable-arts} \
397 %{!?with_caca:--disable-caca} \
398 %{!?with_cdparanoia:--disable-cdparanoia} \
399 %{!?with_dshow:--disable-dshow} \
400 %{!?with_enca:--disable-enca} \
401 %{!?with_esd:--disable-esd} \
402 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
403 %{?with_faad:--disable-faad-internal} \
404 %{!?with_gif:--disable-gif} \
405 %{?with_joystick:--enable-joystick} \
406 %{!?with_libdv:--disable-libdv} \
407 %{!?with_libdts:--disable-libdts} \
408 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
409 %{!?with_mad:--disable-mad} \
410 %{!?with_pulseaudio:--disable-pulse} \
411 %{!?with_quicktime:--disable-qtx} \
412 %{!?with_real:--disable-real} \
413 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
414 %{!?with_select:--disable-select} \
415 %{!?with_smb:--disable-smb} \
416 %{!?with_win32:--disable-win32dll} \
417 %{!?with_vorbis:--disable-vorbis} \
418 %{?with_osd:--enable-menu} \
419 %{!?with_theora:--disable-theora} \
420 %{!?with_x264:--disable-x264} \
421 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
422 %{!?with_xvid:--disable-xvid} \
423 %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
424 %{?with_vidix:--disable-vidix-internal} \
425 %{!?with_mencoder:--disable-mencoder} \
426         --enable-dga1 \
427         --enable-dga2 \
428         --enable-fbdev \
429         --enable-gl \
430         --enable-mga \
431         --enable-radio \
432         --enable-radio-capture \
433         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
434         --enable-tdfxfb \
435         --enable-vm \
436         --enable-x11 \
437         --enable-xmga \
438         --enable-xv \
439         --enable-xvmc \
440         --enable-dynamic-plugins \
441         --enable-largefiles \
442         --language=all \
443         --codecsdir=%{_libdir}/codecs \
444         --with-xvmclib=XvMCW \
445         "$@"
446
447         %{__make}
448 }
449
450 %if %{with gui}
451 # build GUI version
452 build --enable-gui --disable-mencoder
453 mv -f mplayer gmplayer
454 %{__make} distclean
455 %endif
456
457 # now build regular version
458 build --disable-gui
459
460 %if %{with doc}
461 %{__make} -j1 -C DOCS/xml
462 %endif
463
464 %install
465 rm -rf $RPM_BUILD_ROOT
466 install -d \
467         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
468         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
469         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
470         $RPM_BUILD_ROOT%{_desktopdir}
471
472 # default config files
473 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
474 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
475
476 # executables
477 %if %{with mencoder}
478 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
479 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
480 %endif
481 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
482 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
483 %if %{with gui}
484 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
485 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
486 %endif
487
488 # fonts
489 rm -f font-*/runme
490 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
491 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
492
493 %if %{with gui}
494 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
495 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
496 %endif
497 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
498 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
499
500 # man pages
501 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
502 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
503 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
504 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
505 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
506 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
507 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
508 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
509 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
510 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515 %post -n gmplayer
516 umask 022
517 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
518
519 %postun -n gmplayer
520 umask 022
521 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
522
523 %files
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_bindir}/mplayer*
526
527 %if %{with gui}
528 %files -n gmplayer
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_bindir}/gmplayer*
531 %{_desktopdir}/gmplayer.desktop
532 %dir %{_datadir}/%{name}/skins
533 %ghost %{_datadir}/%{name}/skins/default
534 %endif
535
536 %if %{with mencoder}
537 %files -n mencoder
538 %defattr(644,root,root,755)
539 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
540 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
541 %doc DOCS/tech/colorspaces.txt
542 %attr(755,root,root) %{_bindir}/mencoder*
543 %endif
544
545 %files common
546 %defattr(644,root,root,755)
547 %doc DOCS/tech
548 %if %{with win32}
549 %doc etc/codecs.win32.conf
550 %endif
551 %if %{with doc}
552 # HTML and XML-generated docs
553 %doc DOCS/HTML/en
554 %lang(cs) %doc DOCS/HTML/cs
555 %lang(de) %doc DOCS/HTML/de
556 %lang(es) %doc DOCS/HTML/es
557 %lang(fr) %doc DOCS/HTML/fr
558 %lang(hu) %doc DOCS/HTML/hu
559 %lang(pl) %doc DOCS/HTML/pl
560 %lang(ru) %doc DOCS/HTML/ru
561 #%lang(zh_CN) %doc DOCS/zh
562 %endif
563 %doc AUTHORS README
564
565 %dir %{_sysconfdir}/%{name}
566 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
567 %{_mandir}/man1/*
568 %lang(cs) %{_mandir}/cs/man1/*
569 %lang(de) %{_mandir}/de/man1/*
570 %lang(es) %{_mandir}/es/man1/*
571 %lang(fr) %{_mandir}/fr/man1/*
572 %lang(hu) %{_mandir}/hu/man1/*
573 %lang(it) %{_mandir}/it/man1/*
574 %lang(pl) %{_mandir}/pl/man1/*
575 #%lang(sv) %{_mandir}/sv/man1/*
576 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
577 %{_desktopdir}/mplayer.desktop
578 %{_pixmapsdir}/mplayer.png
579 %dir %{_datadir}/%{name}
580 %{_datadir}/%{name}/font*
This page took 0.679327 seconds and 4 git commands to generate.